No plug-ins will pass validation (remove property listener?)

Logic Pro X (and older versions) questions and troubleshooting

No plug-ins will pass validation (remove property listener?)

Postby Dynamike » Tue Sep 25, 2012 3:48 pm

Okay, this is strange ..

I gave my iMac a fresh install of OS X Lion and also Logic Pro. Worked with it already but from time to time I want to make a fresh start. I use my iMac only for producing music. For all the other stuff I use a second computer with Windows. This time it took much more time to download and install all the extra packages (like the Jam Packs). I had to restart Logic several times because downloads failed. Anyway, everything must be in the right place now. Here comes the real problem: NO plug-ins will pass the validation!

Yesterday I tried it with my UAD stuff. Nothing. So I thought, maybe I did something wrong. Today I made a fresh install of my iMac and Logic Pro AGAIN. But now I tried it with just 1 plug-in: Microtonic 3. Same problem. The following phrase from the AU validation result shows the same error:

VERIFYING RECOMMENDED PROPERTIES:
VERIFYING PROPERTY: Latency
PASS
ERROR: -2147450878 IN CALL Remove Property Listener
** FAIL

I bought Logic and Microtonic (and also UAD ofcourse) so it must be a problem within Logic or my computer. Tried Google first but wasn't satisfied with the results. :| What does this problem mean and how can I solve it?
Logic Pro 10.0.6 + 9.1.8 (32-bit) * iMac OS X Mavericks 10.9.2 (13C64) * Intel Quad Core i7 - 2.8 GHz * 12 GB 1333 Mhz DDR3 SDRAM * 1TB Serial ATA Harddisk 7200rpm * Apogee Duet 2 * UAD-2 Satellite Duo Core * KRK RP 5 G2 * Sennheiser HD 650
User avatar
Dynamike
 
Posts: 65
Joined: Sun May 20, 2012 3:32 pm
Location: Netherlands

Re: No plug-ins will pass validation (remove property listen

Postby n6smith » Tue Sep 25, 2012 6:17 pm

You may find this thread of interest...

Apparently other plugins are having this issue with Lion.. that results in the plugin in question, needing to updated..

It's worth noting that this is most likely a Lion related issue rather than a Logic issue as validation is actually handled by the OS and not by Logic itself..
Nigel

The Art Of Sound

New Album Tracks available here!

Logic Pro 10.0.1, OS X 10.8.4
iMac 27" i7 3.4Ghz Quad 32GB
2011 MM Server 16GB
2011 MM Server 8GB
Vienna Ensemble Pro 5
Motu UltraLites
Several FW800 Glyphs & A-90EX Keyboard.
User avatar
n6smith
 
Posts: 2713
Joined: Mon Nov 16, 2009 10:13 am

Re: No plug-ins will pass validation (remove property listen

Postby Dynamike » Tue Sep 25, 2012 6:37 pm

Thanks for the reply and link!
But the thing is, everything worked fine (used all plug-ins before).
I did also a fresh install in the summer, with absolutely no problems.
So I don't understand.
Could it be OS updates?
Because it's now 10.7.5 instead of 10.7.4.
If so, is there a possibility to get .4 back?
Logic Pro 10.0.6 + 9.1.8 (32-bit) * iMac OS X Mavericks 10.9.2 (13C64) * Intel Quad Core i7 - 2.8 GHz * 12 GB 1333 Mhz DDR3 SDRAM * 1TB Serial ATA Harddisk 7200rpm * Apogee Duet 2 * UAD-2 Satellite Duo Core * KRK RP 5 G2 * Sennheiser HD 650
User avatar
Dynamike
 
Posts: 65
Joined: Sun May 20, 2012 3:32 pm
Location: Netherlands

Re: No plug-ins will pass validation (remove property listen

Postby n6smith » Tue Sep 25, 2012 7:25 pm

I'm not sure as some people seem to be having this issue with 10.7.4..

Have you checked for any updates for the plugins you are using? Have you contacted the makers of the plugins to see if they have any ideas/solutions as to the cause? Have you recently installed something in the OS (like a program or other software) shortly before you had this issue...that could have changed things somehow...

Did you see that a Programmer said, at the bottom of that thread i linked to... that all the plugins he had written, were having this issue and that he was looking into the cause? Maybe writing to that thread or contacting him.. might give you some further insight as to the root cause.

Finally....Have you tried uninstalling all your 3rd party plugins and testing.. and then installing one at a time and validating to see if it's just one that is causing an issue preventing the rest from validating?
Nigel

The Art Of Sound

New Album Tracks available here!

Logic Pro 10.0.1, OS X 10.8.4
iMac 27" i7 3.4Ghz Quad 32GB
2011 MM Server 16GB
2011 MM Server 8GB
Vienna Ensemble Pro 5
Motu UltraLites
Several FW800 Glyphs & A-90EX Keyboard.
User avatar
n6smith
 
Posts: 2713
Joined: Mon Nov 16, 2009 10:13 am

Re: No plug-ins will pass validation (remove property listen

Postby Dynamike » Wed Sep 26, 2012 5:26 am

1) Yes, for example: I used the last installer from UAD > 6.3.1 August 2012.
2) No, this is also not done (I think) because I use a whole list of plug-ins from several companies. And: all plug-ins worked before.
3) Logic Pro was both times the first program I installed. Before I made a fresh install of my computer there were no issues.
4) Yes, I saw the reply. But that thread has Mainstage as subject so I first chose an alternative way. *
5) I made a clean install twice and both times I checked a plug-in one at a time. No plug-in will validate. Unbelievable.

* I wrote a mail to someone who works for the company where I bought my computer. It's a specialist in Apple audio and helped me before with an Apogee Duet 2 problem.

I go for a third clean install in a few days and won't do a software update (of my computer) before I tested Logic Pro first.
Don't know what to do else. :(
Logic Pro 10.0.6 + 9.1.8 (32-bit) * iMac OS X Mavericks 10.9.2 (13C64) * Intel Quad Core i7 - 2.8 GHz * 12 GB 1333 Mhz DDR3 SDRAM * 1TB Serial ATA Harddisk 7200rpm * Apogee Duet 2 * UAD-2 Satellite Duo Core * KRK RP 5 G2 * Sennheiser HD 650
User avatar
Dynamike
 
Posts: 65
Joined: Sun May 20, 2012 3:32 pm
Location: Netherlands

Re: No plug-ins will pass validation (remove property listen

Postby Dynamike » Wed Sep 26, 2012 5:41 am

Logic Pro 10.0.6 + 9.1.8 (32-bit) * iMac OS X Mavericks 10.9.2 (13C64) * Intel Quad Core i7 - 2.8 GHz * 12 GB 1333 Mhz DDR3 SDRAM * 1TB Serial ATA Harddisk 7200rpm * Apogee Duet 2 * UAD-2 Satellite Duo Core * KRK RP 5 G2 * Sennheiser HD 650
User avatar
Dynamike
 
Posts: 65
Joined: Sun May 20, 2012 3:32 pm
Location: Netherlands

Re: No plug-ins will pass validation (remove property listen

Postby Dynamike » Wed Sep 26, 2012 7:32 am

Back in business!

Problem is OS X update 10.7.5 !!!
Logic Pro 10.0.6 + 9.1.8 (32-bit) * iMac OS X Mavericks 10.9.2 (13C64) * Intel Quad Core i7 - 2.8 GHz * 12 GB 1333 Mhz DDR3 SDRAM * 1TB Serial ATA Harddisk 7200rpm * Apogee Duet 2 * UAD-2 Satellite Duo Core * KRK RP 5 G2 * Sennheiser HD 650
User avatar
Dynamike
 
Posts: 65
Joined: Sun May 20, 2012 3:32 pm
Location: Netherlands

Re: No plug-ins will pass validation (remove property listen

Postby n6smith » Wed Sep 26, 2012 4:12 pm

This thread also contains some clues as to your issues...

viewtopic.php?f=1&t=87772
Nigel

The Art Of Sound

New Album Tracks available here!

Logic Pro 10.0.1, OS X 10.8.4
iMac 27" i7 3.4Ghz Quad 32GB
2011 MM Server 16GB
2011 MM Server 8GB
Vienna Ensemble Pro 5
Motu UltraLites
Several FW800 Glyphs & A-90EX Keyboard.
User avatar
n6smith
 
Posts: 2713
Joined: Mon Nov 16, 2009 10:13 am

Re: No plug-ins will pass validation (remove property listen

Postby Dynamike » Wed Sep 26, 2012 5:24 pm

Seems to be a big issue indeed!
I stay with .4 now.
Don't need those crappy updates anymore.
(or it must be absolutely sure, all problems are solved)
Logic Pro 10.0.6 + 9.1.8 (32-bit) * iMac OS X Mavericks 10.9.2 (13C64) * Intel Quad Core i7 - 2.8 GHz * 12 GB 1333 Mhz DDR3 SDRAM * 1TB Serial ATA Harddisk 7200rpm * Apogee Duet 2 * UAD-2 Satellite Duo Core * KRK RP 5 G2 * Sennheiser HD 650
User avatar
Dynamike
 
Posts: 65
Joined: Sun May 20, 2012 3:32 pm
Location: Netherlands

Re: No plug-ins will pass validation (remove property listen

Postby makkan » Tue Oct 02, 2012 4:44 am

I have the exact same problem!

Got a bunch of plugins from different companies and they all got validated except the ones from Rop Papen...
Got the Explorer Box from them.
So I contacted their support and was asked to download updates and do uninstall and them install uppdates and the same thing just kept happening...

So now I copy and pasted the errormessages to the Rob Papen support and its been almost a week and no word..
I guess I'll just have to wait for a reply, maybe this is a trickier issue then they thought?
Macbook Pro 2.4 Ghz Intel Core i5, 4gb 1333 mhz DDR3, OS X 10.8.2 (12C54)

Logic Pro 9.1.7 32 bit
makkan
 
Posts: 6
Joined: Tue Oct 02, 2012 1:45 am
Location: Stockholm, Sweden

Re: No plug-ins will pass validation (remove property listen

Postby makkan » Tue Oct 02, 2012 8:17 pm

Problem solved thanks to your posts and threads and this site!

Upgraded to Mountain Lion and ALL plugins validated fine!

Thanks for the tips guys! ;))))
Macbook Pro 2.4 Ghz Intel Core i5, 4gb 1333 mhz DDR3, OS X 10.8.2 (12C54)

Logic Pro 9.1.7 32 bit
makkan
 
Posts: 6
Joined: Tue Oct 02, 2012 1:45 am
Location: Stockholm, Sweden

Re: No plug-ins will pass validation (remove property listen

Postby Simon Morrison » Thu Oct 04, 2012 6:24 pm

The AU validation issue introduced in Mac OS X 10.7.5 is resolved by installing the OS X Lion 10.7.5 Supplemental Update (released today): http://support.apple.com/kb/DL1599
Simon Morrison • Music Technologist • Audio Architect
Logic Pro X 10.0.7 | Mac OS X 10.9.4
www.MorrisonStudios.com | www.AudioEngineeringSolutions.com
Simon Morrison
 
Posts: 129
Joined: Sat Apr 09, 2011 12:03 pm
Location: California


Return to Logic Pro X

Who is online

Users browsing this forum: B_Stone, David Nahmani, John Ridout, logic5guy, Matt Mayfield, steve wilson and 41 guests