"Error code -2 was returned by the Audio driver." [SOLVED]

Logic Pro X (and older versions) questions and troubleshooting

"Error code -2 was returned by the Audio driver." [SOLVED]

Postby cptcoconut » Wed Dec 26, 2012 9:46 am

i just got the latest logic pro version and wanted to record some stuff just to test my audio interface and mics. the first thing i did was downloading "additional content",when downloading finished "Error code -2 was returned by the Audio driver." and i ignored it. the next day i wanted to record something and everytime i try to add new track i can only choose "external MIDI" ... i search for help and found some post saying that core audio must be enabled so i checked it . it was enabled so i disabled it,enabled it again and clicked "apply changes" and this "Error code -2 was returned by the Audio driver." pops out ... what is the problem ? is it something wrong with my audio interface ? i think i did everything right installing the driver ... the interface is RME fireface 800. i had already record some stuff using garageband so i assume that there's something wrong with logic . help,please ...
mac os x 10.7.5
Logic pro 9.1.8
cptcoconut
 
Posts: 10
Joined: Wed Dec 26, 2012 9:37 am

Re: "Error code -2 was returned by the Audio driver." pops o

Postby cptcoconut » Fri Dec 28, 2012 3:00 am

problem solved by an accident. i just did an update off my mac and the problem just disappeared.but there's an other thing that annoys me ... when i try to record anything using my interface (and a mic) i can see that LED on interface is working but i can't see (and hear) anything in logic. i am sure that i choose the right input in logic and that i set all the things right(core audio,gain on the interface etc.) . any hints ?
mac os x 10.7.5
Logic pro 9.1.8
cptcoconut
 
Posts: 10
Joined: Wed Dec 26, 2012 9:37 am

Re: "Error code -2 was returned by the Audio driver." [SOLVE

Postby David Nahmani » Fri Dec 28, 2012 9:42 am

Thanks for updating your thread with your solution!

I marked this thread solved, so please start a new thread for your new question, after updating your signature as per our rules: Forum Rules - please READ THIS before posting (#5)

Thank you!
David Nahmani
 Apple Certified Logic Pro Master Trainer
Author of Logic Pro X - Professional Music Production (Apple Pro Training Series)
Logic Pro X 10.0.6 - Mac OS 10.8.4 - Mac Pro 8 core 2.8 GHz Intel Xeon - 6GB RAM - Metric Halo ULN2
User avatar
David Nahmani
Site Admin
Site Admin
 
Posts: 52634
Joined: Fri Mar 04, 2005 11:16 pm
Location: Valley Village, CA


Return to Logic Pro X

Who is online

Users browsing this forum: Google [Bot] and 23 guests