Logic/Mackie Control & Logic 9 - "Save As" Bug

Logic/Mackie Control & Logic 9 - "Save As" Bug

Postby bex » Sat Feb 06, 2010 7:17 am

Hi everyone,

I have recently received an original non Pro Mackie Control Universal and it is working fine with Logic 9.1 except for a slightly odd behaviour with the SAVE and CANCEL buttons and I wonder if anybody else is experiencing this exact issue and has a fix?

What happens is that if I press SHIFT-CMD-S then the 'Save As..' dialog box appears and the MCU shows 'Save - Advanced Options' on the blue screen, 'SAVE' on the LED, the Vpots let me change the save parameters and the ENTER button lets me confirm the save and the CANCEL button lets me cancel out of the dialog box, much as you would expect.

Now the issue I have is that if I press OPTION-SAVE on the MCU itself, the same 'Save As..' dialog box appears, the same display appears in both the Blue and the red displays, but none of the controls of the MCU respond any more?

Pressing the CANCEL button does nothing at this stage but the press is remembered in memory. The only way to close/use the dialog box is to use the keyboard or Mouse. However if I then SHIFT-CMD-S directly after pressing the CANCEL button on the MCU, it cancels straight out of the dialog box as though it has saved the press in memory.

Seems mighty strange to me that the same command should make the unit act a different way depending on where that command came from.

Has anyone else experienced this or can suggest a solution?

thanks all!

oh in case it has any bearing - The MCU is connected via the MIDI port on a Focusrite Saffire Pro 10 I/0 via firewire. cheers
bex
 
Posts: 2
Joined: Sat Feb 06, 2010 6:40 am

 

Postby fader8 » Sat Feb 06, 2010 8:35 am

Confirmed. Logic 9.0.2. I may try later booting the LC's in Logic Control mode as opposed to Mackie Control mode and see if the behaviour is fixed, but I kind of doubt it.
Music helps not the toothache.--George Herbert

G5Quad2.5, LP9.0.2,OSX.5.8,RME Digi&Multiface,002r, 4xUAD-1,Duende PCIe,Unitor8-AMT8,Logic Control+4 LCXT's,Capybara320,Kurz...
fader8
 
Posts: 11330
Joined: Tue Dec 13, 2005 4:46 am
Location: Tampa, Florida

 

Postby bex » Mon Feb 08, 2010 6:40 am

Thanks Fader8,

It's good to know it's a quirk of the setup and not something I could fix by changing key commands.

Hopefully a fix will be forthcoming, but it's not the hardest thing to work around!

all best
bex
 
Posts: 2
Joined: Sat Feb 06, 2010 6:40 am

Logic/Mackie Control & Logic 9 - "Save As" Bug

Postby Nublu » Wed Feb 10, 2010 12:17 am

Hey, Gentlemen,

I too can confirm this quirk. Quirk because the first time I hit the SHIFT-CMD-S I got the weird behaviour.
Then I tried restarting Logic and the MCU and after playing around a bit I hit SHIFT-CMD-S. I didn't get the weird behaviour. I tried this four more times each time trying different combinations of logic operations. I tried it with SHIFT-CMD-Save on the MCU also. It seems pretty normal.... or maybe it's just biding its' time...patiently waiting for the opportune moment.... damn gremlins.
The legend of the people who accidentally wrote really really good songs about me.......
-----------------------------------------
At Play in the Tale of Now.
User avatar
Nublu
 
Posts: 894
Joined: Fri Nov 24, 2006 7:37 pm
Location: Edmonton


Return to Logic 9 Bugs & Workarounds

Who is online

Users browsing this forum: No registered users and 0 guests