A technical support community for Apple Logic Pro users.

Search found 31 matches

  • 1
  • 2
by en5ca
Wed Jun 23, 2021 10:48 am
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

JakHay wrote:
I have the same problem. Can't believe this would be an issue in Logic. :(

Hi! This affects anyone trying to record audio and MIDI at the same time in Logic. Or simply just pays a little closer attention to MIDI recording timings in general.
by en5ca
Tue Jun 08, 2021 1:33 am
Forum: Logic Pro Bugs & Workarounds
Topic: Plug-in Delay Compensation broken with external side-chain
Replies: 212
Views: 54866

Re: Plug-in Delay Compensation broken with external side-chain

dear I am having this problem even today with logic 10.6.2, while sidechaining vocal on the synths bus with track spacer 2.5 can someone advise and I wish to know whether it has been resolved or not It seems the base case of two tracks side-chained to each other has been solved when no bussing is i...
by en5ca
Wed May 05, 2021 9:20 am
Forum: Logic Pro Bugs & Workarounds
Topic: Plug-in Delay Compensation broken with external side-chain
Replies: 212
Views: 54866

Re: Plug-in Delay Compensation broken with external side-chain

Hope the fix works, i'm using Ableton Live right now and while PDC is top notch, the one second delay (even at buffer 128) everytime i press PLAY is really killing the vibe. I think that is the unfortunate side effect of the buffering required for PDC to be done properly in case of latency inducing...
by en5ca
Tue May 04, 2021 7:43 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

I have a problem with audio/midi recording sync, but I'm not quite sure whether it is the same problem as described here. I'm doing live multitrack recording of the whole band, including the audio outputs of the electronic drum kit, 8 tracks total. At the same time, I'm recording the MIDI of the dr...
by en5ca
Sun Mar 07, 2021 3:10 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

To sum it up, It seems that the only case when recording timing is correct, is when recording only audio with external zero latency monitoring. MIDI will always get compensated for latency, but not the exact amount, whether it is monitored or not, resulting in offset between MIDI and audio recording...
by en5ca
Sun Mar 07, 2021 2:35 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

Yes I agree completely. What I have found is when my buffer is at 1024 the midi fires early and my audio ends up early (from the real time bounce of my external synth). But when my audio buffer is 32 the midi fires late and thus the audio is late. I found 128 to be the sweet spot which gets it pret...
by en5ca
Sun Mar 07, 2021 2:05 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

Its really a simple fix that took me a better part of 2 hours to figure out. Slide the "recording delay" slider to 0. I think by default it's set to -5000. Before i did this, all of my audio tracks were appearing way earlier than they were tracked. Hi! Unfortunately that does not solve th...
by en5ca
Sun Jan 03, 2021 4:43 am
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

Interesting. Yes I have noticed that when I switch the buffer from 1024 (I always record in Low Latency mode) to 64 the audio ends up being late and not early. This is irrelevant of low latency/software monitoring being enabled/disabled. I will play with the buffer in between the two values I menti...
by en5ca
Thu Dec 31, 2020 1:15 am
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

This is a bummer guys. I just got a Jupiter X and having a blast but everytime I bounce the midi the audio is early and I have to cut at first transient then move it to the downbeat. It is interesting how you cannot uncheck the Auto-compensate latency box in the external instrument window as per th...
by en5ca
Mon Nov 16, 2020 7:23 pm
Forum: Logic Pro
Topic: 10.6.0 and low latency mode out of sync?
Replies: 12
Views: 1507

Re: 10.6.0 and low latency mode out of sync?

This version is the only time I’ve noticed it. Well certainly on my system Just tested with Logic Pro X 10.4 also. Same behaviour/bug is present, so downgrading to 10.5 wont probably help. I happen to have this version still installed in my live rig laptop, which is when I ran into this, and switch...
by en5ca
Mon Nov 16, 2020 4:55 pm
Forum: Logic Pro
Topic: 10.6.0 and low latency mode out of sync?
Replies: 12
Views: 1507

Re: 10.6.0 and low latency mode out of sync?

hmowday wrote:
That seems to be the same sort of experience I’m having. I’ll try and replicate it on some other sessions too. Unfortunately just too busy. Is there a way to get logic 10.5 again if I hadn’t backed up the application?


This has been the case from at least Logic Pro 10.2 or something.
by en5ca
Mon Nov 16, 2020 6:30 am
Forum: Logic Pro
Topic: 10.6.0 and low latency mode out of sync?
Replies: 12
Views: 1507

Re: 10.6.0 and low latency mode out of sync?

i experienced that on 10.5 twice. i couldn't replicate it :/ This seems to work very weirdly. Empty project. Put 4 linear phase EQs on Stereo Out, and record MIDI for some simple software synth/drum or something similar. At 120 BPM you have around 1/8th latency. The recorded MIDI notes get placed p...
by en5ca
Fri Nov 13, 2020 2:19 am
Forum: Logic Pro Bugs & Workarounds
Topic: Plug-in Delay Compensation broken with external side-chain
Replies: 212
Views: 54866

Re: PDC broken with external side-chain

lagerfeldt wrote:
I don't see this bug mentioned in the new 10.6 release?

I can't test for myself since I'm not going to switch to Catalina (from Mojave) right now, and 10.6 is ≥Catalina only.


It is still there.
by en5ca
Thu Nov 12, 2020 5:14 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

Sadly, no luck with Logic Pro 10.6. Yet, stated at their website that:
Full plug-in latency compensation, also for external audio and MIDI gear
by en5ca
Fri Oct 30, 2020 11:54 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

I might have the same problem. ... I guess this is just a 'feature' in Logic, and perhaps overlooked in design. Audio recording timing isn't compensated for monitoring latency, and ends up placed too early on timeline. MIDI recordings seem to get some compensation (even when they shouldn't), but ~1...
by en5ca
Mon Oct 26, 2020 7:31 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Plug-in Delay Compensation broken with external side-chain
Replies: 212
Views: 54866

Re: PDC broken with external side-chain

Noticed that Plugin (or any) Delay Compensation isn't applied when monitoring input (audio or MIDI). This made me think that the PDC on Logic might not be done at 'online' or 'audio engine runtime' level, but is simply done by adjusting the read timing of channel source data, so that eventually chan...
by en5ca
Sun Oct 25, 2020 8:23 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

Still no luck with this. It seems that Logic places audio recording in the absolute audio interface AD input time position. Meaning, when using software monitoring, the audio recording position is off by the negative amount of total roundtrip latency. Oddly, enabling or disabling software monitoring...
by en5ca
Sat Oct 24, 2020 9:40 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

Wild guess: have you tried disabling Plug-in Latency Compensation during the recording? screen.png Updated the opening post with a video and a more detailed explanation. I don't think this is directly related to the Plugin Delay Compensation problem, as the offset between audio and MIDI happens wit...
by en5ca
Fri Oct 23, 2020 7:23 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

Wild guess: have you tried disabling Plug-in Latency Compensation during the recording? Tried, it has no effect. Turning Software Monitoring On or Off, or using Low Latency Mode has no effect. Audio and MIDI signals are in sync when monitoring through Logic. No problem there. During recording, MIDI...
by en5ca
Fri Oct 23, 2020 6:57 pm
Forum: Logic Pro Bugs & Workarounds
Topic: Audio and MIDI not recording in sync
Replies: 24
Views: 6323

Re: Audio and MIDI not recording in sync

I think that's how Logic compensates for the plug-in latencies . That is not the issue. For example: If I use the incoming MIDI message to trigger a kick sample, it's in perfect sync with the incoming audio, when monitoring the audio through Logic. Meaning the latency compensation works. EDIT: But ...
  • 1
  • 2