A technical support community for Apple Logic Pro users.

Search found 196 matches

  • 1
  • 2
  • 3
  • 4
  • 5
  • 10
by Christopher11
Thu Jul 09, 2020 3:25 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

I created a device and named it Keystation 88 in Audio MIDI Utility. It's just that MIDI Monitor, the app I downloaded, doesn't see it. Apps like LPX and Garage Band see when I connect the m-audio keyboard, but they don't respond to anything I play. I can certainly try another cable. I suspect it's ...
by Christopher11
Thu Jul 09, 2020 7:21 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

So you can see the m-audio in there ? Does it look connected ? Hey Jakob. Thank you for asking. No, unfortunately, MIDI Monitor sees MIDI data from my Korg M3; it does not even see the m-audio. Logic does not see the m-audio either, despite that I hook that up directly via USB (not the RME interfac...
by Christopher11
Sat Jul 04, 2020 11:54 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

And snoizes midi monitor shows note events coming in from the m-audio ? Actually, no! Although it sees everything from the Korg via MIDI>RME 802. Midi Monitor doesn't see anything from the M-Audio plugged in directly to the computer via USB. It did on my old machine. I wonder if I need to configure...
by Christopher11
Fri Jul 03, 2020 10:51 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

I'm thrilled to finally have my Korg M3 working, but I wonder why hooking up the M-Audio Keystation 88 via USB still does not work. Logic warns me when I plug it in and unplug it of 'Changed Number of MIDI inputs' etc, but won't respond to or see any MIDI events via USB.
by Christopher11
Thu Jul 02, 2020 7:10 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

why did disabling control surfaces work? The bypass is probably stopping conflicting controller messages from lingering MIDI drivers or corrupt preferences. . That's exactly what I thought might be the case... especially since it felt like a MIDI instrument getting overwhelmed and confused. I wonde...
by Christopher11
Thu Jul 02, 2020 3:40 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

Clearly you are right, since disabling as Jakob suggested worked. It also caused my Korg M3 to now work properly as a controller in Logic, or I should say, Logic to respond properly to it. Because it was down to just notes and pitch bend; Logic would not respond to mod wheel or aftertouch. I wonder ...
by Christopher11
Thu Jul 02, 2020 2:38 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

As a troubleshooting step, does it work if you go Logic Pro X > Control Surfaces > Bypass All Control Surfaces ? You know what? That made a huge difference! It is not perfect, but much better, and able to track notes, and sees my mod wheel and after touch as well! Which it hasn't been for months, e...
by Christopher11
Thu Jul 02, 2020 11:28 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

I used my older MB Pro to update to Logic Pro X 10.4.1. I transferred to this machine, and I really like it. It's fast, and everything works perfectly except the MIDI. It still tracks extremely slowly, like it can't keep up, so notes are too long, and it misses most of them. I can't work if I can't...
by Christopher11
Thu Jul 02, 2020 9:38 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

I used my older MB Pro to update to Logic Pro X 10.4.1. I transferred to this machine, and I really like it. It's fast, and everything works perfectly except the MIDI. It still tracks extremely slowly, like it can't keep up, so notes are too long, and it misses most of them. I can't work if I can't ...
by Christopher11
Thu Jul 02, 2020 9:05 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

I've had nothing but trouble with recent Korg midi drivers. Did you install any midi drivers for your M3? Korg has a proper uninstaller that you could use to test. could help you troubleshoot your issue. Blink Hey blinkofani, I uninstalled Korg USB-MIDI drivers. Then I downloaded and am about to in...
by Christopher11
Wed Jul 01, 2020 7:29 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

blinkofani wrote:
I've had nothing but trouble with recent Korg midi drivers. Did you install any midi drivers for your M3? Korg has a proper uninstaller that you could use to test. could help you troubleshoot your issue.

Blink


That's a great idea. I will try to find that, uninstall and start fresh.
by Christopher11
Wed Jul 01, 2020 7:27 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

triplets wrote:
Christopher11 wrote:
Do you need the app store to update? Or can I do it from within Logic?


Yes, sign in and click update.


Thank you sincerely, but I'm not quite sure what you mean. Do you mean I can do it from Logic? Thanks so much for any reply.
by Christopher11
Wed Jul 01, 2020 12:11 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

Oh I can make a copy of it!? That's a fantastic feature. Control Click, will do. Do you need the app store to update? Or can I do it from within Logic?
by Christopher11
Wed Jul 01, 2020 12:00 pm
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

Unfortunately, Logic still does not respond correctly to MIDI. It really is as if Logic gets 'stuck' on certain notes, and then can't respond to or track additional ones.
by Christopher11
Wed Jul 01, 2020 11:44 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

This program works great. Thank you. MIDI Monitor seems to be seeing all of my MIDI actions, including after touch and mod wheel, etc. I can't tell if it's skipping notes or responding the way Logic did, because there's no sound module, but it looks tight. Several programs have suggested I delete ol...
by Christopher11
Wed Jul 01, 2020 11:16 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Re: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

I didn't yet, it's still 10.2.6. I was looking forward to that, and the new features, but I'm only into my first day on this new machine. After migrating all my apps and profile, I wanted to make sure everything worked. Do you think that's the issue, and doing so will fix this MIDI problem?
by Christopher11
Wed Jul 01, 2020 10:34 am
Forum: Logic Pro X
Topic: Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.
Replies: 32
Views: 1039

Bought 2015 MB Pro 2.8ghz. Love it but MIDI not working properly.

Hello friends and Logic pros. I am so pleased to have migrated to a more powerful and lighter machine: from my 2012 MB Pro I migrated to a 2015 MB Pro 15 2.8ghz, with 16 GB of RAM and a 2 TB SSD installed. It came with Mojave OS. Logic opened and plays fine; works perfectly with a FW to Thunderbolt ...
by Christopher11
Thu May 28, 2020 10:29 pm
Forum: Logic Pro X
Topic: Considering 2015 Macbook Pro 15 3.4 Ghz Quad Core
Replies: 4
Views: 211

Re: Considering 2015 Macbook Pro 15 3.4 Ghz Quad Core

I had paid around 1200. I don't mind getting another Mac Pro. I just prefer it is a little newer, and hopefully with a little more CPU power. I need a laptop anyway. I do editing and writing professionally, and need a good Macbook. The one I have now is getting old, and the ASDF keys do not work. Th...
by Christopher11
Thu May 28, 2020 7:19 pm
Forum: Logic Pro X
Topic: Considering 2015 Macbook Pro 15 3.4 Ghz Quad Core
Replies: 4
Views: 211

Considering 2015 Macbook Pro 15 3.4 Ghz Quad Core

I am considering this computer to replace my 2012 MB Pro 15. It doesn't have quite enough juice for my processing needs. I tried a 2010 Mac Pro but sent it back. It was too old and didn't have the graphics card with 'metal' that I needed. I will always need a laptop anyway for various other work I d...
by Christopher11
Sun May 24, 2020 7:56 pm
Forum: Logic Pro X
Topic: Considering 2010-2012 Mac Pro to Upgrade LPX Processing Power
Replies: 41
Views: 1081

Re: Considering 2010-2012 Mac Pro to Upgrade LPX Processing Power

What if I want to install this new, exciting version of Logic, with Sampler, etc? Can that run on High Sierra? You need Mojave for Logic 10.5 High Sierra goes up to 10.4.8 The interesting thing that happened when I upgraded my Mac Pro with a metal capable graphics card to update to Mojave, the CPU ...
  • 1
  • 2
  • 3
  • 4
  • 5
  • 10