Jump to content

Midi regions that automatically expand...


JimmyJ
 Share

Recommended Posts

Hey everyone,

 

So, I have had this ongoing annoying issue for a while that I have been trying to figure out. At this point I could really use some help..

 

when I am in piano role playing with midi, perhaps I will add something towards the end of the region and then several bars will automatically be added to the region. overlapping whatever other regions that were in those bars... the midi regions that I am usually spending time with are often actually smaller parts of larger regions that I have shortened, then when I am working they automatically expand and it can lead to some really annoying issues.. I am sure there has got to be some kind of setting to adjust for this and I have tinkered in my preferences and project settings, but can't figure out how to fix it. My goal iis for no midi region to ever expand unless I tell it to.Thanks in advance for your input.. J

Link to comment
Share on other sites

Wild guess here:

have you tried with No Overlap setting and Region border trimming?

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

Not sure if this will work for you as a workaround but, have you tried using cycle recording? Then instead of adding space to regions it will cycle back to beginning. Once it cycles to the beginning if you don’t enter any more notes it won’t alter the beginning (add too/replace/etc.)

 

Set cycle manually or you can also select region(s) and ‘set cycle locators by region’.

LPX 10.4.5; OS 10.14.5; iMac I5/2.9GHz, 16 GB RAM; SSD; Saffire Pro24: Scarlett 2i2; AxiomPro61

Misc: iControl; Denon MC600

Link to comment
Share on other sites

Hello everyone, I haven't posted here before.

 

I have that problem too.

 

It happens when I drag-copy a note within the region and then the region will expand to the next bar. It doesn't matter if the note copied is in the middle or at the beginning of the region, the behavior is the same.

 

This doesn't happen if I change the pitch of an existing note in the region or use the draw-tool from the Command-click Tool menu to add a note, in this case the region will be unchanged.

 

I, often, have regions that are uneven in length, like 11/8 or 7/8 for example, while the main time signature in Logic is set to 4/4. It seems like this behavior came in one of the latest versions of Logic X, I assume that this is a bug and it's extremely annoying as it is now.

Logic X 10.4.6, OSX 10.14.6, iMac 27 Late 2014, i7 4 GHz, UAD Apollo Twin.
Link to comment
Share on other sites

  • 2 years later...
Hi - reviving this thread in the hopes that ny solutions have been discovered to this? I'm having a similar issue where I record a new midi segment on a region, and then it automatically extends 8 measures prior to the region and records over everything that came before it. I've checked all my settings and nothing looks off. It's super frustrating. Thanks for any help!
Link to comment
Share on other sites

  • 4 weeks later...

Similar behavior just started for me too. On any track suddenly in a project that was fine until 10 minutes ago, any time I record a new midi region it automatically extends back to one particular place in the song in my case. If I record a new midi region before that place in the song everything is fine. So there is now just this special measure / magic place in the song that all new regions insist on extending back to, on all tracks. Turning on a cycle changes nothing. Strangely, if I start the transport playing first and then hit record, this does not happen. Also, it does not happen with audio regions. Is there a setting somewhere for this bizarre behavior? I changed nothing?

 

One final thing here, if I start recording a new region anywhere past this "magic measure" but don't play any notes at all (and no CCs), stopping the transport creates a small ghost region 1 bar in length back at that magic measure. But there's now no region to join back to it since I played nothing. I can be 2000 measure to the right of that place, but still I'll get that small 1 bar empty measure created back there. If I were to have played something then I would have gotten a region 2000 measures long connected back.

Link to comment
Share on other sites

Similar behavior just started for me too. On any track suddenly in a project that was fine until 10 minutes ago, any time I record a new midi region it automatically extends back to one particular place in the song in my case.

Can you save a copy of that project, and in the copy, delete all tracks but that one, and attach that project here? How to attach files to your post

My new book on Logic Pro is out!

Link to comment
Share on other sites

Sure. However, it's not just on one track. It's on all software instrument tracks.

 

And I have found a fix for the problem. After deleting regions on multiple tracks I found that there is one offending region on one track which causes the behavior on all tracks. Every new region on every track that you create extends back to where that one region on that one track ends. Delete that one region and all is well.

 

But it is an interesting bug that you'll want to check out. I'm curious if you can replicated it. I'm on 10.7.2 BTW on an M1 running Logic as Apple Silicon Native in Big Sur.

 

I've included the project file (all audio and data removed from the package) with just that one problematic region left on a drum track. There are detailed notes in the Project Notes section on how to recreate the issue. BTW, this is a long project so we are talking about measure 3480 and beyond. Thanks for looking at it.

 

Project attached as a zip file.

LogicRecRegionIssueClean.logicx.zip

Link to comment
Share on other sites

You can work around this bug by switching Chase off for Sustain events (cc#64) in the project settings. Or delete all Sustain events from the region that causes this. Or mute the region before you start recording. Or wait for a Logic version which fixes this bug.

1997894976_Screenshot2022-01-21at22_01_11.thumb.png.4521ee31868e7b9a592236e3fd07a44b.png

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

Alright. Plenty of options there. I got around it by just removing the region. But it's good to know that there is indeed something buggy here. I wonder if Apple's Logic team is aware of this issue.
Link to comment
Share on other sites

I've included the project file (all audio and data removed from the package) with just that one problematic region left on a drum track. There are detailed notes in the Project Notes section on how to recreate the issue. BTW, this is a long project so we are talking about measure 3480 and beyond. Thanks for looking at it.

 

Project attached as a zip file.

Thank you for providing a project like this with clear easy steps to reproduce the issue. I was able to reproduce this bug. I will move this to the Bug section and report this bug to Apple as well.

My new book on Logic Pro is out!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...