Jump to content

Step FX driving Stereo Out clipping


lennylavida
 Share

Recommended Posts

Hi!

 

First started noticing this in Logic 10.6.0 and it is still present in current version 10.7.2.

 

Anyways... when I use a native plugin called Step FX on a project everything works well until I re-open the same project the next day. I get a clipping Stereo Out bus, but not from the very beginning of the project. Usually few bars are playable and then suddenly Stereo Out is heavily clipping and from an oscilloscope I can see that output is offset to negative (bottom) side of the oscilloscope. Only way from there on is to close Logic and after re-opening mute or delete all instances of Step FX. Maybe there is a better workaround of a fix for this?

 

Issue is present on Mac Pro 5.1 (4.1) using RME Raydat (pcie) and Macbook Pro M1 Max using Antelope Audio Zen Q SC over thunderbolt so I can´t blame my Mac Pro being too old.

P.S pardon me English, not a native speaker.

Macbook Pro M1 Max, MacOS 12.2, Logic Pro X 10.7.2, Antelope Zen Q SC
Link to comment
Share on other sites

Can you share a screen recording? It's hard to fully understand what's happening.

Is that only happening on a specific project? Have you tried the same on a new project?

If that's only on that project, maybe some kind of automation is happening that suddenly changes any parameter that causes that? Just wild guesses...

Danny Wyatt (formerly known as 3ple here on the forum)
Musician, Music Producer, Songwriter, DJ

• Logic Pro 10.6.3
• M-Audio Fast Track Pro 4x4
• MacBook Pro 13" Mid 2012 || 2.5 GHz Dual-Core Intel Core i5 || 8GB 1600 MHz DDR3 RAM
• macOS Catalina 10.15.7

Official Website: http://www.iamdannywyatt.com (links to all my social media included)
Join my Discord: https://dwyatt.me/discord

Link to comment
Share on other sites

Hi, Danny!

 

Thank you for your interest.

Here is a quick screen recording with an oscilloscope to demonstrate that track meters are all active including Stereo Out but sound is all muted. I was unable to catch the very moment it went inaudible as the moment is hardly predictable, but recorded the aftermath. You can see that deactivating the Step FX instance doesn´t help although on few occasions it has. Also not a single automation is even drawn/recorded to the track with Step FX. It happens on all projects I include Step FX and the problem is still present even when I import all data to a new project file.

 

Macbook Pro M1 Max, MacOS 12.2, Logic Pro X 10.7.2, Antelope Zen Q SC
Link to comment
Share on other sites

Hi, Danny!

 

Thank you for your interest.

Here is a quick screen recording with an oscilloscope to demonstrate that track meters are all active including Stereo Out but sound is all muted. I was unable to catch the very moment it went inaudible as the moment is hardly predictable, but recorded the aftermath. You can see that deactivating the Step FX instance doesn´t help although on few occasions it has. Also not a single automation is even drawn/recorded to the track with Step FX. It happens on all projects I include Step FX and the problem is still present even when I import all data to a new project file.

 

 

I was looking at the video, but not only the screen you have is huge and it's barely visible what is what (even on full screen mode), but I can't truly understand what happened. I saw the Stereo Output stopped displaying any meter action... is that the issue?

 

Are you able to share the project?

Create a copy, remove all audio and MIDI regions. Also, remove all audio from the project itself (right sidebar) to make it easier to share.

Let me test it here and see if I can understand what's happening.

Danny Wyatt (formerly known as 3ple here on the forum)
Musician, Music Producer, Songwriter, DJ

• Logic Pro 10.6.3
• M-Audio Fast Track Pro 4x4
• MacBook Pro 13" Mid 2012 || 2.5 GHz Dual-Core Intel Core i5 || 8GB 1600 MHz DDR3 RAM
• macOS Catalina 10.15.7

Official Website: http://www.iamdannywyatt.com (links to all my social media included)
Join my Discord: https://dwyatt.me/discord

Link to comment
Share on other sites

  • 1 month later...

Hi there,

 

I believe I'm having the same issue.

 

I've been trying to use a Step FX plugin on a couple audio tracks in one of my sessions. When I start playing back the audio with the plugin on, everything is fine for a few seconds and then all the audio cuts out and a short and sharp clipping sound is heard. The playhead keeps moving, and the individual track faders keep showing levels, but the stereo output fader shows no levels. In addition, the performance meters in the control bar show nothing to indicate that the computer is struggling at all. When I pause, and disable the plugin, everything works again. If I then activate the plugin again, the same clipping is heard again.

 

I've tried opening a new, empty project, to see how the plugin fares there and it resolves the issue completely, and I should mention that the session I'm working in is quite large, but without the Step FX on, everything works smoothly. I have a hard time believing that this is a simple matter of processing power. But then again, what do I know. It makes me wonder whether it's possible that logic is muting the output as a sort of protective measure...

Link to comment
Share on other sites

Hi there,

 

I believe I'm having the same issue.

 

I've been trying to use a Step FX plugin on a couple audio tracks in one of my sessions. When I start playing back the audio with the plugin on, everything is fine for a few seconds and then all the audio cuts out and a short and sharp clipping sound is heard. The playhead keeps moving, and the individual track faders keep showing levels, but the stereo output fader shows no levels. In addition, the performance meters in the control bar show nothing to indicate that the computer is struggling at all. When I pause, and disable the plugin, everything works again. If I then activate the plugin again, the same clipping is heard again.

 

I've tried opening a new, empty project, to see how the plugin fares there and it resolves the issue completely, and I should mention that the session I'm working in is quite large, but without the Step FX on, everything works smoothly. I have a hard time believing that this is a simple matter of processing power. But then again, what do I know. It makes me wonder whether it's possible that logic is muting the output as a sort of protective measure...

 

So you're saying that this only happens on that particular project?

If possible, share that project here by removing all midi and audio regions (including all audio from the Audio Files folder), make sure you then use the Clean Up feature (File > Project Management > Clean Up.

NOTE: create a backup first!!! ;)

 

I will be happy to check the project and see if I experience the same and if so, if I can understand the issue.

Danny Wyatt (formerly known as 3ple here on the forum)
Musician, Music Producer, Songwriter, DJ

• Logic Pro 10.6.3
• M-Audio Fast Track Pro 4x4
• MacBook Pro 13" Mid 2012 || 2.5 GHz Dual-Core Intel Core i5 || 8GB 1600 MHz DDR3 RAM
• macOS Catalina 10.15.7

Official Website: http://www.iamdannywyatt.com (links to all my social media included)
Join my Discord: https://dwyatt.me/discord

Link to comment
Share on other sites

Here's the session file. Completely cleaned

 

 

I guess the track you are having issues with is the "rev gtr chord 1", right?

Danny Wyatt (formerly known as 3ple here on the forum)
Musician, Music Producer, Songwriter, DJ

• Logic Pro 10.6.3
• M-Audio Fast Track Pro 4x4
• MacBook Pro 13" Mid 2012 || 2.5 GHz Dual-Core Intel Core i5 || 8GB 1600 MHz DDR3 RAM
• macOS Catalina 10.15.7

Official Website: http://www.iamdannywyatt.com (links to all my social media included)
Join my Discord: https://dwyatt.me/discord

Link to comment
Share on other sites

Ok so here's what I tried to make it work and so far so good:

Add another audio track, move all plugins (except the Step FX) and regions, automation, etc. Do it manually, don't just duplicate the track.

Add a new instance of Step FX.

Recreate all the settings on that second version, but avoid using the Copy - Paste feature. I don't know if there's something weird happening when you do that, but try to just do it manually one by one.

Delete the original track.

For some weird reason, that original instance (or even the insert slot itself) is buggy.

 

Let me know if that solved the problem for you.

Danny Wyatt (formerly known as 3ple here on the forum)
Musician, Music Producer, Songwriter, DJ

• Logic Pro 10.6.3
• M-Audio Fast Track Pro 4x4
• MacBook Pro 13" Mid 2012 || 2.5 GHz Dual-Core Intel Core i5 || 8GB 1600 MHz DDR3 RAM
• macOS Catalina 10.15.7

Official Website: http://www.iamdannywyatt.com (links to all my social media included)
Join my Discord: https://dwyatt.me/discord

Link to comment
Share on other sites

I just updated my original post. Please check it again

Danny Wyatt (formerly known as 3ple here on the forum)
Musician, Music Producer, Songwriter, DJ

• Logic Pro 10.6.3
• M-Audio Fast Track Pro 4x4
• MacBook Pro 13" Mid 2012 || 2.5 GHz Dual-Core Intel Core i5 || 8GB 1600 MHz DDR3 RAM
• macOS Catalina 10.15.7

Official Website: http://www.iamdannywyatt.com (links to all my social media included)
Join my Discord: https://dwyatt.me/discord

Link to comment
Share on other sites

  • 2 months later...

Hi!

Sorry for being away for such a long time. I´m having issues with Step FX quite frequently and so far gotten much help from the duplicating method from Danny with a simpler approach. I simply drag the buggy instance of Step FX to another track and insert a new instance of Step FX to the original spot where I dial back the settings. After that I simply delete the moved instance and it's all good.

Macbook Pro M1 Max, MacOS 12.2, Logic Pro X 10.7.2, Antelope Zen Q SC
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...