A technical support community for Apple Logic Pro users.

 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Tue Sep 01, 2015 9:55 am

You da man, Eric! 10.2 is running on a new adm. acct. Now what? Should it be OK on my usual acct. or do I have to do something else to ensure that? Is there still troubleshooting to be done? Do I make this new account my regular one and go from their?
Thanks
Dan
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Tue Sep 01, 2015 1:16 pm

Well, it still crashes on my regular account. That answers that question. What next?
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Thu Sep 03, 2015 12:39 pm

I feel like I'm on the edge of getting this solved. 10.2 will work on a different user account, but not my usual one. How do I go about troubleshooting from here?
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Eric Cardenas
Moderator
Posts: 22735
Joined: Sat May 07, 2005 1:47 pm
Location: Uppsala, Sweden

Re: Crashing after update

Thu Sep 03, 2015 12:45 pm

Hi Georg!

This means that there is something not right in your user folder.
Try this:
    
  • Quit Logic Pro X.
  • Move the ~/Music/Audio Music Apps folders to the trash, do not empty it yet.
  • Launch Logic Pro X again.
Eric Bradley Cardenas
EC Making Sound
Mac mini 2.6 GHz 16GB RAM Areca⚡RAID | MacBook Pro 2.3 GHz 16GB RAM | Os 10.14.5
Logic Pro 10.4.5 | RME Fireface UFX | Adam A7 + Sub8 | Spectrasonics | Softube
 
User avatar
des99
Posts: 3587
Joined: Tue Jan 27, 2015 12:08 pm

Re: Crashing after update

Thu Sep 03, 2015 1:17 pm

Most likely a permissions problem...
mu:zines | music magazine archive | difficultAudio
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Thu Sep 03, 2015 2:47 pm

Moved that folder to trash - 10.2 still crashes while "gathering info about plug-ins". Already repaired permissions a couple times during this whole episode. Do you want to see crash log?
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Eric Cardenas
Moderator
Posts: 22735
Joined: Sat May 07, 2005 1:47 pm
Location: Uppsala, Sweden

Re: Crashing after update

Thu Sep 03, 2015 11:06 pm

No, there is no need for more crash logs.
It can be, as des says, some of the permissions that are not correctly configured in you user folder.
It can also be other stuff on your account that don't play right with Logic.

Since it appears to crash while checking plugins it could be something in your user plug-in folder.
Navigate to [YOURUSER]/Audio/Plug-ins/Components. Do you have anything there?
Eric Bradley Cardenas
EC Making Sound
Mac mini 2.6 GHz 16GB RAM Areca⚡RAID | MacBook Pro 2.3 GHz 16GB RAM | Os 10.14.5
Logic Pro 10.4.5 | RME Fireface UFX | Adam A7 + Sub8 | Spectrasonics | Softube
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Fri Sep 04, 2015 9:58 am

That folder has:
EZDrummer....EZPlayer....Kontakt5(player)....StylusRMX....SuperiorDrummer....Trilian....23 assorted Michael Norris effects.....MSED
Curiously, no Omnisphere, but that is in the systems' plug-in components folder.
I tried once launching 10.2 with all the MN components in the disabled folder - still crashed. I don't know what MSED component is, but I put it in the disabled folder - still crashed.
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Eric Cardenas
Moderator
Posts: 22735
Joined: Sat May 07, 2005 1:47 pm
Location: Uppsala, Sweden

Re: Crashing after update

Fri Sep 04, 2015 10:11 am

Create a temporary Disabled-plug folder on the desktop and move all these plugins to this folder instead.
Make sure that it is empty then launch Logic.
Eric Bradley Cardenas
EC Making Sound
Mac mini 2.6 GHz 16GB RAM Areca⚡RAID | MacBook Pro 2.3 GHz 16GB RAM | Os 10.14.5
Logic Pro 10.4.5 | RME Fireface UFX | Adam A7 + Sub8 | Spectrasonics | Softube
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Fri Sep 04, 2015 11:58 am

Put all plug-in components from user/audio/plug-ins/components folder into a folder on the desktop. Shut down the computer. Restarted a few minutes later. Tried opening 10.2 - same crash.
Thanks for sticking with me, Eric. Very frustrating for me.
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Eric Cardenas
Moderator
Posts: 22735
Joined: Sat May 07, 2005 1:47 pm
Location: Uppsala, Sweden

Re: Crashing after update

Fri Sep 04, 2015 3:03 pm

So the user plug-in folder is clean now.
That's good.
Try deleting this file, also indoor user folder:
~/Library/Caches/com.apple.audiounits.cache

See if there is any progress.
Eric Bradley Cardenas
EC Making Sound
Mac mini 2.6 GHz 16GB RAM Areca⚡RAID | MacBook Pro 2.3 GHz 16GB RAM | Os 10.14.5
Logic Pro 10.4.5 | RME Fireface UFX | Adam A7 + Sub8 | Spectrasonics | Softube
 
User avatar
Eric Cardenas
Moderator
Posts: 22735
Joined: Sat May 07, 2005 1:47 pm
Location: Uppsala, Sweden

Re: Crashing after update

Fri Sep 04, 2015 3:09 pm

I would also try this if you still have issues:

Hold down Control when launching Logic Pro X and choose to not launch the Core Audio driver when prompted.
Eric Bradley Cardenas
EC Making Sound
Mac mini 2.6 GHz 16GB RAM Areca⚡RAID | MacBook Pro 2.3 GHz 16GB RAM | Os 10.14.5
Logic Pro 10.4.5 | RME Fireface UFX | Adam A7 + Sub8 | Spectrasonics | Softube
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Sat Sep 05, 2015 12:31 am

Hmmm, I got rid of that plug-in cache and still crashed. Launched without the audio driver and it came up !
Now, is this the driver for the RME ff800? When the crashing first started, one of first things I did was check for updated drivers. Found RME had one and I installed it. I am now running version 3.27.
What to do ?
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Mon Sep 07, 2015 11:41 pm

Sorry for the bump, but feeling a little lonely on page 3.
I've tried re-installing the RME driver and still no luck. When I get 10.2 to launch, without the core audio driver, I tried setting the audio preferences to built-in speakers/mic. When I hit "apply changes" it crashes.
I'm at a loss of what or how to troubleshoot next. Any ideas?
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Eric Cardenas
Moderator
Posts: 22735
Joined: Sat May 07, 2005 1:47 pm
Location: Uppsala, Sweden

Re: Crashing after update

Mon Sep 07, 2015 11:53 pm

I don't believe that this is driver related.
It looks like it can be related to the plug-ins on your user folder or the permissions on that folder.

Something is not right with your user account.
You could try and troubleshoot this further but it has already wasted many days of your life.
I would use the new account instead. Move all your important data there and make it the default.
Eric Bradley Cardenas
EC Making Sound
Mac mini 2.6 GHz 16GB RAM Areca⚡RAID | MacBook Pro 2.3 GHz 16GB RAM | Os 10.14.5
Logic Pro 10.4.5 | RME Fireface UFX | Adam A7 + Sub8 | Spectrasonics | Softube
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Tue Sep 08, 2015 11:43 am

Thank you for your efforts, Eric. Not the answer I wanted to hear, but sort of expected.
I did not look forward to transferring all important data to the new user account, so I thought I'd use the fast-switching idea, and just log-on to use Logic. Started with this idea and was confronted with alerts to re-register software and NI libraries.......
So, I'm sticking with 10.1.1 on my usual user/account. Maybe there will be a 10.2.1 in the near future that addresses my rare (but not unique) problem. Maybe somebody at Apple will look at my two dozen crash reports and tell me what is wrong. Maybe when I can get to my Disc Warrior stuff (I'm in temporary digs till I move in November) I can get a more thorough permission repair done.
No complaints with 10.1.1 - just disappointed I can't get at the new stuff.
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
User avatar
Eric Cardenas
Moderator
Posts: 22735
Joined: Sat May 07, 2005 1:47 pm
Location: Uppsala, Sweden

Re: Crashing after update

Tue Sep 08, 2015 11:53 am

If you want to continue to trouble shoot you can proceed by trying to install the plug-ins you mentioned to your Main Library.
That's the default location.
I would also start scouting the folders that Logic uses and see if the permissions look strange.
Select a folder and press Option-Command-I to show the inspector. You can now navigate wherever you want and the inspector will show your selection.
Look at the bottom of the inspector, where you have the permissions, and see if you can find any anomalies.
Eric Bradley Cardenas
EC Making Sound
Mac mini 2.6 GHz 16GB RAM Areca⚡RAID | MacBook Pro 2.3 GHz 16GB RAM | Os 10.14.5
Logic Pro 10.4.5 | RME Fireface UFX | Adam A7 + Sub8 | Spectrasonics | Softube
 
User avatar
des99
Posts: 3587
Joined: Tue Jan 27, 2015 12:08 pm

Re: Crashing after update

Tue Sep 08, 2015 1:02 pm

Remember that running "fix permissions" in Disk Utility does not do what you think it does - it just sets some OS stuff back to the default permissions. It won't fix items in your user account that have "difficult" permissions set - so it's worth check on the permissions, as Eric says, to see if anything looks funky...
mu:zines | music magazine archive | difficultAudio
 
User avatar
Goergtn
Topic Author
Posts: 68
Joined: Wed Aug 26, 2015 3:08 pm
Location: Nashville, TN.

Re: Crashing after update

Tue Sep 08, 2015 2:27 pm

I have done as you guys suggested, but no go. I put all my plug-in components in the main/audio/plugins/components folder, trashing older duplicates. I checked permissions and found the audio folder did not have my username listed, so I added it and had it applied to contents.
A couple months ago I added a Kronos audio/midi driver (usb). I've only used it that way for its editor. In Logic it is hooked up with 5-pin din as a sound source only. Should I hunt this down and trash it?
LPX 10.5.1
iMac 3.4 GHz i5, 24 gig ram, OS 10.14.6 (Mojave) RME FF800
Omnisphere, Trilian, RMX, Sup.Drummer
 
Dan Updike
Posts: 2
Joined: Tue Sep 08, 2015 5:31 pm

Re: Crashing after update

Wed Sep 09, 2015 8:17 am

I had a similar problem related to this post involving not being able to launch Logic 10.2 after a content update until after creating a new admin account. Thank you very much for that suggestion Eric.

I did not want to have to use this new account to run Logic, so I decided to see what may be the difference between the two accounts.

Under the new admin account: "/Users/logicadmin/Library/Application Support/Logic" I found the following files:
drwxr-xr-x 4 logicadmin staff 136 Sep 6 11:26 .
drwx------+ 14 logicadmin staff 476 Sep 6 11:15 ..
-rw------- 1 logicadmin staff 49152 Sep 6 11:26 .Alchemy_Preset_Ratings_And_Tags.db.swp
-rw-r--r-- 1 logicadmin staff 44032 Sep 5 10:16 Alchemy_Preset_Ratings_And_Tags.db

The directory itself had the following permissions:
drwxr-xr-x 4 logicadmin staff 136 Sep 6 11:26 Logic

In the same directory under my existing account I found a single file called "Logic" with the following permissions:
-r--r--r--@ 1 10867355 wheel 0 Jan 31 2009 Logic

I deleted the file because it looked to have a size of zero and only read permissions, owned by some account called "wheel".

macDaddy:Application Support danupdike$ rm Logic
override r--r--r-- 10867355/wheel for Logic? y

After the deletion of this file Logic was able to launch successfully from my original account. After successful launch it appears Logic was able to create the correct directory with the necessary content:

dr-xr-xr-x 20 root admin 680 Sep 1 19:02 Logic