A technical support community for Apple Logic Pro users.

 
RWCmusic
Topic Author
Posts: 10
Joined: Wed Oct 28, 2020 10:02 am

Audio disappearing...

Mon Nov 16, 2020 11:59 am

Hi!

I'm having a problem with audio disappearing, recorded audio not midi. It's happened on many projects, i could be working on a project for months and then randomly, when i open the session, some of the audio is just missing. The recorded section is still there but theres not waveform visible and no audio audible. Why? Can i get that audio back? It's so frustrating having to re record parts.

Sometimes it happens randomly, or at least it appears random and other times its after i bounce individual tracks, even the bounced file has no audio despite there being no issue with the audio at the time of bouncing.

Any help would be greatly appreciated!

Thanks
 
mendo_bendo
Posts: 4
Joined: Sat Nov 14, 2020 4:37 pm

Re: Audio disappearing...

Mon Nov 16, 2020 2:12 pm

I used to have this problem often and I don’t anymore, since I’ve started saving my projects as folders instead of packages. Make sure when saving a session that the checkbox next to audio files is also checked.

I don’t know why it happens but my conclusion has been that saving as a package is a bad idea, folders always work for me. Hope this helps!
 
RWCmusic
Topic Author
Posts: 10
Joined: Wed Oct 28, 2020 10:02 am

Re: Audio disappearing...

Tue Nov 17, 2020 2:03 am

Thanks for the reply! I do save it this way, with audio checked and i save them as folders but i have the same issue.
 
User avatar
David Nahmani
Site Admin
Posts: 84756
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Audio disappearing...

Tue Nov 17, 2020 2:21 am

RWCmusic wrote:
when i open the session, some of the audio is just missing.

When you open the Logic project file, do you get an alert stating that an audio file is missing?

Are you saving your project folders on your system drive?
David Nahmani
• My Logic Pro X 10.5 book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.6.1
MacBook Air 1.3 GHz i5 — MacOS X 11.0.1 — 4 GB RAM
iMac 3.2 GHz Quad Core i5 — MacOS X 10.15.4 — 8 GB RAM
 
RWCmusic
Topic Author
Posts: 10
Joined: Wed Oct 28, 2020 10:02 am

Re: Audio disappearing...

Tue Nov 17, 2020 2:58 am

Yes i get 'audio file not found' pop up every time. I have tried locating the file and also 'skipping all', it still works even if i skip and the audio file that supposedly wasn't found, is still visible and audible within the project. Even if i locate the audio file, it still goes missing the next time i open the project.

Yes i am saving to my system drive. Thanks!
 
User avatar
David Nahmani
Site Admin
Posts: 84756
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Audio disappearing...

Tue Nov 17, 2020 3:02 am

RWCmusic wrote:
Yes i get 'audio file not found' pop up every time. I have tried locating the file and also 'skipping all', it still works even if i skip and the audio file that supposedly wasn't found, is still visible and audible within the project. Even if i locate the audio file, it still goes missing the next time i open the project.

Yes i am saving to my system drive. Thanks!

You're welcome. Ok good to know about the system drive, at least we know it's properly formatted.

So make sure you take a note of the exact, precise file name (and number if any) that is/are missing. It's not possible for Logic to playback an audio file that it cannot find, so my guess is, it's playing another file, not the one that is missing. You can open the Project Audio browser to see the missing file, they should have an orange exclamation point symbol in front of their name. If you locate them, make sure you then save your project file to update the reference to the new location. When you open that file again, you will no longer get an alert that the file is missing — unless of course you manually change its location in the Finder without that Logic project's knowledge.
David Nahmani
• My Logic Pro X 10.5 book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.6.1
MacBook Air 1.3 GHz i5 — MacOS X 11.0.1 — 4 GB RAM
iMac 3.2 GHz Quad Core i5 — MacOS X 10.15.4 — 8 GB RAM
 
RWCmusic
Topic Author
Posts: 10
Joined: Wed Oct 28, 2020 10:02 am

Re: Audio disappearing...

Tue Nov 17, 2020 7:52 am

Okay great i will give this a go next time the issue arises. Thanks for you time!
 
User avatar
David Nahmani
Site Admin
Posts: 84756
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Audio disappearing...

Tue Nov 17, 2020 7:53 am

You're welcome!
David Nahmani
• My Logic Pro X 10.5 book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.6.1
MacBook Air 1.3 GHz i5 — MacOS X 11.0.1 — 4 GB RAM
iMac 3.2 GHz Quad Core i5 — MacOS X 10.15.4 — 8 GB RAM
 
johnnyjazz
Posts: 3
Joined: Sat May 08, 2021 8:06 am

Re: Audio disappearing...

Sat May 08, 2021 8:12 am

Same issue here...
To locate the missing audio from the browser, does the project need to be saved as a folder? Currently my session is saved as a project and that's all my browser can see - the Logic X fine, but no audio files beyond that.
Thanks in advance, John
 
User avatar
triplets
Posts: 18574
Joined: Wed Sep 14, 2005 3:21 pm
Location: North Hollywood
Contact:

Re: Audio disappearing...

Sat May 08, 2021 10:44 am

johnnyjazz wrote:
Same issue here...
To locate the missing audio from the browser, does the project need to be saved as a folder? Currently my session is saved as a project and that's all my browser can see - the Logic X fine, but no audio files beyond that.
Thanks in advance, John


To locate the missing audio file you need to know the exact name of the file. And then start searching for it on your computer.
Logic Pro 9 Master Pro and X certified
ProTools 10 & 11 Certified Operator
2 x 3.06 Intel Six-Core 24 GB RAM, Logic 10.5.1, 10.14.6., UA Apollo
2012 i7 MBP 8 GB Logic 10.6.1, 10.15.7
Contact me for Logic help (Teamviewer, Zoom, Skype)
http://www.ultimatestudiosinc.com
 
johnnyjazz
Posts: 3
Joined: Sat May 08, 2021 8:06 am

Re: Audio disappearing...

Sat May 08, 2021 11:19 am

Thanks triplets! Yes, I can see the files in "show contents" of the Logic package.
My issues may be pretty deep: 16 files are now 8-bit, and many are shortened as well
Attachments
Screen Shot 2021-05-08 at 2.11.33 PM.png
Screen Shot 2021-05-08 at 2.11.33 PM.png (111.67 KiB) Viewed 233 times
 
User avatar
David Nahmani
Site Admin
Posts: 84756
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Audio disappearing...

Sat May 08, 2021 11:48 am

You can start by saving your project again, organized as a folder instead of a package (File > Save As).

Was your project saved on a microsoft formatted hard drive?
David Nahmani
• My Logic Pro X 10.5 book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.6.1
MacBook Air 1.3 GHz i5 — MacOS X 11.0.1 — 4 GB RAM
iMac 3.2 GHz Quad Core i5 — MacOS X 10.15.4 — 8 GB RAM
 
johnnyjazz
Posts: 3
Joined: Sat May 08, 2021 8:06 am

Re: Audio disappearing...

Sat May 08, 2021 7:19 pm

No microsoft - never! Project's on my hard drive.
I "saved as" project to a folder, though maybe I should've saved the project into a folder from the start?
I opened the newly created folder-project, but opening the browser took 40 min! Some of the files were missing from that folder's audio, so I copied all the audio files from the original project's "show contents" portion and replaced the folder's audio files.
Now I'm having some success linking a few exclamation-marked files in the browser, but they may all be 8-bit now.
Attachments
Screen Shot 2021-05-08 at 9.59.12 PM.png
Screen Shot 2021-05-08 at 9.59.12 PM.png (51.04 KiB) Viewed 164 times