A technical support community for Apple Logic Pro users.

 
thirdspace
Topic Author
Posts: 63
Joined: Mon Nov 02, 2009 12:24 am

Mainstage 3.4.4>3.5.1 High Sierra Should I upgrade?

Sat Feb 20, 2021 1:40 am

I am currently running Mainstage 3.4.4 on an old iMac which won't update past High Sierra OS X 10.13.6 (I do this so I can build setups which I run on my MacBook Pro running Mainstage 3.5.5 on Catalina, when away from that machine which typically lives in my studio; the old Mac lives in the house). Should I upgrade to Mainstage 3.5.1 on the old Mac? Will it still work? The App Store says I need a minimum of OS X 10.15.5 or later. Thanks in advance
Logic Pro 10.5.1, Mac OS X 10.15.4
 
gacki
Posts: 92
Joined: Fri Jul 17, 2020 3:18 am

Re: Mainstage 3.4.4>3.5.1 High Sierra Should I upgrade?

Sun Feb 28, 2021 3:52 am

AFAIK 3.5.1 will not work with High Sierra nor Mojave; 3.4.4 is to my knowledge the last version to run on High Sierra.
 
thirdspace
Topic Author
Posts: 63
Joined: Mon Nov 02, 2009 12:24 am

Re: Mainstage 3.4.4>3.5.1 High Sierra Should I upgrade?

Mon Mar 01, 2021 1:55 am

thank you - not sure what I will be losing out on on my old machine but I won't risk the upgrade!
Logic Pro 10.5.1, Mac OS X 10.15.4