A technical support community for Apple Logic Pro users.

 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Mon Oct 04, 2021 10:31 am

My Logic keeps breaking my control surface setup (three X-touches). It randomly assigns port to teh wrong devices or double map.
 
sunbrother
Posts: 54
Joined: Sun Sep 26, 2021 9:55 am

Re: Plug-in Delay Compensation broken with external side-chain

Mon Oct 11, 2021 10:52 am

ansolas wrote:
My Logic keeps breaking my control surface setup (three X-touches). It randomly assigns port to teh wrong devices or double map.


You can turn that behavior off.
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Mon Oct 11, 2021 11:24 pm

sunbrother wrote:
ansolas wrote:
My Logic keeps breaking my control surface setup (three X-touches). It randomly assigns port to teh wrong devices or double map.


You can turn that behavior off.
Not Controller,I am talking about theses :
Screenshot 2021-10-12 at 08.22.31.png
Screenshot 2021-10-12 at 08.22.31.png (483.25 KiB) Viewed 2143 times
 
sunbrother
Posts: 54
Joined: Sun Sep 26, 2021 9:55 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 12, 2021 5:03 am

I understand. You can turn that behavior off. I turned it off myself, as Logic was constantly re-assigning my Faderport and making duplicates.
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 12, 2021 5:36 am

sunbrother wrote:
I understand. You can turn that behavior off. I turned it off myself, as Logic was constantly re-assigning my Faderport and making duplicates.


How ? please?!

Just checked it right now and it was broken again:

 
sunbrother
Posts: 54
Joined: Sun Sep 26, 2021 9:55 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 12, 2021 7:55 am

In that window, toggle New > Automatic Installation
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 12, 2021 9:39 am

sunbrother wrote:
In that window, toggle New > Automatic Installation

It is disabled here.
 
JakobP
Posts: 2291
Joined: Sun Aug 17, 2014 1:49 pm
Location: Stockholm

Re: Plug-in Delay Compensation broken with external side-chain

Fri Oct 15, 2021 11:36 am

ansolas wrote:
sunbrother wrote:
In that window, toggle New > Automatic Installation

It is disabled here.

Not sure why control surface issues are discussed here ? Your problem seems worthy its own thread...
Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Sat Oct 16, 2021 3:08 am

JakobP wrote:
ansolas wrote:
It is disabled here.

Not sure why control surface issues are discussed here ? Your problem seems worthy its own thread...

I apologise, you are correct. This is another topic.
 
User avatar
David Nahmani
Site Admin
Posts: 87099
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Plug-in Delay Compensation broken with external side-chain

Sat Oct 16, 2021 7:41 am

ansolas wrote:
I apologise, you are correct. This is another topic.

Don't hesitate to start a new thread for that topic, so that we can help further troubleshoot it there.
David Nahmani
• My Logic Pro book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.7.1
MacBook Air 1.3 GHz i5 — MacOS X 11.0.1 — 4 GB RAM
iMac 3.2 GHz Quad Core i5 — MacOS X 12.0.1 — 8 GB RAM
 
rfpm
Posts: 25
Joined: Thu Jan 23, 2020 8:24 am

Re: Plug-in Delay Compensation broken with external side-chain

Mon Oct 18, 2021 5:06 pm

I'm very hands off with Logic these days, moved to Reaper last year but I still check in now and then. From what I'm reading 10.6.3 sounds nearly like a step backwards. Anyone tried out the 10.7 update?
 
en5ca
Posts: 38
Joined: Thu May 06, 2010 12:03 pm

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 4:37 am

rfpm wrote:
I'm very hands off with Logic these days, moved to Reaper last year but I still check in now and then. From what I'm reading 10.6.3 sounds nearly like a step backwards. Anyone tried out the 10.7 update?

According to release notes, nothing has been done.
 
rfpm
Posts: 25
Joined: Thu Jan 23, 2020 8:24 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 5:05 am

en5ca wrote:
rfpm wrote:
I'm very hands off with Logic these days, moved to Reaper last year but I still check in now and then. From what I'm reading 10.6.3 sounds nearly like a step backwards. Anyone tried out the 10.7 update?

According to release notes, nothing has been done.


Very disappointing to hear, oh well.
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 8:02 am

Just checked it, it is still broken !
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 10:02 am

PDC seams to be broken even without sidechain now:

Here Just 2 channels of Alchemy.

One Panned to hard right the othet hard left.

On one I added adaptive Limiter with 200ms Lookahead, to make tging obvious:

 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 10:28 am

Playback seams to be compensated, live is just broken, yes i have enable all

Screenshot 2021-10-19 at 19.15.38.png
Screenshot 2021-10-19 at 19.15.38.png (123.28 KiB) Viewed 1789 times


https://www.youtube.com/watch?v=vvTqevMKXMg
 
en5ca
Posts: 38
Joined: Thu May 06, 2010 12:03 pm

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 10:30 am

ansolas wrote:
PDC seams to be broken even without sidechain now:

Here Just 2 channels of Alchemy.

One Panned to hard right the othet hard left.

On one I added adaptive Limiter with 200ms Lookahead, to make tging obvious:


Unfortunately that seems to be the desired behaviour of Logic when monitoring live inputs through software. Basically making 'record what you hear' impossible with mixed latency input sources.

viewtopic.php?f=42&t=152855
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 10:49 am

For Virtual Instruments either ?

And how do you play a track stack instrument which contains effects which introduce latency ...

I doubt that this is intended
 
en5ca
Posts: 38
Joined: Thu May 06, 2010 12:03 pm

Re: Plug-in Delay Compensation broken with external side-chain

Tue Oct 19, 2021 10:53 am

ansolas wrote:
For Virtual Instruments either ?

And how do you play a track stack instrument which contains effects which introduce latency ...

I doubt that this is intended


Simple. You don't, at least in sync. But agreed, that probably isn't what they intended, but it's what has been accepted. That's been an issue since early versions of Logic Pro X.
 
User avatar
ansolas
Posts: 81
Joined: Wed Aug 13, 2008 8:19 am

Re: Plug-in Delay Compensation broken with external side-chain

Wed Oct 20, 2021 7:47 am

Here another Example. Essentially it is the same example as the previous, but this time I wanted to check how sidechain 'meanwhile' behaves.
The result is quite 'funky' to formulate it in a political way.

So I added one Alchemy playing a pad sound
On thet Track there is a Compressor.

Its Sidechaininput is set to another channel with the kick drumsynth on it.
Playback sound Ok to me.
But here come the funkines.

Live playback of all other tracks are now behave as expected!

Once I remove the Sidechain Input it get's broken as in the previous videos I showed.