A technical support community for Apple Logic Pro users.

 
User avatar
fuzzfilth
Topic Author
Posts: 4608
Joined: Mon Aug 03, 2009 2:31 am
Location: Germany

Bug in Environment Button

Wed Dec 23, 2020 11:23 am

Hey there, please check and verify this:

- Open an Environment window
- Create a New>Monitor Object
- Create a New>Fader>Button Object and cable it into the Monitor
- Change the Button's Out definition from Control to Fader

Now the Button randomly sends value 1 instead of 127 for its On-status. Selection state of the Button or other objects seems to randomize this even more.

Happens in Logic 10.4.4 and 10.5.1.

fader.gif
fader.gif (275.9 KiB) Viewed 1051 times
Christian Obermaier
Contact me for private Logic Consulting, Training, Troubleshooting via Skype, Zoom or Teamviewer

1 x MacPro 6core 2010 24Gb RAM
2 x MacBookPro i7 2012 16Gb RAM
OSX.14.6. Mojave, Logic X.4.4 & 5.1
 
Plowman
Posts: 1507
Joined: Mon Sep 12, 2005 3:10 pm

Re: Bug in Environment Button

Wed Dec 23, 2020 2:36 pm

I can confirm this in Logic 10.5.1. It took about twenty seconds of clicking, but eventually the 127 began to appear. Thereafter, it appears more frequently. Regarding selection of objects, I can't trace anything conclusive. But no matter what object is selected, 127 randomly appears.
6-core Mac Mini 2018 with 64 GB and OS 10.15.7 running Logic 10.6.1, 8-core Mac Pro 2.8 (early 2008) with 16 GB RAM and OS 10.14.1 running Logic 10.4.3, Mac Mini Server mid-2011, Logic Control, Vienna Ensemble Pro (VI and Synchron), Vienna MIR, Ivory