A technical support community for Apple Logic Pro users.

 
aaronbagby
Topic Author
Posts: 56
Joined: Tue Mar 26, 2013 8:24 am

Mod Wheel Assigned?

Thu Mar 26, 2020 9:41 pm

Hello again. I know I've been posting like crazy, but today's led me to the current predicament...

I spent much of today assigning controller parameters... Now my mod wheel has stopped being recognized in Logic. Bypassing control surfaces makes it function normally. Instinct says I've assigned CC1 to something, but there are definitely no assignments with a value change on CC1. Where should I look next?
 
User avatar
David Nahmani
Site Admin
Posts: 75385
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Mod Wheel Assigned?

Fri Mar 27, 2020 3:32 am

Look under Logic Pro X > Control Surfaces > Controller Assignments. Somewhere in that window, your modulation MIDI CC (#1) is assigned to something. You can select the assignment and press Delete on your keyboard to remove it.
David Nahmani
• My Logic Pro X 10.4 book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.4.8 - Mac OS X 10.15.1 - MacBook Air 1.3 GHz i5 - 4GB RAM
 
aaronbagby
Topic Author
Posts: 56
Joined: Tue Mar 26, 2013 8:24 am

Re: Mod Wheel Assigned?

Fri Mar 27, 2020 10:11 am

David Nahmani wrote:
Look under Logic Pro X > Control Surfaces > Controller Assignments. Somewhere in that window, your modulation MIDI CC (#1) is assigned to something. You can select the assignment and press Delete on your keyboard to remove it.


Thanks, that was where I had already looked. It was definitely not assigned to anything. I ended up deleting preferences and starting from scratch to solve it.