A technical support community for Apple Logic Pro users.

 
briansin
Topic Author
Posts: 19
Joined: Tue Jun 02, 2020 8:27 am

Weird! X 1 0 0 Midi in/out flashing?

Tue Jun 30, 2020 9:21 pm

Hi all,
I have been using Logic with my Komplete M32 for a few weeks now. Tonight, it just happened that when I monitor the midi in / midi out part of the LCD, it keeps flashing X 1 0 0 for both midi in and midi out. This ONLY happens when I have a komplete kontrol plugin loaded (doesn't happen with Alchemy or whatever loaded). Also, it has to be in plugin mode on the KK (controlling Logic in Track mode works just fine). Also, if i record anything on this track, i get Sysex Mackie Designs events in the Event list.

I've been using this KK keyboard for a while with Logic on this mac, and have never seen this. It literally just started happening overnight. Anyone have any thoughts they could share?

Thanks
 
User avatar
Atlas007
Posts: 8803
Joined: Mon Dec 14, 2009 11:58 pm
Location: Montreal

Re: Weird! X 1 0 0 Midi in/out flashing?

Tue Jun 30, 2020 9:25 pm

LogicX 10.5.1 ( & 9.1.8),MainStage3.4.4
MBPro 17", Core2Duo, 8G, OSX 10.12.6
MacPro, Xeon 6Cores, 64GB, OSX 10.15.5
ULN8, MOTU MIDI TP-AV, C4, Eucon McControl, KorgNano, Novation SLMkII
AAS, NI, Celemony, Spectrasonics, Korg, MIDIQuest, etc...
PC, iPad3(V-Control & LogicRemote), AtariST(Notator SL), Several vintage gear
 
briansin
Topic Author
Posts: 19
Joined: Tue Jun 02, 2020 8:27 am

Re: Weird! X 1 0 0 Midi in/out flashing?

Tue Jun 30, 2020 9:34 pm

Yes, but this doesn't list any resolution. Even if I filter out the System messages from the input filters, it still records it for automation and still flashes X 1 0 0 on the Midi in / midi out part. Is there a fix for that part?

Thanks
 
User avatar
rAC
Posts: 388
Joined: Tue Mar 01, 2016 1:52 am
Location: Mooloolaba

Re: Weird! X 1 0 0 Midi in/out flashing?

Wed Jul 01, 2020 3:02 am

Have you asked NI?
27" iMac Pro 1.1 8 core 64 GB 1 Tb SSD with 27" Apple Thunderbolt display
MacOS Catalina 10.15.5, Logic X 10.4.8 (10.5 also being investigated/trialed)
4 TB G-RAID via Thunderbolt Display and 4 TB TBolt HDD Timemachine only,
RME UFX via Firewire to Thunderbolt Display,
MOTU MIDI express XT to USB, Seaboard 25 via BT or USB,
Roland AT45, Kurzweil PC2r & PC3X, Arturia MatrixBrute, 12Step & BCF2000 via MOTU’s MIDI
PC3X, MatrixBrute, 12Step and BCF2000 occasionally via USB.
 
User avatar
David Nahmani
Site Admin
Posts: 78667
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Weird! X 1 0 0 Midi in/out flashing?

Wed Jul 01, 2020 4:04 am

That means your keyboard is sending SysEx data to Logic. Maybe because it's in some kind of proprietary control surface mode supposed to communicate with N.I. software or gear?
David Nahmani
• My Logic Pro X 10.4 book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.5.1
MacBook Air 1.3 GHz i5 — MacOS X 10.15.1 — 4 GB RAM
iMac 3.2 GHz Quad Core i5 — MacOS X 10.15.4 — 8 GB RAM
 
briansin
Topic Author
Posts: 19
Joined: Tue Jun 02, 2020 8:27 am

Re: Weird! X 1 0 0 Midi in/out flashing?

Wed Jul 01, 2020 6:55 am

rAC: yes, but NI is not very prompt on answering these days, i've found this forum to be much more knowledgable and informative.

David: indeed, the KK keyboards have 3 modes: midi (fine), daw control (also fine), and direct control of the Komplete Kontrol software (either standalone or as a plugin in a DAW). And yes, it's only sending these Mackie messages when it's in the mode meant to control KK (not seeing these in midi or logic control mode). But the question is why did it just start? i've been recording using KK plugins in logic for a while now, and have never seen these system messages pop up. Now, they pop up every second when i'm controlling KK within logic.

I can filter out the system messages in the midi project settings, but I still see the X 1 0 0 constantly flashing in the LCD. Any thoughts on why it would just have started happening or what I can possibly do? Why is logic seeing these messages from the KK when it's meant for the KK software? Any reason you can think of on why it woudl just have started?

Thanks
 
User avatar
David Nahmani
Site Admin
Posts: 78667
Joined: Sat Mar 05, 2005 12:16 am
Contact:

Re: Weird! X 1 0 0 Midi in/out flashing?

Wed Jul 01, 2020 7:19 am

If the messages are present at Logic's input, Logic displays it. As far as I know this is the way it's always worked, I've personally never experienced Logic behaving any differently.
David Nahmani
• My Logic Pro X 10.4 book (Apple Pro Training Series)
Contact me for Private Lessons
Logic Pro X 10.5.1
MacBook Air 1.3 GHz i5 — MacOS X 10.15.1 — 4 GB RAM
iMac 3.2 GHz Quad Core i5 — MacOS X 10.15.4 — 8 GB RAM
 
briansin
Topic Author
Posts: 19
Joined: Tue Jun 02, 2020 8:27 am

Re: Weird! X 1 0 0 Midi in/out flashing?

Wed Jul 01, 2020 8:45 am

Thanks David, understood. So I guess the question is why is the M32 sending these Mackie SysEx events now when it's controlling KK, when it never did before. If anyone has any ideas, I'd be grateful to hear them.

Thanks
 
User avatar
Atlas007
Posts: 8803
Joined: Mon Dec 14, 2009 11:58 pm
Location: Montreal

Re: Weird! X 1 0 0 Midi in/out flashing?

Wed Jul 01, 2020 8:58 pm

Wild guess: lately you probably inadvertently enabled some (SysEx emitting) feature in your controller.
LogicX 10.5.1 ( & 9.1.8),MainStage3.4.4
MBPro 17", Core2Duo, 8G, OSX 10.12.6
MacPro, Xeon 6Cores, 64GB, OSX 10.15.5
ULN8, MOTU MIDI TP-AV, C4, Eucon McControl, KorgNano, Novation SLMkII
AAS, NI, Celemony, Spectrasonics, Korg, MIDIQuest, etc...
PC, iPad3(V-Control & LogicRemote), AtariST(Notator SL), Several vintage gear
 
briansin
Topic Author
Posts: 19
Joined: Tue Jun 02, 2020 8:27 am

Re: Weird! X 1 0 0 Midi in/out flashing?

Wed Jul 01, 2020 11:41 pm

I haven’t done anything with the settings of the controller. Do you have any helpful ideas on what that might be? Why would the KK be emitting these? Thanks