Jump to content

Automation question


formula101

Recommended Posts

Today after opening a session I noticed that several of my tracks in Logic weren't responded to cc7.

I looked at all my midi regions and saw that volume automation was drawn in, but levels were not changing.

I then changed Automation Mode on the track in question to Read, and that fixed the problem.

 

But my question is, I don't remember ever needing to set Automation Mode to Read in the past. In fact, on all my midi tracks, The "Read" button is in grey, and has always been in grey, yet I never had a problem with Logic not reading automation on any midi regions.

 

Curious if I accidentally changed a setting?

Link to comment
Share on other sites

Thanks Eric.

 

Do you know how I can go back to the way I worked before? To clarify, I like to draw automation on every region on a track, and keep the "Read" button in grey for that particular track. I'm confused as to why I need to now turn track automation on when in the past, the regions were able to read the automation just fine.

Link to comment
Share on other sites

Apologies for not being clear. I want to draw automation on midi regions only, not the track. I have many projects set up this way. Does this mean that with 10.1.1, I now have to turn track automation on for every single track that has automation drawn on the region?
Link to comment
Share on other sites

You can see that there is a clear divide between the different parameters.

You have the old track-based automation parameters at the top and the MIDI channels followed by the CCs underneath.

This makes sense both if you think about compatibility and from a pure external instrument point of view.

 

You can of course use CC7 to control the instruments volume if you'd like.

Link to comment
Share on other sites

So before I try and revert to an earlier version of Logic, what is the best option for me (given the fact that all my old sessions have tracks upon tracks of midi cc 7 automation data written on regions) to not have to go through each and every track an enable "Read?"

 

By the way, I tried selecting all tracks and switching on automation for one track, and the others actually did not follow suit.

 

Am I just missing a setting in 10.1.1 that will allow my midi cc 7 volume automation to behave as it did before? I find it odd that this update would mess with this feature.

 

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...