Jump to content

Why does beat map change when Flex time is on?


dukeh62

Recommended Posts

Thanks Eric. I'm actually trying to adjust the tempo of these tracks. So how do you suggest I approach this? When I play the track with flex on, obviously the measures and map aren't lined up. Do I remap with Flex on? Right now the results sound like crap when I playback with Flex engaged.

 

Thanks in advance!

Link to comment
Share on other sites

You are probably almost there as you have already beat mapped the file.

Don't turn on flex yet.

Create a new audio file and and set its input to bus x. Set the output of your original track to bus x.

Record enable the new track and record. The new file will be a replica of your original region but it will have the tempo information of your beat map. Now turn on flex on your new track.

Link to comment
Share on other sites

Create a new audio file and and set its input to bus x. Set the output of your original track to bus x.

Record enable the new track and record. The new file will be a replica of your original region but it will have the tempo information of your beat map.

 

It would be easier to just export the tempo changes that result from beat mapping into your audio files (Edit > Tempo > Export Tempo Information to Audio File). Just make sure your regions are selected before using the command.

 

Furthermore, if your goal is to have have your performance play at a steady tempo:

 

After you export the tempo info, create a new tempo set with the desired fixed BPM (say "120" or whatever), then enable Flex. Your files will now conform to the fixed tempo without having to do any manual Flex editing.

 

J.

Link to comment
Share on other sites

Thanks for the help guys. All that stuff worked, but now I'm perplexed with two new issues...

 

Here's what I've done so far:

 

- Beat-mapped entire song

- Removed tempo information from audio files

- Then exported new tempo information to audio files

- Made my flex time adjustments

- Saved and closed session.

 

Now when I open the session, I get an error message that the length of some audio files have changed, and therefore one or more tracks may have moved and will be out of place. (I have two reference tracks that I did not flex time or export new info, so maybe those are the culprits?)

 

The OTHER issue, is that when I reopen the session, my beat map is no longer lining up correctly when I turn flex time off.

 

What happened?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...