Jump to content

recording regions-driving me nuts! [SOLVED]


mike.h.1234

Recommended Posts

Hi all,

 

I'm hoping someone can tell me what I'm not doing right here.

If I record a midi track, the region created in the arrange window always starts at bar 1 and not from where I want it to start. For example, say I want to record a region at bar 10, then I can set locators easily enough and do that, but still the region then starts at bar 1 and gives me a needless 9 bars rest.This is driving me mad because it seriously slows down the work rate as I use the score and event list to edit with. I have gone through everything in the preferences and tried every combination of link and view modes. Any help/ideas would be greatly appreciated.

Also, anybody any ideas on how to make logic chase VSL keyswitching?

 

I'm using Logic Pro x v10.1.1 on a 2013macpro. 32gb ram 6 core.

 

cheers all

 

Mike.

Link to comment
Share on other sites

Hi Des99,

 

Following on from your clue re the event list, I see that when I try to record anywhere in the song, a controller no16 (general 1) message appears at bar 0 (where my song starts) in the event list and as a region in the arrange window. From that point on no matter where I start recording, the new region merges with the event/region at bar 0, hence my extremely long regions in the arrange window. Is there a way around this....

Thanks again Des

Link to comment
Share on other sites

Following on from your clue re the event list, I see that when I try to record anywhere in the song, a controller no16 (general 1) message appears at bar 0 (where my song starts) in the event list and as a region in the arrange window.

 

Hmm, wonder what's causing that. Do you have any MIDI devices on your system that might be sending messages to Logic? Try, for example, unplugging any MIDI input devices and see whether that CC 16 is being created.

 

From that point on no matter where I start recording, the new region merges with the event/region at bar 0, hence my extremely long regions in the arrange window. Is there a way around this....

 

Is the overlapped recording settings set to "Join with Selected Regions"..?

Link to comment
Share on other sites

Hi Des, Eric,

 

Thanks for cooling it down Eric.

Yep,I had already unplugged my keyboard and punched record to no avail. Join when cycling is set, but still the same issue. At least that tells me it's within Logic. BTW I'm using a unitor8 and 2 amt8's, could they be the culprits....

 

Thanks gentlemen.

Link to comment
Share on other sites

Hmm... that's very strange.

 

It could be related to your starting point.

Logic is known for having various issues when moving the starting point to something other than 1.1.1.1.

 

You can attach your project here and I'll have look at it to see if it behaves erratical on my system too.

 

Thanks for cooling it down Eric.

 

You're welcome.

Link to comment
Share on other sites

Hi Eric,Des,

 

Yes it is strange, however, I monkeyed around in the environment and decided to delete my tempo fader and lo and behold the problem is no more. I now have to check that I plumbed in the tempo fader correctly in the first place to see if it's an issue or not. I will let you know if it's a bug. In the meantime anything I should know about the tempo fader that isn't in the mannual...

Mike.

Link to comment
Share on other sites

Hi Des, Eric,

 

Problem solved.

Just for the record, the problem was with the tempo faders filter in the fader inspector column in the environment. It defaults to off when you create a tempo fader, I just set the filter to other and voila.

Once again thanks for all your help.

 

Mike

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...