Jump to content

Help Correcting Project Tempo After Making Flex Pitch Edits


iamcam

Recommended Posts

I just finished doing some flex pitch edits on a bunch of vocal tracks that I imported into Logic X, and after I finished the edits I realized that I never set the project's tempo to the correct tempo. It's still at its default 120 bpm, when it should actually be 140 bpm. The vocal files were recorded at 140 bpm and are playing back at their original tempo, but Logic's current set tempo of 120 is inaccurate. When I try to correct this by adjusting the tempo to 140, the vocal files themselves seem to stay in place visually on the grid, but they're sped up when I play them; faster than 140 bpm. There are various splits in the regions too, as I'm in the middle of editing. I want the audio to stay the same as it is currently, just with the grid aligned to the correct tempo of 140 bpm.

 

Is there a way to adjust the main tempo without affecting the audio files and while maintaining all my flex pitch edits, just so the grid behind them will reflect a tempo of 140 bpm instead of 120? I would like to do this to make editing easier. It seems to work when I turn off flex mode and then adjust the tempo, but it goes back out of sync as soon as I turn flex mode back on. Is it possible to do this without having to re-do all my flex pitch edits? I've tried to SMPTE lock the regions and then adjust the tempo, but that doesn't seem to work either. The audio still remains out of sync with the project tempo.

 

Any help would be greatly appreciated. Thanks.

Link to comment
Share on other sites

I can only provide a workaround that should do it:

First just Save the project, then Save as... it under a different name (like "oldname"140). The original "oldname" will remain unaltered from here on.

In "oldname"140, bounce the flexed tracks in place, (make sure flex is off on the new tracks), then delete the originals, SMPTE lock the new regions (unless they all start at 1 1 1 1 - then there's no need to SMPTE-lock) and set the tempo of the project to 140, then Save again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...