Jump to content

Logic Pro/Kontakt Multi-Timbral (Help Needed)


explojoseph

Recommended Posts

Okay, I want to preface by saying that I don't know for sure if this is an issue with Logic Pro or Kontakt. I understand that there is a Kontakt support forum, but I've found these forums to be much more reliable overall and I'm always very satisfied with the support (as much as I love Kontakt). Also, most Logic Pro users have extensive experience using Kontakt, so I figured it can't hurt to ask. So here it goes...

 

I'm trying to create a multi-timbrel instrument in Kontakt 5 (Logic Pro), but I keep running into this weird issue... I'm able to create the multi and the individual tracks corresponding to the 16x outputs. The tracks all work perfectly (kind of). All the instruments are properly routed so that the right instruments play on the intended tracks/outputs.

 

THE PROBLEM is that the volume indicator triggers on a DIFFERENT track for some of them. So, I'm going to go ahead explain what I did. (hopefully, somebody can check my steps and see exactly where I went wrong along the way):

 

1. Loaded 16 instruments into instance of Kontakt on a 16x output channel.

 

2. Set each instrument's midi channel in Kontakt in a consecutive order (e.g. first instrument was set to [A]1, the second to [A]2, etc.).

 

3. Went to "batch functions" and selected the option to "clear output section and create one individual channel for each loaded instrument".

 

4. Opened Logic's mixer and pressed the plus sign on the Kontakt multi track for as many instruments I had (keeping in mind that the host channel is the first instrument).

 

5. Individually went to every added channel in Logic's mixer and created a track for each one.

 

 

These are the exact steps I took. I've done this many times and tried experimenting with it differently. Still, I keep running into the same issue. I've even checked multiple YouTube tutorials, but clearly I'm missing something.

 

 

Thanks in advance for your help.

Link to comment
Share on other sites

Okay. That makes no sense. All the channels were properly set. But when I did the batch configure for all the channels, it uncorrectly routed everything for no reason.

 

Now, when I tried doing it with channels opened by default in "omni" and then switching them to the desired channels, this problem arose. However, if I had Kontakt set to next "available channel", then they routed properly. So, basically its a bug with Kontakt, and I can't manually set the channels?

 

I'm so confused as to why that happened

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...