Jump to content

Sound is recording everything instead of just vocals.

Recommended Posts

I get the whole point of recording, got it to work and everything but when I try to record a vocal with a instrumental playing on it's own track, instead of only recording my vocals it's recording the instrumental and my vocals all together at the same time onto one track. Even just playing the song both of the meters moves up like my microphone is catching all the sounds but really its not.. Any help would be appreciated thank you :)
Link to comment
Share on other sites

Hi and welcome to Logic Pro Help.


Click this link to your signature and add your system information:

• Logic version and sub-version (e.g. Logic Pro X 10.1.1)

• OS X version and sub-version (e.g. OS X Yosemite 10.10.3)

• Computer (e.g. MacBook Pro, Mac Pro, iMac)

• Processor (e.g. 2.2 GHz Intel i7)

• Memory (e.g. 8GB)

• Audio interface manufacturer and model (e.g. RME Babyface)


(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

Link to comment
Share on other sites

  • 3 months later...

Could it be you're using a USB mixer to monitor and also to plug your microphone into? If the mixer is a 2x2 audio interface, it is sending what you're hearing while recording your vocals back into logic recording input. So both signals get recorded on the new track. Post your complete hardware setup if you want us to help you.



Link to comment
Share on other sites

Hi, thanks for the response. BLINK yes you are right,.. The problem was that I was using the USB mixer to monitor and also to plug microphone into. So, I am now using the built-in output (on iMac) which solves the problem of the audio track recording onto my vocal track, HOWEVER, my vocals don't come through this way while I'm recording (I hear the audio/instrumental track only) and if I use the headphones on the USB interface to monitor my vocals, I can't hear the instrumental track. Is there a way to get around this? (I've tried turning 'input monitoring' in the channel strips on Logic.)


I'm not sure what other info to add about my hardware set up other than yes I'm using headphones through it for the INPUT sound and now using headphones in the iMac for the OUTPUT sound. (I did input all the info I know into my signature, hopefully that is coming through on my posts)



Link to comment
Share on other sites

Yes, that's the strange thing. With this set-up with my new iMac (I used to have a PC set-up), the Mix control knob on the Tascam does not work. (I checked the driver, it is up-to-date). So the only control I have with volume is the overall control with the Phones volume dial.

Some more info; there are 2 options for the Tascam Input settings in the Logic Audio Preferences; 'Bit Audio' and 'Core Audio'. I have tried both.

Link to comment
Share on other sites

The options in my Logic Pro Preferences (under Audio) are:




I have tried unchecking one and all and combinations of all! Doesn't help unfortunately. Hmmm. Does anyone recommend I do an uninstall and reinstall of Logic?

Link to comment
Share on other sites

  • 2 years later...

Solution: Buy a separate audio interface dedicated solely to monitoring.


I know this is an old thread, but I had the same problem, and was able to glean the solution by reading several similar threads. From what I could gather, it seems that if your audio interface is used for both your input (e.g., microphone, guitar, synthesizer, etc.), and your output; i.e., you're using the same audio interface to output sound for monitoring (e.g., through a pair of connected studio monitors), Logic produces a "loopback" effect, where all of your previously recorded audio tracks in Logic's timeline will also "print" (record) onto any newly recorded audio tracks.


Again, I had the same problem until I bought a separate audio interface, dedicated solely for monitoring, an M-Audio M-Track 2X2M class-compliant USB audio interface ($149). I chose this one because it looked cool, was inexpensive, and is a class-compliant USB device (so it doesn't need a driver to work). I assigned the M-Track 2X2M as my "output device" in Logic's preferences/audio menu. I only use the M-Track 2X2 interface to send audio to my Yamaha HS5 studio monitors from its two 1/4" phone jacks on the back. I don't use any of its analog inputs (or else I would produce the same loopback problem).


[Note that in my particular case, all of my input devices are hardware synthesizers (e.g., Korg Kronos) all of which support sending a digital audio stereo-pair + MIDI data over USB, so I don't need an audio interface for any of my inputs.]



M-Audio M-Track 2X2M





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...