Jump to content

Logic Pro X 10.2.1 drop down menu bug on Maverics [SOLVED]

Tony Flex

Recommended Posts



Some drop down menus are not working up in LPX 10.2.1. When you click on it nothing happens. The menu button changes it colour as it were clicked, but no pop-up happens.

Here is the list for me:

-sidechain menu

-scale menu (view)

-Repeat Regions\Events multiple times key command

-Channel Eq stereo\mid\side processing menu

-Preferences Automation both menus


Here is short video with this bug


What is did:

-permission repair

-disk repair

-reinstall Logic from App Store

-remove all Logic preferences files

-tried integrated and discrete video adapters


Sometimes menu in Repeat Regions\Events multiple times starts to work.


The menus are working fine under another user.


Im running OSX Maverics 10.9.5 on MacBook Pro 15 early 2011 (MC723LL\a).

Link to comment
Share on other sites

same problem here on mavericks, but no app called "moom" installed


after trying to change some dropdown-menus (not with all but mainly them in the project-settings), all file commands such as open, save as etc. don´t work, too. gladly those settings are available via the menubar, so for now I try to avoid changing them by the drop-down menus.


I will try to disable all extensions and report again.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 4 weeks later...

Hello All!


So I have some great news! First off, I want to give a shout-out to the developers at Moom who were great at responding with various suggestions and trying to figure out why this was happening. As it turns out it wasn't in fact anything Moom related. It was a Logic bug after all. One that affected computers running 10.9.5.


Yesterday Apple released an update that brings Logic Pro X to version 10.2.2. Check out the release notes, they specifically mention fixing the issue: "All menus now open reliably on computers running OS X 10.9.5."



I did my testing and all menu’s do in fact work again. And they play beautifully with Moom. So Yay! Just update to LPX 10.2.2 and that should fix things for you. Hope this helps anyone who has been having this issue.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...