Jump to content

A-49 USB keyboard not working with LPX [SOLVED]


Recommended Posts

Hi there,

I'd really appreciate your thought if anyone has ideas to the solution for this! :)


I have the latest LPX 10.2.1 and recently noticed that my Roland A-49 keyboard, that I used to just 'plug and play', is no longer working with Logic Pro X. The light is on and it is fairly new so I doubt that there's a problem with it. It doesn't seem to be triggering any notes, as I can't see any activity in the display window at the top. I've downloaded and installed the latest drivers and followed the instructions for the Audio Midi Setup program, but no good. Strange, because it worked no problem until recently, perhaps it's to do with the latest update?


One NEW thing I noticed since the latest LOGIC update, is that when I connect the A-49 Logic says:

'Creating MIDI keyboard assignments.

Please select MIDI CH 1 on your Roland A Series Keyboard.'

It never used to say this before.


I tried selecting MIDI channel 1 on the keyboard, but it made no difference. According to the manual, when it is unplugged, the keyboard resets to MIDI CH 1 anyway, so it should be set up correctly automatically.


Any ideas?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...