Jump to content

Remove tempo doesn't work when using flex [SOLVED]


Recommended Posts

In a previous post there was a discussion about regions ( associated with imported audio) changing length when flex'd.


The way to circumvent this from happening is as follows.


1/ import the region with flex off

2/ remove the tempo information from the file

3/ delete the region

4/ re-import the audio file ( now without tempo information).


Now when flex'd the region does not adjust to conform to the current project tempo.


The attached demonstrates the issue and how to resolve it.


My question is...When I remove tempo from the file, it does not persist into the region already on the track ( I assume in memory) and that I have to delete it after I remove the tempo information and re-import it again. Is there any way to remove tempo information so that it applies to not only to the external audio file, but also to any regions currently referencing that file in the arrange/main window?



Link to comment
Share on other sites

Yes - I understand that. Please watch the video above in its entirety to get the full picture.


In order to remove tempo - you have to pull the audio file in from the project browser. Now you can remove tempo as you described. However, when you flex the initial region that was pulled in before you removed the tempo - it still flex's as though the initial tempo was still embedded ( even though tempo has been removed it). So you have to delete that region, then re-drag in the audio and then it flex's without that initial adjustment.


I am trying to save the step of deleting the region and re-importing it.



OK: I found another way of doing it...

1/ Import the external audio file

2/ remove tempo

3/ Do a bounce in place

New region now flex's without that initial tempo adjustment ( shortening or elongating the region).

Link to comment
Share on other sites

if you right click on the gif - you can opened it in a new tab or window and see it in full screen mode.




Let me see if I can explain a bit better.


1/ open a new project and add an audio track.

2/ set the global tempo of the project to 400BPM ( this is to exaggerate the point)

3/ Import an external audio file you know has tempo embedded in it ( 60-200BPM) (if not you can create one in logic).

4/ zoom so you can see the entire audio files in the arrange window.

5/ enable flex.

The region will shrink dramatically and be be significantly sped up. (time compressed from imbedded file tempo to project tempo)

(Reasoning why...when you initially flex a region it looks at the global tempo vs the file tempo and flex's based on that ratio and time compresses accordingly. If there is no embedded tempo than the flex assumes the file is at the project tempo and flexing results in no time compression or expansion)


So now with the audio file region highlighted you do the Edit-Tempo-remove tempo you remove the tempo from the audio file.


Now if you flex the region you "CURRENTLY" have in the arrange window - it still time compresses the file. However, if you drag in a new copy of the audio file and flex it - it does not time compress the file ( which is expected because you removed the tempo).


So this generated the question - why does the region that was dragged in prior to the remove tempo not time compress after the tempo has been removed ( it is as though once an audio file is dragged into the arrange window it is copy or in memory version and no longer actually reference the external file).


Hopefully that provides a better explanation of what I am trying to determine.

Thanks for your patience in letting me explaining this.......

Link to comment
Share on other sites

Ok but that wasn't the steps you had on your first post.

When you enable flex a tempo marker is created.

What you want to do is to remove tempo: nothing happens.

Now control-click on the region and chose Reset All Flex Edits.


PS. I like GIFs when they are small and to the point but I really feel that they loose their meaning when you have to open them up in a new tab.

Link to comment
Share on other sites



I did not know about this flex tempo marker. So even after you remove the tempo from the audio file, the flex marker associated with region already in the arrange window remains intact. Resetting the flex markers achieved the exact desired results.

So for others ( unless I am the only one who didn't get this)

1/ I dragged in the same audio file ( with embedded tempo of 80 ) onto two different audio tracks.

2/ Global project tempo is set high(200) and when I enable flex both regions time compress.

3/ I then remove tempo of the 1st track and again enable flex on both and still they do the same( this was the confusing part for me)

4/ I then reset flex marker on track 1 and now when I enable flex.....

Track 1 doesn't move and track 2 compresses.

Absolutely Brilliant!!!!! Well done Mr. Eric!

Ps. this is the smallest I could make it and still provide relevant information.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...