Jump to content

Logic pro 10.2.4 issue on Yosemite ? Recording fine but no audio when playing


guiyome006
Go to solution Solved by David Nahmani,

Recommended Posts

HI from France guys !!

 

Ok ..so to go straight to the point...Got a MBP mid 2014, quad core I7, 16gb ram, Yosemite 10.10.5 (never upgraded since i bought it),  Antelope Orion Studio in Thunderbolt.  I ve (finally) downloaded logic pro this week (10.2.4) as i ve just upgraded my audio interface for an Antelope Orion Studio (took me 10 years ah...was about time!!...) ...i did the latest firmware update on it as i was installing it too...so you know...

 

Fact is i can record audio and midi tracks...no pb...but when i m trying to just play on my actual project THRU an audio track (when Logic is just on play/read mode), nothing happens...!!??!! No sound at all coming from any audio tracks !! Everything s fine with midi tracks and virtual instruments tho...i can play as many as i want when logic is just playing/recording....

 

The other thing is.. in order to get some sound to my stereo out from an audio track, i ve had to untick the "monitoring input only from active track" box in Preferences/Audio/General tab...basically the box just below "software monitoring"...and that did it !!

 

I did not do the 10.11 El Capitain Os upgrade as i ve read many bad reviews on that and therefore was afraid to do so...many people have regretted doing so apparently...

Even tho Antelope is advising to upgrade to El Capitain, i ve just stayed on the safe side.... Today I ve also read a few blogs where people were running Yosemite and Logic 10.2.4 without any issues...So yeah...if someone could explain me what to do to fix this up...wd be great !! 

 

I m guessing it must be a wrong setting on Logic itself (hopefully)...as my audio interface is obviously routed properly to record and playback within Logic. Basically quite frustrated right now as i ve done my researches to fix this up without any solutions yet... Hopefully u guys can sort me out... Thx in advance !! Fingers crossed....waiting to read from you...

 

Guillaume

Link to comment
Share on other sites

I did not do the 10.11 El Capitain Os upgrade as i ve read many bad reviews on that and therefore was afraid to do so...many people have regretted doing so apparently...

Even tho Antelope is advising to upgrade to El Capitain, i ve just stayed on the safe side....

I didi the update to El Cap because of 10.2.4 and no probs.

Do a Time Machine Backup and upgrade. It goes pretty smooth.

Link to comment
Share on other sites

Thx for your reply

 

Well i guess you re right...sounds like it might be the issue there ....after few hours of researching today i think it all comes down to this... Im just a bit surprised as of why the 10.2.4 works on certain people set up with Yosemite tho??...and not on mine!!

 

But eh...those are pbbly the mysteries of the digital world let s say.. Just by curiosity...did u try to install 10.2.4 on Yosemite before upgrading to El Capitain? if so was it working fine for you?

Link to comment
Share on other sites

I have 10.2.4 on Yosemite on one of my Mac and it works fine here.

 

do you think i need to uninstall all my software/applications before doing the upgrade??

Or i just let everything as it is and El Capitain will incorporate everything back in ?

No need to uninstall anything. Just leave everything as is, and you'll find everything the same way under El Capitan. 

Link to comment
Share on other sites

Yes the Orion is correctly set up in Logic...no pb...

I ve troubleshooted pretty much all afternoon ;-)

Found no solution but to upgrade so far..

Logic can playback/read/record fine with the Orion

It s just i can't play over (with an audio track) while Logic is only playing...

But please feel free to let me know if you have other options but to upgrade....not done it yet...but im pretty damn close!!

Link to comment
Share on other sites

i think you talk about the box i ve already unticked

Preferences/audio/main...then underneath "software monitoring" box right??

If so then yes...i Have not selected this option (as told in my very first post i wd have no sound at all if this was selected)

correct me if im wrong

Link to comment
Share on other sites

Good to hear it's working!

 

Anyway...do you think it still worth it to upgrade to El Capitain then ??

It's up to you. Updating can cause compatibility issues with both software and hardware, so if you have the time to troubleshoot those potential issues then yes go ahead and upgrade, but if you're busy working in Logic and everything behaves fine right now in Yosemite, don't upgrade.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...