Jump to content

Varispeed - two pitches coming out when slow


Music Spirit

Recommended Posts

I cannot get Varispeed just to slow down -20% without changing pitch.  When 'speed only' is selected I get an effect whereby the original pitch comes out and then a second pitch comes out slowed down. 

 

As if the Stereo audio file is playing through two different pitch filters ...

 

Is this anything to do with the fact that the Project is Beatmapped? And that Varispeed wont work with Beatmapping? 

 

This is definitely not the midi track - this parallel pitch effect happens when just the audio is solo'ed.

 

NB I have tried to attach a SNIPPED version of the Project with a tiny aif and the Logic document but it wont let me upload the Project ( it and the aif are greyed out when I navigate to the folder on my desktop from  the Attachments menu next to Options at the bottom of the message)

 

1587019609_ScreenShot2016-08-28at19_42_10.png.38c91ad83f6dc11432d0711d752493d0.png

Link to comment
Share on other sites

Great help again - thanks! Here is the Project

 

Just to add regarding the purpose of this post: I am preparing tracks for teaching young jazz musicians  at my local school and also for learning the solos on any instrument. 

 

Add the audio file ( in this case Miles Seven Steps to Heaven) 

Beatmap the whole track ( by playing in Midi Click first, establishing accurate map and then Beatmapping)

Transcribe the a chorus or two ( no real point in doing all of them .. it's overload for the student) but at least an entire chorus of each main instrument

( By the way the Drum solo on this is famous - google it if interested and very hard for me personally to Beatmap hearing the time through the drum solo)

 

Then in attempting to use Varispeed is where I got stuck .. it seems as if just "Speed Only" does not seem to work but Pitch is affected as per my earlier post

 

Ideally you would use Varispeed to slow the track down a bit so you could play along with the solo. 

 

( Incidentally I did not use Varispeed to transcribe the solo - just my ears at normal tempo! I dont like Varispeed for transcribing .. I think it's better to be able to 'hear' the lines played at normal speed _ I find i can do this by looping a couple of bars at at time and then inputting by step or playing the lines in on a keyboard and then quantizing them). 

 

The attached project is just a snippet of the whole thing which would perhaps have taken up too much bandwith to upload here.

 

Look forward to any comments :) 

Seven Steps to Heaven 28 Aug 2016 SNIP.zip

Link to comment
Share on other sites

I am also finding the same here. I am afraid at the moment not in the studio and am on a small 11" Macair using only the built in speakers so I would ask you listen to both (attached logic projects) and let me know if there is any improvement.  

 

Attached are two files......

#1

I took the beat mapped multi-tempo audio file and created a constant tempo (no beat mapped) version. This eliminated the beat mapping yet keeping the audio playing back exactly as you beat mapped it. I then turn on varispeed and believe I still hear the issue.

 

#2

I then turned off varispeed off and using only the global tempo track reduce the tempo by 20%. The seems to sound ok - again would need you confirm please. 

Something is causing some strange artifacting with this audio region with varispeed on at certain speeds, not sure why at this point. However if the global tempo reduction achieves the end result with pitch problem - at least you have a way to do it.   

 

 

Seven Steps to Heaven 28 Aug 2016 SNIP - Constant Tempo No beatmapping.logicx.zip

Seven Steps to Heaven 28 Aug 2016 SNIP - Variable Tempo (20 percent lower).logicx.zip

Link to comment
Share on other sites

I have now checked out both the files and am curious as to your procedure - the first file is what I have been aiming to do!   A slowed down track with the midi transcription playing at the correct pitch. 

 

Am thinking: did you slow the track down and then Bounce in Place so you had an audio file that played correctly at the slowed down  tempo? 

 

This seems to be the way forward  and  a general solution would be to slow the track down first - make a new audio file and then beatmap and transcribe the notes.

 

Look forward to your view - thanks again!

Link to comment
Share on other sites

Ok 

Your initial project tempo is ~278bpm. A 20% reduction would put it at ~223 BPM.

There are two ways to speed up or slow down a song that has multiple tempo's. (Without using varispeed)

1/ you can use the global tempo track

2/ you can use the tempo event list

 

Both are shown in the vid below.  The general process is....

 

0/ Turn off varispeed

1/ Open the global tracks and ensure the tempo track is visible.

2/ Turn on Flex ( I clicked on reset flex markers, but that wasn't necessary - just out of habit )

3/ click on the global tempo track header to select all tempo events

4/ Drag the "line" of the initial tempo from 278 to 224

     4B or you can open the tempo event list and with all of them selected drag so the initial tempo changes per the above.

 

1370056989_slowingdownbeatmappedproject.thumb.gif.b7bfbb061284186c9b1ccebeb8e81190.gif

Edited by volovicg
Link to comment
Share on other sites

And here is a way where to used varispeed and eliminated the multiple tempo events/beatmapping (in case is was the source of the issue with varispeed)

 

0/ turn off varispeed

1/ Select the region and remove tempo information from the audio file.

2/ Turn on Flex

3/ Create a new tempo set

4/ Change the initial tempo to around 260 ( or whatever you want).

5/ Bounce in place

6/ Turn flex off

7/ turn on varispeed

8/ Lower by 20%

 

Now  you have a constant tempo, varispeed works and everything is right in time as it was originally with the beat mapped/multi-tempo initial state.

 

 trumpet pitch issues seems resolved...

                 

 

575556751_varispeedway.thumb.gif.03e5d8e1ff23a5c442a55c6581cc11e3.gif

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...