Jump to content

Adding key command causes spinning beach ball


schmargle
Go to solution Solved by Eric Cardenas,

Recommended Posts

Hi there. I am slicing up a multi-track drum recording to create some samples. I need a way to do something similar to the Tab to Transient feature in Pro Tools. So I've decided to create a key command for the Forward to Transient feature in Logic Pro X. 

 

So, I've gone in and created a new key command. To do that, I go to Key Commands/Edit. I find the function for which I want to use a key command. I choose Learn by Key Label (or Learn by Key Position), then I hit the key I want to use. I've tried the ' (single quote) key and the / key. After I close the key command edit menu and try to use the key command, I get a spinning beach ball, and I have to force quit.

 

What am I doing wrong? Are these some special keys I can't use? I've tried a few others, and they're either occupied or apparently unable to be assigned. I tried the tab key, for example, but that doesn't seem to be assignable. (Instead, when I hit it, the tab is used to navigate around the key command menu.)

 

I have assigned key commands in the past, and they've worked fine, but maybe I'm forgetting something?

Link to comment
Share on other sites

Hi schmargle. 

Not sure why you are experiencing this.

 

Click this link to your signature and add your system information:

• Logic version and sub-version (e.g. Logic Pro X 10.2.4)

• OS X version and sub-version (e.g. OS X El Capitan 10.11.6)

• Computer (e.g. MacBook Pro, Mac Pro, iMac)

• Processor (e.g. 2.2 GHz Intel i7)

• Memory (e.g. 8GB)

• Audio interface manufacturer and model (e.g. RME Babyface Pro)

 

(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

 

I use this function all the time. I first use the marquee tool to create a small selection then it's left/right arrow to go forward or back by transient.

Link to comment
Share on other sites

That sounds like it could be a corrupt preference file. 

 

Try this - be aware that this will reset all your preferences to factory status, so you may want to first export all your custom key commands (if any) for example.

  1. Quit Logic. 
  2. Hold down Option as you click the Go menu in the Finder and choose Library. 
  3. Open your Preferences folder. 
  4. Move com.apple.logic10.plist to your desktop. 

 

Reopen Logic and see if you can reassign your key commands? 

Link to comment
Share on other sites

Thanks for the responses. OK, I think I've narrowed down the issue.

 

Here's what I've done:

—I've moved the preferences to the desktop, assigned the key command, and reopened Logic, as David suggested.

—When I tried to use that key command in my current session (which has about 17 tracks), I got the spinning beach ball once again.

—But when I opened a brand new session, and just dragged in one track, it worked correctly.

—When I went back to the original, 17-track session, I realized that I had several tracks highlighted at once before pressing the key command. If I tried the key command, I got the spinning ball. ....But if I waited long enough, it stopped. So I tried to highlight just one track...and...tada! it worked.

 

So, here's the question, which I guess now is more about Forward by Transient than adding key commands. With the Forward by Transient function, can you only highlight one track at a time? Does highlighting more than one track somehow confuse Logic or require a super huge amount of memory (maybe because each track has a next transient, and Logic has to find each track's transient then determine which transient on which track actually happens first)? I would think that with 16 GB of memory, I should be able to do this...

Link to comment
Share on other sites

  • Solution

Make the marquee selection span over the multiple tracks.

That should be all.

 

1562175785_Transientselection.thumb.gif.d54d3daab92c1ccfea517404c979000d.gif

 

You can also group your tracks and use the Q button to determine which transients that respond to the command.

I would also go through the important files first to see if Logic is recognising the transients at the correct location. 

Link to comment
Share on other sites

Excellent, thank you! Yes, now when I (a) select the tracks first and (b) make sure the Q button is on the right track, it works as it should. If I forget either of those things, it doesn't. I would have thought that grouping the tracks would have been enough to get it to move along, but selecting seems to be required. Thanks for your help!
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...