Jump to content

Locking Midi Channels


tjkoerber
Go to solution Solved by volovicg,

Recommended Posts

Is it possible to lock the midi channel assignment in the arrange window to a specific track? 

 

Let me be more clear, I have 4 different midi controllers, all assigned to different channels on the devices, with corresponding midi channels selected on the logic tracks. Whenever I select a different drum sound, synth module, or anything else, the midi channel gets reset to all, instead of staying locked on 1, 7, or whatever I have assigned to the specific controller. It makes it pretty frustrating when cycling through sounds trying to find the right, synth, drum kit, or while jamming with others. It's a huge pain, and it feels like there has to be an easy solution, I just haven't come across it yet. 

 

I've messed around in environment making templates with transformers, and trying to find a way to make it work, but all that seems to do is to separate the midi channels without having to set channel numbers on the controllers themselves. Any helpful hints? Thanks!

Link to comment
Share on other sites

  • Solution

Try this ( Credit to EC)

in the library ( lower left corner - the gear) enable patch merging.... leave the merge window open as you select different instruments.  Midi channel should remain and not go back to "al"l. If this works - please confirm - (not in front of logic right now)

Link to comment
Share on other sites

@volovicg this seems to be exactly what I am looking for, so long as I click on the new patch directly to load it and don't use the bracket shortcuts [  or ] to switch patches. And yes, it only works while the Enable Patch Merging is open. Have yet to use in a live/jam setup, but seems to be working great. Thanks!
Link to comment
Share on other sites

Hold the shift key down while you press the left [ or right ] to keep the midi channel intact.....

Let me know if that does the trick for you....

@volovicg So, that works and allows me to keep the midi channel set correctly.. but for some reason it jumps straight through to the Logic instruments in the Legacy folder rather than cycling through the plugins in the Drum Kit tab, or the Synth tab in a linear fashion like left [ or right ] would do. That's a little strange, no? I'll try getting rid of the legacy stuff and will see if that helps out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...