Jump to content

Problem with a 3rd Party Plugin in LPX


Recommended Posts

I'm new to the site, new to Logic Pro X and DAW in general, and I am having difficulty finding the info I need to solve a problem.

After several days of watching videos, reading tutorials, perusing the LPX manual, and searching countless websites and blogs, I come here begging for mercy.

The problem I am running into is that everything I look at assumes the reader already has a good understanding of mixing and DAW operation, which I don't.


I have an Avid 11 Rack and started using LPX around 3 weeks ago. I had few issues recording the 11R once I figured out which inputs and outputs to use.

This was pretty much plug and play and went very smoothly. I even managed to successfully record my tube amp using direct out with a simple input change and amp bypass on the 11R. Because I have only been using LPX 3 weeks, my progress is currently based on success/fail, not good/bad.


Here is my problem: I can't make a plugin called "BIAS Amp" work since I can't figure out how to configure it into the mix. I had also purchased Addictive Drums 2 but I didn't have any problems getting it working properly. This BIAS Amp plugin on the other hand refuses to cut me any slack.

I know it is my lack of knowledge in Logic that is the problem since my idea of a mix is 1 track each for drums, bass, and a guitar. If I add an audio track for my guitar and insert BIAS as an effect, the box comes up that allows me to make changes to the plugin. The problem is, everything that I have tried has resulted in no change to the signal from the 11R, either on the recording or while live tracking.

Now before anyone asks what i've tried, I haven't tried much. I've mostly been winging it and researching while attempting to figure out what I should try.

I tried entering BIAS as an effect on guitar track- loads but no change in output signal from 11R. I found an article and tried to follow it by setting the guitar track output to Bus 1 and then entering the plugin as an effect in Bus 1 with output set to stereo output. Again, same problem as before- plugin pops up but no change in output signal from 11R. I am able to get the meters inside the plugin showing activity, but again, no change in signal tone either through the monitors or recorded.

Honestly, I need somebody to treat me like a child who knows nothing and help walk me through how to set this up. Please? 

I appreciate any help you are willing to offer. Thanks.

Link to comment
Share on other sites

Just thought I would go ahead and repost to this thread since this problem is solved.

After talking with the company, as expected, it was a stupid error on my part. 

Apparently I failed to notice that the plugin defaults to a clean amp every time I close Logic.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...