Jump to content

Dragging note velocity sends G-2 note data bug?


mc_deli

Recommended Posts

While using Plogue Chipsounds I got strange behaviour: when I dragged the note velocity of random notes in the controller pane of the piano editor in 10.3.1 it triggered a G-2 note event - I noticed it because it triggered a keyswitch.

 

Over on the Plogue forum here : https://www.plogue.com/phpBB3/viewtopic.php?f=17&t=8023 the resident advisor says it is a 10.3.1 bug - can anyone confirm this with e.g. another system or software instrument?

Link to comment
Share on other sites

You can download Snoize's free MIDI monitor to spy on Logic's output. I just tried and Logic doesn't send any MIDI events when using the velocity slider in the Piano Roll inspector. 

Hi David, how about this: https://www.youtube.com/watch?v=oh2C4C_tst8&feature=youtu.be

This is fresh today, 10.3.1, empty project, Snoize, video showing note velocity drags sending G-2, made by Plogue engineer.

Does this help explain better - can you reproduce this?

Link to comment
Share on other sites

I meant choose that from the top menu in Logic. But in any case I spent more time with this issue today and was able to reproduce it. Bypassing control surfaces does not help. Nor does turning off MIDI Out. 

 

Seems like a bug with Logic Pro X. 

OK thanks for that. Glad it wasn't Chipsounds (the ace VI I was using when this happened - highly recommended)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...