Jump to content

Emagic MT4 - will it work on Sierra?

Recommended Posts

Hi all


I'd like to use my old Emagic MT4 MIDI interface with Sierra and Logic Pro X. Plugging it in via USB I get the red patch light but not the USB light. I see there is a Unitor 2.5 driver but I'm guessing this is now redundant - when I try to install it said: "Your computer does not need this update". Oddly I tried once more and it installed, but still no joy.

Any clues??

Link to comment
Share on other sites

I think I did install a driver many incarnations ago, but not sure if that's still pertinent. A search for "emagic," or "MT4" shows nothing.


here's a screenshot under "Audio Midi setup" - which might be the best place to troubleshoot. Assuming you know what that it and where to find it? I think I ultimately added it from inside that area. It has always simply worked - I've used it since Yosemite and earlier, on this same MacPro


Link to comment
Share on other sites

Thanks David - I have that installer and as mentioned, when I first tried to install it said: "Your computer does not need this update". Oddly I tried once more and it installed, but still no joy.

What have you tried exactly? Do you have a MIDI keyboard connected to the MT4? Have you tried playing that keyboard and see if it can trigger an instrument in Logic?


Since the MT4 appears in Audio MIDI Setup and is not grayed out, that indicates that your Mac recognizes it as connected - so it should work? 

Link to comment
Share on other sites

Thanks everyone - put this one down to user impatience!! So I assumed it wasn't working as only the patch light came on when plugged in, but as soon as I open AMS or Logic Pro X the light switches to USB - and works fine for MIDI coming in from my old controller keyboard. I didn't get this far when I posted the question as I gave up when I saw the Patch light - note to self - be more patient! So apologies for the false alarm and thanks for all the ideas and encouragement!!

Only unanswered questions I suppose are whether I needed to install the driver at all or whether it would have worked with drivers supplied by MacOS - something for another time I guess!


Thanks again



Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...