Jump to content

channel strip setting behavior


Cevyn

Recommended Posts

Hello i have updated logic x and am running on high sierra.  My channel strip settings button is non responsive in the mixer.  In the drawer if i click on small arrow next to button, the drawer opens and shows me the options but all user settings are gone, and even when i save again there the presets do not show up again. also the drop down menus are red which is completely different. i have reinstalled both logic and high sierra- but the behavior continues- any help would be greatly appreciated
Link to comment
Share on other sites

here is my screen shot of the music folder.  I did throw that in to the trash as advised by this forum and it did fix the greyed out setting button. However it didn't resolve the drop menus to all be red.  this happens in both logic and MainStage.  Let me know if you have any thoughts on that- thx for your help!

307130986_ScreenShot2017-09-29at5_42_51PM.thumb.png.2edefd95c4509ef4a93677cc1dea4f43.png

1878305242_ScreenShot2017-09-29at5_45_54PM.thumb.png.eb66ad0b0bc0b193d6aeeeaa8ea231fc.png

Link to comment
Share on other sites

I have a very, very similar problem.

Channel-strip "Settings" buttons everywhere have become completely unresponsive.

User EXS instrument patches have become un-linked from Logic.

 

I have recently downloaded a lot of Apple content using LPX Library management tools, and reorganised some of my external HD folders.

Either activity could have caused some of my problems.

 

I think need to know, for LPX 10.3:

1) Where exactly the various folders related to user channel-strip .cst files, EXS instruments and EXS settings “should” be, including

2) What those locations should look like in the Finder, in terms of named sub-folders.

 

Hopefully I can then work out where to put alises or file-copies to get my own settings, etc, to appear alongside factory ones.

(Puzzled by the total unresponsiveness of the Settings buttons, though.)

 

Detail:

Migrating from LP8 I established a regime using aliases to invoke to my own .cst and EXS-related files, which were kept in folders on an external HD. That worked well for both saving new settings and patches, and retrieving everything previously saved.

Under that regime I was also able to reorganise my .cst files into whatever folders and sub-folders I wanted (on the external HD), via the Finder. The channel-strip Settings pop-up would update itself accordingly: click-hold on any channel-strip Settings button produced a pop-up of factory options, plus my own in separate segment lower down.

My own EXS Instruments and Settings could be invoked in a similar way from within the main EXS GUI pane.

 

All this functionality has disappeared. As stated: Settings buttons are completely unresponsive. The EXS GUI now shows factory instruments (related to recently downloaded Apple content) but all my own instruments/settings are missing.

 

My user files (.cst, EXS-related) still exist in their folders on the external HD, but are seemingly adrift  from LPX.

 

Unfortunately I did not keep track of exactly how/where I placed my aliases to combine Apple and user content. I also fear that Apple content migrated from LP8 as well as my own patches, etc, has been mixed-up, overwritten or otherwise "frozen out" as a consequence of downloading new content with LPX Library tools.

Should I trash everything Logic-related and start again?

Link to comment
Share on other sites

Here's my fix to my own problem as described above (Channel Strip Settings buttons dead, missing EXS instrument+settings). It's a long post, but some of the detail might be useful to others trying to diagnose similar problems to do with keeping LPX user settings on external HD.

 

I did not need to trash LPX app files, or preferences. I just looked carefully into my Mac user account ‘Audio Music Apps’ folder via the Finder. A key step was getting over the fact that nowhere in that folder is there any mention of 'Logic'. For those with my issue, I suggest:

 

- Quit LPX.

 

- In Finder, go to: users/YourName/Music/Audio Music Apps

 

- Drag to a temporary folder outside system/user level everything in ‘Audio Music Apps’ that might have to do with LPX channel strip or instrument settings. In my case that was: folders called 'Alchemy Samples' and 'Patches' and an old file called ‘IOLabels Core Audio’.

 

Keep the ‘Audio Music Apps’ Finder window open, positioned so that you’ll be able to see its contents easily after launching LPX.

 

- Launch LPX. Make a new LPX project with (for e.g.) an audio, an Aux and an EXS track. Open a separate ‘Mixer’ window.

 

- Make a bit of space on-screen so that you can see the Finder window showing your ‘Audio Music Apps’ folder.

 

- As you click on channel strips/settings, etc., watch what happens inside the ‘Music Audio Apps’ Folder.

 

[at this point my previously-frozen Settings buttons in the Mixer channel strips became active, although the invoked pop-up showed only Apple factory options]

 

- Look out for  folders appearing, such as ‘Channel Strip Settings’. Let’s call these ‘default’ folders. If these default folders are ones that would logically contain settings that you wish to keep elsewhere (e.g. on external HD) you will need to replace them with aliases that point to your replacement folders, and destroy the defaults. The aliases must have exactly the same name as the LPX-generated defaults they are replacing.

 

Remember, what you do to any LPX resources in the ‘Audio Music Apps’ folder is only going to affect the user settings in LPX. Factory settings reside in another location entirely (SystemHD/Library/Application Support/Logic).

However, do also be aware that LPX resources that have nothing to do with your problem could also be kept in the ‘Audio Music Apps’ folder (??and even resources for other apps - here I’m not sure). Proceed carefully, keeping a note of what you’ve done. Don't destroy any moved data for a few days, until you've gone through all the processes that could have been affected.

 

I have a folder called ‘Channel Strip Settings’ on external HD, containing a variety of settings in sub-folders. If you are in my situation, then:

 

- Make sure your ‘Channel Strip Settings’ folder is in a location from which it need  “never” be moved. Make an alias of it. Drag the alias directly into the user ‘Audio Music Apps’ folder.

 

There is no ‘Logic’ sub-folder in the ‘Audio Music Apps’ folder. LPX-related folders reside there, mixed up with other folders created by LPX (and perhaps by other audio/music apps - again, I’m not sure).

 

Within 'Audio Music Apps' you now have an LPX-generated ‘Channel Strip Settings’ default folder and an alias called ‘Channel Strip Settings alias’ (or similar) that points to a folder of your own creation, elsewhere.

 

- Drag the LPX-generated ‘Channel Strip Settings’ folder out to a temporary location, then rename your alias ‘Channel Strip Settings’. Do this in the Finder, with LPX in the background, so as to avoid touching anything in LPX that would trigger the re-creation of the folder you are trying to replace with an alias.

 

If this has worked, when you invoke the Settings in a channel strip the pop-up should show both factory settings and your own settings in a separate, ruled-off section.

 

AudioMusicAppsALIAS_eg.thumb.jpg.c2126df644e123097953cbb7765bc172.jpg

The attached jpeg shows a detail of my own 'Audio Music Apps' folder viewed in the Finder. Note the three aliases in the folder. Note that everything in the  columns to the right of the ‘Audio Music Apps’ folder column resides on external HD, and in this instance is invoked -in the Finder as from within LPX-  via the ‘Channel Strip Settings’ alias. To absolutely clear: the Channel Strip Settings themselves (that is, my own 'user' settings) are on an external HD.

Link to comment
Share on other sites

thanks for the feedback- i have resolved the issue about the setting button. that was suggested in another thread to trash the music apps folder. however the red drop down menus are still a strange thing to look at in both logic and MainStage 
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...