Jump to content

Strange MIDI behaviour with plug-in


amusong

Recommended Posts

I have purchased Tina Guo cello legato sample for Kontakt 5 Player use in Logic Pro X.  I only updated from Logic 9 to Logic X a few days ago so that is new to me.  The cello samples I only got loaded onto Kontakt 5, and appeared to get working, last night.  

 

I have 2 MIDI input options, the inbuilt 'musical typing with keyboard" in Logic X, and a Nord Stage 2 keyboard (yes I have turned the MIDI section on on the Nord).  I can get the cello samples to play using the in-built "musical typing" in Logic.  However, with the Nord, although I can see MIDI input occuring up in the transport area in Logic, I cannot hear the cello samples play as I record.  

 

However, here's where it gets a bit strange.  For BOTH keyboards, if I hit "Record",  there is a region of MIDI data recorded.  However, when I play back the track, although I can hear the cello part recorded by musical typing, I cannot hear the data recorded by the Nord (even though I can see the MIDI notes there!).  

 

In the attached image you can see the regions for each keyboard.  The pink region is recorded by the Nord but does not generate any audio output - when I play the track, even though there a MIDI notes there, no sound is heard.  The yellow regions are recorded by "musical typing", and generate audible audio output just as I would expect (and very nice it is too!).  So basically although the Nord shows every appearance of working, both in the transport section of the display and by creating a MIDI data track, there is no cello sound from the Nord either during recording or on playback.

 

Are you able to shed any light on this for me?  I am very keen to try the Tina Guo cello samples in a project that I am working on but need to use a proper keyboard to do it, so am stuck at present.

 

I should also mention the following:

•  I am long time Logic 9 user so not entirely new to this software.

I also opened a Logic 9 project just to check that the Nord operated as it should on MIDI input in Logic 9, and it did.  I have used the Nord many times for MIDI in Logic 9.

753279625_ScreenshotTinaGuoinLogicX.thumb.jpeg.bcae8ef9ab4ef071ccb42bc7602cb3e8.jpeg

Link to comment
Share on other sites

Sounds like a MIDI channel issue. Your Nord is probably transmitting on a different channel than the one that the instrument listens to (Channel 1 in your example).

 

You can set the track to MIDI channel 1 in the track inspector pane and you should be good to go.

Or you could change the channel that the Nord is using.

Link to comment
Share on other sites

Thanks very much Eric, that got me some cello sound from the Nord regions.  

 

I am curious though......the default selection for MIDI was already set "All" so I would have thought that "all" would have included Channel 1 too.  Why didn't it?

 

As a supplementary question, I really don't know anything much more about MIDI than plugging my keyboard in.....it has always just worked in the past.   But now I am interested.  Channels....what are they?   Would you by any chance know of a good internet tutorial on how MIDI works on Logic so I can bone up on this topic.

Link to comment
Share on other sites

Thanks very much Eric, that got me some cello sound from the Nord regions.

 

You're most welcome.

 

I am curious though......the default selection for MIDI was already set "All" so I would have thought that "all" would have included Channel 1 too.  Why didn't it?

 

Logic's 'All' setting passes the MIDI channel that your controller is sending or the channel from the sequencer.

Setting it to 1 will modify all messages to channel 1.

 

Kontakt is a multi-timbral instrument, meaning it will differentiate between MIDI channels.

By default it is setup to set the first instrument you load to channel 1, second to channel 2, and so on…

If you look at your Cello in the rack you can see that it is assigned to MIDI Channel: [A]1. A is the port and 1 is channel 1 of 16.

Try changing this to omni and that instance will respond to any channel even if you set Logic's instrument channel to All.

 

 

As a supplementary question, I really don't know anything much more about MIDI than plugging my keyboard in.....it has always just worked in the past.   But now I am interested.  Channels....what are they?   Would you by any chance know of a good internet tutorial on how MIDI works on Logic so I can bone up on this topic.

 

You can think of channels as you think about channels on a mixer. Each channel has it's own volume, pan, and other modulations available to it.

I believe this is a good start to understanding MIDI:

MIDI 101 by TweakHeadz Lab

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...