Jump to content

10.4 editing midi CC automation in arrange window is missing


jculp3
 Share

Recommended Posts

In 10.4 I used to use the F1 key command (can't remember if that was something I set up - or Logic...) to open CC midi automation inside a midi region in the arrange page, without having to open the piano roll. This was so helpful. Just downloaded 10.4, and realized that this key command now opens some other type of audio automation. Anybody else having this issue? This was so helpful since I could edit CC data easily on tracks side by side in more of a group view.
Logic 10.5.1, OS 10.14.6, MBP 15" 2016 2.7 Ghz i7, 16gb ram, UAD Apollo/Twin, LaCie 1TB SSD.
Link to comment
Share on other sites

Just found the answer on another post by David...

 

MIDI Draw has been incorporated into Region automation:

1) Click the Show/Hide Automation button in the Tracks area menu bar to view automation data.

2) Make sure the Automation button in the Track header is set to "Region."

3) Use your usual key command (default is Command-Y).

Logic 10.5.1, OS 10.14.6, MBP 15" 2016 2.7 Ghz i7, 16gb ram, UAD Apollo/Twin, LaCie 1TB SSD.
Link to comment
Share on other sites

Thanks David!

 

Another thing with this new way to view midi automation... I found that Logic is not displaying anymore (in the track header, nor the region) the midi CC#. In previous Logic versions, Logic would show the CC# in the region and this is what I would go by. Now for instance, Logic calls CC#12 - "Ch.1 Effect#1 MSB". Seems useless to me. Is there a way to change this back to showing just CC#? thank you!

Logic 10.5.1, OS 10.14.6, MBP 15" 2016 2.7 Ghz i7, 16gb ram, UAD Apollo/Twin, LaCie 1TB SSD.
Link to comment
Share on other sites

I'm finding I can display the CC information but as soon as I hit play it disappears.

 

Trap! I have fallen in few days ago.

It means that there is a new option making the parameter of the instrument sending midi info.

It's cool because as soon as you move a parameter inside the plug, the automation show what parameter .

But backwards, it's now a mess for the CC editing.

To deactivated this, go to main menu MIX and deactivate Autoselect Automation Parameter in Read Mode.

Back to usual stuff.

Kind off midi loopback.

Your CC data point to a midi parameter of the instrument.

BUT, as soon as you hit play, the plug read the CC data and send the related played parameter, but it's not necessarily the same midi data ...

Hard to explain but, you know ...

Edited by Tribalman
Mac Mini i7 Late 2012 / OS X 10.12.6 / LPX 10.4.2 / 16G ram / RME Fireface 802 / SSD 840 Pro 512 for system and virtual synth datas / USB 3 Ext SSD 850 EVO 512 Gig + Akitio NT2 U3 ( Raid 0 ) 2To SSD for Kontakt and temporary audio stream / Int HDD 1T for Audio & samples Back up
Link to comment
Share on other sites

In your first pic oddball, it is showing the automation as "Ch. 1 Modulation". In the past, this would be shown as "CC#1". Now, we all know that "modulation" is CC#1, but when you get into the higher numbers it becomes less apparent what CC# you are dealing with, which makes it more difficult to know which parameter you are trying to adjust. For instance, Logic now calls CC#12 "Ch.1 Effect#1 MSB". This description seems useless to me. I'm wondering if there is a way to change this back to showing just the CC#.
Logic 10.5.1, OS 10.14.6, MBP 15" 2016 2.7 Ghz i7, 16gb ram, UAD Apollo/Twin, LaCie 1TB SSD.
Link to comment
Share on other sites

I'm wondering if there is a way to change this back to showing just the CC#.

As I said just before try this :

To deactivated this, go to main menu MIX and deactivate Autoselect Automation Parameter in Read Mode.

Mac Mini i7 Late 2012 / OS X 10.12.6 / LPX 10.4.2 / 16G ram / RME Fireface 802 / SSD 840 Pro 512 for system and virtual synth datas / USB 3 Ext SSD 850 EVO 512 Gig + Akitio NT2 U3 ( Raid 0 ) 2To SSD for Kontakt and temporary audio stream / Int HDD 1T for Audio & samples Back up
Link to comment
Share on other sites

I did what you said and it still calls CC#12 "Ch.1 Effect#1 MSB". I only want Logic to display it as "CC#12" and not "Effect #1 MSB." What am I missing here?
Logic 10.5.1, OS 10.14.6, MBP 15" 2016 2.7 Ghz i7, 16gb ram, UAD Apollo/Twin, LaCie 1TB SSD.
Link to comment
Share on other sites

I did what you said and it still calls CC#12 "Ch.1 Effect#1 MSB". I only want Logic to display it as "CC#12" and not "Effect #1 MSB." What am I missing here?

And it goes like : you see CC#12 when logic not playing, and as soon as you hit play, it disappear ?

Right ?

I had that and deactivating the option I pointed to, it's back as before ...

Mac Mini i7 Late 2012 / OS X 10.12.6 / LPX 10.4.2 / 16G ram / RME Fireface 802 / SSD 840 Pro 512 for system and virtual synth datas / USB 3 Ext SSD 850 EVO 512 Gig + Akitio NT2 U3 ( Raid 0 ) 2To SSD for Kontakt and temporary audio stream / Int HDD 1T for Audio & samples Back up
Link to comment
Share on other sites

Okay, not the same thing as the two pictures from Oddball above , sorry .
Mac Mini i7 Late 2012 / OS X 10.12.6 / LPX 10.4.2 / 16G ram / RME Fireface 802 / SSD 840 Pro 512 for system and virtual synth datas / USB 3 Ext SSD 850 EVO 512 Gig + Akitio NT2 U3 ( Raid 0 ) 2To SSD for Kontakt and temporary audio stream / Int HDD 1T for Audio & samples Back up
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...