Jump to content

MIDI 'Overlap' feature not working in 10.4


Recommended Posts

I've scoured and found 'solutions' to this in older posts - but since the update i'm simply trying to record midi over existing midi(and keeping the original) and place midi regions on top of an existing midi so that they both play - none of this is working. It just erases the original midi no matter what i do. Yes, i've got drag set to 'overlap', and in the dropdown menu under 'record', 'overlapping midi recordings' i've got the default settings 'merge' selected (albeit i've tried every other permutation also). There must be something i'm missing.
Link to comment
Share on other sites

Choose Record > Overlapping MIDI Recording > Overlap.

Make sure your Replace mode is off.


Thanks David, but i have tried all of that - Replace is definitely off and have tried all options under 'record'. What i didn't mention was this project was started before the update in 10.3, so i'm wondering if it's got something to do with having to start a fresh project off in 10.4

I've since discovered that when starting a new project in 10.4 - there are no issues at all - so i was able to export two midi regions to a fresh project file - merge them - then export them back where they play as one in the 'offending' project! It's far from ideal, and i'm still perplexed as to why Logic wants to overwrite the midi - but i hopefully should be ok for any future projects now. Thanks again :-)

Link to comment
Share on other sites

Then yes it sounds like an issue with using an older project in 10.4. They did change the way those options are organized along with the Replace mode so that's most likely what's messing with your older project. You could try reimporting all your tracks, regions, automation, plug-ins, global tracks etc... into a newer template using the All Files Browser.
Link to comment
Share on other sites

  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...