Jump to content

External Midi track stack, input monitoring


hecksome
Go to solution Solved by hecksome,

Recommended Posts

I've created a track stack that consists of an external midi channel (Midiplus TBox 2x2) and an audio input to control a hardware synth. The issue I'm having is that once I record the audio, if I leave input monitoring enabled on the audio track, I still hear the midi that I recorded as well even if the midi channel is muted. I either need to press control M to mute the region, or cut the region out to solve this. I prefer to leave the audio input monitoring on so I don't have to click it next time I record.

 

Is there any other way to solve this?

Link to comment
Share on other sites

I guess what I mean is, why can't I just mute the track? Why does the individual region need to be muted instead?

 

It would seem to me that muting the track should make the midi track stop sending information to the external synth, but that's not the case, right?

Link to comment
Share on other sites

I guess what I mean is, why can't I just mute the track? Why does the individual region need to be muted instead?

 

It would seem to me that muting the track should make the midi track stop sending information to the external synth, but that's not the case, right?

 

I agree that muting the MIDI track should stop sending any information. Maybe something going on with your MIDI interface?

Link to comment
Share on other sites

Long shot this, but you don't have any kind of plugin on the external instrument/midi channel that communicates with your external synth do you? I used to have this problem with the Novation Ultra/Mininova's and their editor - even when the midi track was muted it would still be sending the notes through to the keyboard.
Link to comment
Share on other sites

why can't I just mute the track?

It's a bug.

 

The "M" button on a track header is a remote control for the "M" button on the channel strip assigned to that track. The thing is, external MIDI channel strips do not have a "M" button. That means the "M" button on their track headers... doesn't do anything at all. :roll: Always been that way. That "M" button shouldn't even be there in the first place.

 

So you're left with muting the regions as you've been doing, or turning the external MIDI track off which is a more elegant workflow:

 

logic-001.png.cafe3308a0c170ade0be87ea6c7f6883.png

Link to comment
Share on other sites

  • Solution

Thanks all for your help! I'm on 10.4.1

 

Ok, so now I'm discovering that mute DOES actually work when I create a new external midi channel, but for me does not when using the external instrument plug in on an empty channel strip. The external midi channel mute used to not work like this (I swear!), glad that's fixed!

 

I started using the external instrument setting so I could use midi FX plugins, but I'll go back to using an external midi track and call that good enough.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...