Jump to content

quantizing problem when using Flex Pitch


nixoblivion

Recommended Posts

Hi Guys,

 

I keep having these Problems when i use flex pitch in logic pro x.

Its really awkward.

I like to use flex pitch for slight pitch shifting, some region movement (timing) and gain function of single words.

I think its great for that, if you dont overdo it.

 

But every now and then i get this weird problem where my whole region seems to shift. It seems to do some sort of quatize to the grid i have or something. I made sure to not use the quantize function in the flex mode (have never used it before), but something seems to shift all my audio.

I have 2 audio examples so you can hear what i mean.

 

No Flex

https://www.dropbox.com/s/45lzgrsqsi9d319/no%20quantize.mp3?dl=0

 

with Flex

https://www.dropbox.com/s/w8dt1n5vbd0pfk0/quantize.mp3?dl=0

Link to comment
Share on other sites

I have no idea. :D

I have never used the new Tempo modes. Just read about them.

 

What should it be set to? Also i noticed when i open the Flex mode now (which i initially defined as Flex Pitch) it openes the 2nd Tab that is tempo Flex... Haven't had that happen before.

Link to comment
Share on other sites

How do i deactivate the "File Tempo"?

I have added a screenshot to show what i mean.

 

I seem to somehow always activate this File Tempo mode, that moves the Time of my Regions!

All i want to do is get into Flex Pitch mode to edit the pitch and timing manually.

 

I double click the region and then Click on Flex mode. Change the Flex mode to Flex Pitch, to edit what i want to do. Most of the time this works. Sometimes it seems to go into File Tempo mode though and changes the timing of my region.

Very frustrating!

1964320320_ScreenShot2018-05-14at15_56_35.thumb.png.74109982491555d9d7818531831ca836.png

Link to comment
Share on other sites

so why does the tempo get edited?

Because when you turn on Flex Time the tempo information embedded in the audio file is used to make the audio file follow the tempo of the project.

 

what am i doing wrong that logic assumes i want to edit the tempo??

You're using Flex Time on an audio file that has embedded tempo information.

 

how do i avoid this in the future?

The same way you just did: either remove the tempo information from the audio file, or do not use Flex Time.

 

Note that this is normally not an issue with audio recorded inside the current project as long as you don't change the project tempo after recording.

Link to comment
Share on other sites

Thanks for the detailed response!

 

Note that this is normally not an issue with audio recorded inside the current project as long as you don't change the project tempo after recording.

 

Interesting. I'm always using Audio Files recorded in the current Project and i did not change the Tempo (knowingly).

This is not the first time this has happened to me!

 

You're using Flex Time on an audio file that has embedded tempo information.

So then what is the easiest way to get in to Flex Pitch, without getting into Flex Time??

The way i use is to double click the Region to enter into the "Audio editor" and then Press the Flex button. This automatically puts me in Time Flex. I then change to Pitch Flex.

Most of the time this works!

The strange thing is that my Time does not change at first. Its after a while that suddenly the time is off.

Link to comment
Share on other sites

Interesting. I'm always using Audio Files recorded in the current Project and i did not change the Tempo (knowingly).

In that case, turning on Flex should not change the playback speed of the audio file because its embedded tempo is the same as the project tempo.

 

You're using Flex Time on an audio file that has embedded tempo information.

So then what is the easiest way to get in to Flex Pitch, without getting into Flex Time??

You can't. But really watch your workflow, if as you said the audio is recorded in the current project and you don't change the project tempo after recording then it's not an issue. If you do change the tempo then you have to remove the embedded info from the audio file.

Link to comment
Share on other sites

ok Thanks David.

Its strange, because i rarely change tempos in a song and i rarely import audio to a project with a different tempo, but you never know :)

 

Is there any other quantizing option in Flex that can be activated somehow?

Thanks for your support guys!

Link to comment
Share on other sites

So Back to the topic at hand. Im back to mixing the project where i had this problem.

 

here is the link of the same part again. (just the vocals)

https://www.dropbox.com/s/cpeqyw2cv4cxa66/quantize%202.mp3?dl=0

 

the timing is correct now, but you can hear aliases/artifacts inbetween the words and later on they get worse!

I removed the tempo information from the file. Turned on Flex Pitch again and this is what happens. I did not Pitch a thing yet...

whats going on? it seems to be some automatic quantizing of the file.

 

edit: i must add this is a live recording. you can hear the saxophone in the bleed and that is what sounds weird!

Link to comment
Share on other sites

I listened to the last audio region and I can hear a bunch of artifacts. But they are caused by your vocal take that has a bunch of bleed making it polyphonic, which FlexPitch can not handle.

 

Just to confirm that this is the issue you are hearing. – Try setting the Flex algorithm to polyphonic instead.

Will that help you get rid of those artifacts?

Link to comment
Share on other sites

Well what i want to do is just change the Pitch of the vocals, not the timing. So using anything else but Flex Pitch is useless in my situation.

Does this mean, i can not use Flex Pitch in a case like this with bleed in the channel?

 

Yes these artifacts are one of the problems i have.

The second problem is the fact that as soon as i activate Flex mode in this Region you are listening to, the whole region moves back! It is no longer in time with the rest of the song. You can see it in the waveform..

Link to comment
Share on other sites

Does this mean, i can not use Flex Pitch in a case like this with bleed in the channel?

Correct. You need Logic to be able to easily identify the pitch of the recording in order to be able to manipulate it, and if there's tons of bleed that's going to be challenging for Logic to identify the pitch of the vocals.

 

The second problem is the fact that as soon as i activate Flex mode in this Region you are listening to, the whole region moves back! It is no longer in time with the rest of the song.

I believe we've exhausted the discussion on that problem though:

 

1) The audio does not move if you don't change the project tempo. To verify this behavior on your own, open a new empty project, create one audio track, record something for one or two bars, toggle Flex Time on/off, the audio stays put.

 

2) If you do change the tempo then you have to remove the tempo information from the audio file. Then you'll be able to use Flex without the audio moving.

Link to comment
Share on other sites

Correct. You need Logic to be able to easily identify the pitch of the recording in order to be able to manipulate it, and if there's tons of bleed that's going to be challenging for Logic to identify the pitch of the vocals.

Thanks. I get it now! :) i did not think about the bleed part.

I believe we've exhausted the discussion on that problem though:

 

2) If you do change the tempo then you have to remove the tempo information from the audio file. Then you'll be able to use Flex without the audio moving.

 

hmm.

Ive tried deleting the audio tempo in the vocal track several times. still everytime i activate flex, it moves the audio parts (not the whole region).

When i create a new project and record new audio material this does not happen, therefore something must have changed in my project, but not sure what it is!

Link to comment
Share on other sites

This is driving me so crazy!!

Im so sorry for bothering you guys so much! But this just makes no sense to me!

 

On the two pictures you can see all three regions WITH and WITHOUT Flex Pitch enabled (Flex and Follow On and Off).

As you can see one Region moves! The other two regions stay on the same spot!

 

On the attachment i posted its the 2nd region that moves. Later in the song i did the same thing with Flex Mode On and Off and it was the 3rd region that moves!!

I really don't get it.

 

The song tempo is 120 (keep). I havent changed it, its not even the tempo of the song cuz we did not record to click....

can someone explain this to me??

9659324_ScreenShot2018-05-16at21_32_40.png.325f5d22118a97401c077eea44edeb6c.png

59427526_ScreenShot2018-05-16at21_32_50.png.4b98c90daad3f1f8d5a29f9914a4ac91.png

Link to comment
Share on other sites

Hi David,

 

Someone gave me the Tipp of doing it this way!

 

But in this case i should not have to delete any audio tempo since i did not use the Grid or change the tempo or anything. The Tempo has been 120bpm since the beginning! Never changed it.

 

Im starting to think it has to do with the Regions.

Yesterday i was trying the same thing again and with the short regions that i have, the audio moved. When i was using regions that started from the beginning of the track, i did not have this problem anymore! might be a coincidence, who knows.

Also sometimes it worked better when i "Bounce in Place" the track to a new Track and then edit it in Flex.

It seems that some Setting is wrong with some of the Tracks.

954124884_ScreenShot2018-05-17at15_50_59.png.1301fe0a60cc81963d5402f7199a4520.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...