Jump to content

Recording Kontakt Script Generated Notes


UK User

Recommended Posts

I have been experimenting with trying to record Kontakt script generated notes into Logic, specifically with "The Orchestra", which uses arpeggiators to create rhythms.

 

What I did was to open a standalone instance of Kontakt, set it to output script generated notes and makes sure the Kontakt Virtual Output is switched on. I also set Logic to output sync with the external Kontakt to lock both tomthe same tempo.

 

Here is the issue. If I record a passage, while it is recording the note lengths appear to look about right, correct notes, velocity data etc.

 

Once recording is stopped the note lengths change and each note extends from its start point right to the end of the passage. So each note overlaps and extends to the end of the region.

 

I have checked to make sure no quantising is set on record in the inspector. I just cannot seem to work out why it changes after I stop recording? Any ideas why this is happening, or is this a bug in the way Logic deals with midi from script generated notes?

Link to comment
Share on other sites

So I put a midi monitor on the output of Kontakt standalone and only see Note Ons, not sure if this is the cause?

 

I tried a different library by Soundiron called Symphony Series Woodwinds that also has an Arpeggiator and get the same result. So I am guessing both use the same built-in Kontakt functionality but may be wrong.

 

What I find weird is that during recording the notes look the right length, but when recording stops the single note off generated by lifting off the keyboard is where all notes extend to. Is this expected behaviour? It seems like the single Note Off is overriding the incoming note lengths?

 

Maybe its just not possible, but it seems the Kontakt Arpeggiator does not generate note offs. Is there some kind of Kontakt script that could add these for each note?

Link to comment
Share on other sites

Make sure the logger is configured to display noteoff messages. If the noteoff messages aren’t being sent the that is definitely the problem. I don’t know why Logic first shows them short, that implies the noteoff’s are being sent.

 

However there is another point here that you have overlapping notes being sent out. The script is sending, apparently, both the notes of when you play the keyboard, as well as the arpegiated notes. I would presume that you only want the arp noteon and noteoff sent.

 

My theory at the moment is that noteoff is sent, check settings. Thr arp noteoff cuts off sound for both overlapping notes and that’s why LPX starts out sounding correct and displaying correct note endings. However at the end you have one final noteoff for the played notes and logic must make some assumption and figure something out to display the long held notes

 

If you select a couple of those long notes and delete them are the short notes hiding underneath?

 

The real problem is that kontakt script should not send the held note it should only send the arp note and noteoff’s

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...