Jump to content

MIDI channel field in track inspector does not work properly


enossified
Go to solution Solved by des99,

Recommended Posts

I have come across a fatal problem.

 

I recently switched controllers from a Novation Impulse 61 to a Nektar Panorama P6. I was working on a project using the Panorama and went to edit in the piano roll. When I selected a single note and moved it, I saw there were actually two notes, one overlaid over the other. Moving the one on top exposed the one underneath. I opened up the events list and verified that this was indeed the case. Every single event and control message was in the list twice on two different MIDI channels, 2 and 4. :shock:

 

Confused, I launched MIDI Monitor and started pressing keys on the Panorama. The monitor showed that each key sends identical messages on channels 2 and 4, as do sustain pedal, expression pedal, wheels, etc. It did this whether or not Logic was open. So I relaunched Logic, opened the track inspector and changed MIDI channel from All to 1 expecting that the track would no longer respond to the Panorama keyboard. However I could still audition and record the software instrument on the track! In fact I tried all 16 channel settings in the track inspector and no matter what channel was set the track still responded to both channels 2 and 4. The event list showed messages arriving on both channels 2 and 4, regardless of the setting made in the Track Inspector :evil:

 

Just as a sanity check, I closed Logic and launched Ableton Live. Setting the MIDI input on a track to anything except All, 2 or 4 caused the track In Live to not record notes from the Panorama...as expected.

 

OK, why is Logic totally ignoring the MIDI channel setting in the track inspector?

 

In the meantime I will be contacting Nektar about this issue.

Edited by enossified
Link to comment
Share on other sites

  • Solution
Every single event and control message was in the list twice on two different MIDI channels, 2 and 4. [/b] :shock:

 

Sounds like the keyboard was in Layer mode and sending out two layers, one on MIDI channel 2, and one on MIDI channel 4.

It's common for controller keyboards to have multiple zones or layers to let the user easily layer sounds.

 

So I relaunched Logic, opened the track inspector and changed MIDI channel from All to 1 expecting that the track would no longer respond to the Panorama keyboard.

 

OK, why is Logic totally ignoring the MIDI channel setting in the track inspector?

 

It's not ignoring it, you are just misunderstanding what it does. When set to "All", all incoming MIDI data on any channel is passed through as is, to the instrument. So it will receive events on MIDI channel 2 and 4, in your case.

 

When set to "1", Logic rechannellises, so all MIDI events on any channel *get converted to MIDI channel 1* on the way to the instrument. No events are filtered. All your channel 2 events will get converted to channel 1 events - and so will your channel 4 events. The instrument will only receive events on channel 1 (with duplicate events, in your case, leading to possibly funky behaviour).

 

*There is an exception to this behaviour in multichannel record mode, if you are in this mode, which might be why you see channel 2 and 4 events still in the event list.

Link to comment
Share on other sites

des99 you have saved my life!

 

I found that at some point I had enabled zones 2 and 4. I will pay a large sum of money to the first person who can guess what channels those zones were assigned to. :wink:

 

Although there is a save button, apparently a number of the settings are memorized without having to be saved...like zones. If no zones are enabled, the keyboard sends over the global channel (1, in my case).

 

Many thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...