Jump to content

Midi Recording Early


Evermore
 Share

Recommended Posts

Hi, I've searched this forum for a fix for the midi-recording-early problem and I haven't found an answer. I'm having no luck figuring it out after researching all evening about this. In fact I've had this problem for years but haven't been able to focus on music so I've let it go. I'm getting back into it thankfully and I'd like to figure this sync problem out. Is this happening for anyone else? I'm not sure how to express what's happening on a technical level so I thought I'd start with the generally phrased question.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

If you're using external instruments for midi, there is a problem within LPX with latency-compensation.

Logic Pro X 10.4.4 - 2 x 3.46ghz 6-core mid-2010 Mac Pro 32GB RAM - MOTU MTP-AV USB-Midi interface x3 - OS 10.13.6 - MOTU PCI-424 / 2408 x 3 to Yamaha DM2000 console - UAD Octo pcie card - Yamaha CP33 keyboard controller - Various sound modules connected via midi/MTP-AV's

Link to comment
Share on other sites

I'm only using a Novation 49 SL MKII midi controller straight into the usb. All midi notes are recorded ahead of the beat. I can't get any setting to have any effect.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

Yes this is a bug. Apple actually contacted me about this in June via email to ask for info after I submitted a bug report, but after I sent them all the info I could, I never heard another word, so I have no idea if they if they are working on it.

 

The main problem is the use of latency-inducing plugins on AUX or OUTPUT channels. LPX handles latency on those types of channels by delaying all other channels to match. Unfortunately, LPX does not correctly auto-delay external midi tracks when there is PDC on AUX or OUTPUT channels. It also does not correctly delay the metronome if midi is being used for the metronome rather then an audio click.

 

The External Instrument, however does correctly handle PDC.

 

So one work around is to not use external midi tracks, always use instruments tracks with the external instrument plugin.

 

don't use the metronome over midi.

 

Another work around is to disable latent plugins on AUX or OUTPUT channels while recording the midi.

OSX 12.x (Monterey) on OpenCore - Logic Pro 10.7.4, VePro7, Mainstage3 - 5,1 MacPro 3.46ghz x 12 96gb ram

Link to comment
Share on other sites

HI Thanks! I'm not using external midi, nor am I recording audio from external synths of anything like that. I'm just plugging my novation keyboard straight into the Mac Pro usb and playing midi notes. If I play along with the metronome all my notes are ahead of the beat consistently.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

I just looked in the transport to get an exact number of how much the timing is early. All my recorded midi notes are roughly 108 ticks ahead of the beat.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

the Logic project is completely empty. And I don't have another keyboard controller to experiment with unfortunately.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

I'm out of ideas for the moment.

 

another thing to try, just to eliminate the novation as the problem, is try to use Reaper or some other DAW and replicate the test.

Edited by Dewdman42

OSX 12.x (Monterey) on OpenCore - Logic Pro 10.7.4, VePro7, Mainstage3 - 5,1 MacPro 3.46ghz x 12 96gb ram

Link to comment
Share on other sites

Wether i use a blank new project or a full one it still happens. I usually use a buffer of 512. With the buffer at 128 the midi still records early. I thought it might have something to do with the USB so I tried it with the caps lock keyboard and it still does it.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

Just to be clear, I had my midi recording early, which would seem to be against the laws of physics. It's due to the latency issue, and only happens with external instruments. You're actually playing it at the right time, but then Logic seems to grab what you played and move it ahead upon playback, even when it doesn't need to. One of the things you can do is in the audio preferences turn off latency compensation for "All" and make it "audio and software instrument tracks." I've found that if you introduce a bus or aux anywhere in your song, the latency gets messed up. It is a real problem and needs to be addressed. We did inform Apple earlier this year, but you might try filing an additional bug report with them, as the more reports they get, the more they might pay attention.

Logic Pro X 10.4.4 - 2 x 3.46ghz 6-core mid-2010 Mac Pro 32GB RAM - MOTU MTP-AV USB-Midi interface x3 - OS 10.13.6 - MOTU PCI-424 / 2408 x 3 to Yamaha DM2000 console - UAD Octo pcie card - Yamaha CP33 keyboard controller - Various sound modules connected via midi/MTP-AV's

Link to comment
Share on other sites

I just did a loopback test with the ping function in the utility I/O plugin and it says I only have a latency offset of +ONE sample. Both my audio and midi are recording ahead of the beat and nothing I can find to do fixes it.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

I know how frustrating this is, and believe me, I'm not trying to be funny, but is there any chance the "beat" you're referring to could somehow be incorrect? When you manually insert notes via the piano roll, etc., do they play correctly with the beat? Is your recording showing up early on the grid of the tracks window or just early upon playback?

Logic Pro X 10.4.4 - 2 x 3.46ghz 6-core mid-2010 Mac Pro 32GB RAM - MOTU MTP-AV USB-Midi interface x3 - OS 10.13.6 - MOTU PCI-424 / 2408 x 3 to Yamaha DM2000 console - UAD Octo pcie card - Yamaha CP33 keyboard controller - Various sound modules connected via midi/MTP-AV's

Link to comment
Share on other sites

I just did a loopback test with the ping function in the utility I/O plugin and it says I only have a latency offset of +ONE sample. Both my audio and midi are recording ahead of the beat and nothing I can find to do fixes it.

 

Both audio and midi are recording early? Ok...something is strange... Can you describe exactly the test you are performing to determine they are both recording early?

OSX 12.x (Monterey) on OpenCore - Logic Pro 10.7.4, VePro7, Mainstage3 - 5,1 MacPro 3.46ghz x 12 96gb ram

Link to comment
Share on other sites

Simply looking at the grid is all I’m doing to determine that the timing is early. I play along with a click or beat that is on time. looking at the grid in the arrange window or piano roll or audio edit window it’s easy to see all notes are placed before the beat lines in the grid.

 

It’s a fast system, I can play guitar or sing through the software without noticeable latency. That part is wonderful. I’ve been doing this since the early 90’s and it great to finally technology fast enough to play through with no latency. What can I be missing? Theoretically it seems more possible to have notes or audio which record late after the beat due to processing time.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

When you hit play does the sound of the click seem to be spot on compared to the visual clock?

 

When you record, LPX by design attempts to calculate where to place audio and midi on the timeline based on what it thinks you heard. It takes into account soundcard latency going in and out.

 

Most midi interfaces these days also have timestamping in the midi interface that should ensure with the above that midi events are registered on the track lining up with what you were hearing when you recorded it.

 

What sound card are you using? And does the click sound off in sync with the visual clock?

OSX 12.x (Monterey) on OpenCore - Logic Pro 10.7.4, VePro7, Mainstage3 - 5,1 MacPro 3.46ghz x 12 96gb ram

Link to comment
Share on other sites

Interface is Apogee Ensemble Thunderbolt.

Click and visual clock are in sync.

Midi is straight out of my novation keyboard into the usb of the Mac Pro.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

If you step-enter a beat so that it lines up with the grid, and then attempt to record with that as opposed to the internal click, what happens?

Logic Pro X 10.4.4 - 2 x 3.46ghz 6-core mid-2010 Mac Pro 32GB RAM - MOTU MTP-AV USB-Midi interface x3 - OS 10.13.6 - MOTU PCI-424 / 2408 x 3 to Yamaha DM2000 console - UAD Octo pcie card - Yamaha CP33 keyboard controller - Various sound modules connected via midi/MTP-AV's

Link to comment
Share on other sites

Have you tried with the built-in audio ? Maybe your Ensemble is reporting the wrong latency to Logic ?
Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
Link to comment
Share on other sites

I’ll try that again. I did a few days ago to no avail but I’ll try it again. I had a brief moment of apparent success after I took the AIC midi driver out of my midi setup (in audio/midi system prefs) but it vanished and reverted back to my current state.

LPX 10.4.1, Mac Pro (Late 2013), 3.7 GHz Quad-Core Intel Xeon E5, Ram:64 GB 1866 MHz DDR3, Storage 1T SSD
Sierra 10.12.3
Apogee Ensemble Thunderbolt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...