Jump to content

region loop problem


mpl

Recommended Posts

Hello

Just recorded some drums, then cut out a 1 bar section and then looped that using the region loop tick box.I noticed as the track plays that the loop slips out of sync.As you can see the region is exactly 1 bar in length yet by bar 472 its way off.Is there some setting that I've not set or is this a bug? It is the same using repeat multiple, see screen shot 2,It increases 1 tick for every 8 bars. If some one could confirm this or deny it that would be useful in my hunt for the cause.

Thanks

mike

1542880115_logic1.thumb.png.81d131f7469b29db741a9fe81dc32adc.png

L2.thumb.png.1c708f2d5093a7b7cc81634742ffac97.png

Link to comment
Share on other sites

If you look close, in the length column in event list, there's a dot following the last digit, meaning it's longer than a bar, but less than a tick longer. I would try change the length in event list to 1 bar exactly and see if that changes anything ? Personally I use the event float, but shouldn't matter which one you use.
Link to comment
Share on other sites

The issue is related to cutting regions when

1/ smart snap is on and you are zoomed in tight and can set the play head between ticks

2/ anytime you cut a region regardless of zoom and you have "snap edits a zero crossing" enabled.

3/ if you have your snap set to (frames, quarter frames or samples).

 

Your regions are not looping correctly because they are not exactly one bar long (as JacobP) indicated.

 

implementing one of the corrections above will stop this from occurring in the future. There are several ways to quickly fix what you have already.

and in your case given each region is one bar long do the following.

 

1/ open the event list ( press the up arrow in the event list to show all the regions if needed).

2/ double click on the length field and enter ( 1, space bar, 0, space bar, 0, space bar, 0 , enter) ( the dot should go away for this entry

3/ hit cmd a - to select all events in the list ( or select them manually - up to you).

4/ hold the shift+ option key down and click on the the entry you just modified - this will make all entries the same.

 

6852836_sampleadjustments.gif.d73c39050d87d9865489056f69ee675f.gif

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...