Jump to content

MIDI Duplicates/Unwanted Recording to Multiple MIDI Channels [SOLVED]


WorshipNerd
 Share

Go to solution Solved by Ohlsen,

Recommended Posts

Hi! I've seen several posts on this, but I have done everything I've seen given as a solution to no avail, so I'm going to ask specifically. When recording a MIDI track, I'm getting duplicate notes (actually near-duplicate--off by a tick) for every note. Here we go:

 

MIDI Controller is a Casio CDP-100 with Local Control turned OFF.

MIDI connection is through MIDI cable only... Keyboard to Interface via MIDI cable, interface to iMac via USB, but no USB connection whatsoever from the keyboard.

MIDI Event List shows I'm recording to multiple channels. This is the problem I assume, but I don't know the fix. I've set my MIDI track to MIDI channel 1 and my keyboard to MIDI channel 1, but still I get these note clones.

 

I've used Logic for a decade-plus, and never had this happen in this way. But I'm using a new iMac and a keyboard I haven't done much (if any) MIDI recording with, so perhaps therein lies the issue somewhere. Any help is most appreciated as I've got deadlines to meet. Thank you!

 

1504865136_ScreenShot2019-01-09at10_35_57AM.png.f8dcbf4ae2a2c1c14f24e0415de06ace.png

 

Logic Pro X 10.4.3

Mac OS 10.13.6 (High Sierra)

Link to comment
Share on other sites

One easy and quick way could be to delete the events from channel 2.

 

To prevent that from happening, you could filter out events from channel 2 to get recorded, using a transformer in the environment.

 

Or perhaps, check in the MIDI Input preferences, you might get a double / undue entry, which could be causing the undue events reaching Logic. In such case, removing the corresponding checkmark should solve the problem.

Edited by Atlas007
Link to comment
Share on other sites

  • 1 year later...
  • 1 year later...

Hi all,

Unfortunately I have the same problem when recording that all events are duplicated, and since my keyboard is old, there's is no possibility for changing the input. I would therefore like to "filter out the channel 2" as proposed, but .... I don't now how and where to do this?

 

I am Using Logic Pro X (10.7.2), Mac mini M1, Steinberg UR44, and any solution would be highly appreciated.. THX!

Link to comment
Share on other sites

Hi all,

Unfortunately I have the same problem when recording that all events are duplicated, and since my keyboard is old, there's is no possibility for changing the input. I would therefore like to "filter out the channel 2" as proposed, but .... I don't now how and where to do this?

 

I am Using Logic Pro X (10.7.2), Mac mini M1, Steinberg UR44, and any solution would be highly appreciated.. THX!

What is your keyboard brand and model?
Link to comment
Share on other sites

Hi fuzzfilth

Thanks a LOT for this very instructive guide :) I wonder if there might be any downside to this solution? Will it limit future possibilities of recording on different channels, or should I rather consider to update my keyboard?

Thanks again, great help and fast response!!

Link to comment
Share on other sites

Thanks a LOT for this very instructive guide :) I wonder if there might be any downside to this solution? Will it limit future possibilities of recording on different channels, or should I rather consider to update my keyboard?

The solution is a band aid solution with no real downside other than having to reproduce it or import it in every single project where you need it (or save a template with that setup inside and start new projects from that template).

 

The best solution would be to figure out if that's the keyboard doing this (have you tried for example what des99 suggested?) or the MIDI interface, and fix the problem at the source. If everything is set up normally, then pressing a key on your keyboard should send a single MIDI Note On event on only one channel (normally MIDI Channel 1).

 

There may be a factory reset procedure for your keyboard? Edit: I found it, try this:

1. Turn off the digital piano

2. While holding down both the (TONE) and (FUNCTION) buttons, press the (POWER) button.

Link to comment
Share on other sites

  • Solution
Thanks again David (and fuzzfilth) , for pointing again on the solution from des99, it turned out that I unknowingly had changed some settings on the keyboard, and now the duplicates ar gone! I'm so greatful for your help, and I hope you don't think you've wasted your time on me, since you at least have saved me a LOT of time! :)
Link to comment
Share on other sites

  • 10 months later...
On 1/17/2022 at 1:49 PM, David Nahmani said:

The solution is a band aid solution with no real downside other than having to reproduce it or import it in every single project where you need it (or save a template with that setup inside and start new projects from that template).

The best solution would be to figure out if that's the keyboard doing this (have you tried for example what des99 suggested?) or the MIDI interface, and fix the problem at the source. If everything is set up normally, then pressing a key on your keyboard should send a single MIDI Note On event on only one channel (normally MIDI Channel 1).

There may be a factory reset procedure for your keyboard? Edit: I found it, try this:

1. Turn off the digital piano

2. While holding down both the (TONE) and (FUNCTION) buttons, press the (POWER) button.

Hi, I also have this issue. My MIDI keyboard is the StudioLogic SL88 Grand. Every note I play is duplicated, resulting in two identical notes in the event list for every one note that I play. The only difference is that one note is in Channel one, the other in Channel two. 
 

I’m able to delete these notes by deleting notes from the same ‘midi channel’. But I want to find the route cause of the issue. My keyboard is directly plugged into my Mac with a USB, just one cable. 
I have read about turning off ‘layers’ and turning off ‘local parameter’ but I’m not sure how to do this on my keyboard? Any help would be greatly appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...