Jump to content

"Point" to already downloaded Logic Sound Library on an external hard drive


plint merrick
 Share

Recommended Posts

Give a look into /Library/Application Support/Logic, personally I moved the whole EXS Factory Samples folder, which in my case is around 10GB, but probably not everything there is strictly "essential".

 

Thanks. Unfortunately my EXS Factory Samples folder is almost 45GB in size. However, when I open Logic on my new partition and it asks me to download the essential sounds, it says the download is 1.69GB, which isn't too bad, so it's probably easier just to do that in this case.

MBP 2018, 2.2Ghz 6 Core Intel i7, 16GB RAM, Logic X 10.6.3, OSX 10.15.7, Focusrite Scarlett 2i2, Komplete 10 Ultimate, Komplete Kontrol S61.
Link to comment
Share on other sites

I wanted to do something similar and for me the easiest and most flexible way is just using symlynks…

 

1) Close logic;

2) Locate what you want to move in the finder and move it to the new location. For example I just moved the EXS Factory Samples 10GB folder in /Library/Application Support/Logic/ to another HD;

3) In the terminal write

ln -s /drop\ here/the\ moved/folder "/path to the original location".

As always in the terminal you either put the path into "quotes" of use backslash\ before\ each\ space.

In my case this was:

ln -s /Volumes/JackBook\ Pro/Supporto/Logic/EXS\ Factory\ Samples /Library/Application\ Support/Logic/EXS Factory\ Samples

4) Open Logic and it will work without knowing the difference from before.

 

With this method you can chose what to move where and actually have a library spanning multiple HDs if you want.

 

Hi jackoverfull. I decided to give this a go, but couldn't get it to work. I was wondering if you might point out the error of my ways? I'm not savvy with using Terminal at all.

 

1. I installed Logic 10.6 on a new partition of my internal SSD, but didn't download any of the extra content, just the essential sounds only.

 

2. The folder containing my full Logic library is on my external HD.

 

3. I opened Terminal and typed 'ln -s'.

 

4. I then dragged the folders into Terminal to copy their paths.

 

5. I pressed return.

 

6. I opened Logic, but all the loops and everything in the Library is pending download.

 

I've attached a screenshot of my Terminal window. I'd be very grateful if you could point out what I have done wrong.

 

Thanks.

 

Edit: I managed to create the symlynk in the original location in /Library/Application Support/Logic/, but when I open Logic, all the loops and presets etc are still showing as pending. I can't load or use anything. Is there another step I need to take?

 

Thanks.

 

2074714808_Screenshot2020-11-29at17_59_34.png.387b118b77d29d760484c6c7c8ebed9f.png

MBP 2018, 2.2Ghz 6 Core Intel i7, 16GB RAM, Logic X 10.6.3, OSX 10.15.7, Focusrite Scarlett 2i2, Komplete 10 Ultimate, Komplete Kontrol S61.
Link to comment
Share on other sites

Can someone who has downloaded all the content upload their “receipt?” That way I can just make logic think I have the content downloaded without having to download 60+gb again. These are the steps I’m trying to do: https://discussions.apple.com/thread/8627088

 

I have downloaded all the content, but how do I know which receipts I need to upload?

MBP 2018, 2.2Ghz 6 Core Intel i7, 16GB RAM, Logic X 10.6.3, OSX 10.15.7, Focusrite Scarlett 2i2, Komplete 10 Ultimate, Komplete Kontrol S61.
Link to comment
Share on other sites

Good point madk0w, same behavior here.

 

I just checked on my laptop that had only downloaded the "Essential sound and instruments". In the Library Manager it still shows that only that portion is installed. Yet the entire content is working on this laptop. This laptop possibly never stored "receipts", acknowledging that it had downloaded the packages.

 

Someone could try the test below to see what happens. I'm chicken to try it because everything is working so well on both macs.

 

Edit: Don't bother with the following test, madk0w found that it doesn't work.

 

  • Check box one of the "uninstalled" library packages and click Install. Logic might then see that this library package is actually installed and quickly update its status to Installed without having to download anything.
     
    If that works then proceed to Check box all the other packages. What might possibly happen is that legitimate receipts from apple might be then be bestowed on your computer.

 

Pure conjecture this. Anyone volunteer to test or even remember where apple puts these "receipts"? I would test, but I have slow internet here. :)

 

Edit: Further notes - madk0w reports in the next post that the above does not work.

- So at this point a simple solution is to only download new content to your master "Library" external drive using only the original computer that actually downloaded the library content. On all other computers you have set up to share this drive, ignore their Library Managers.

 

Hi. Are your apple loops all working? Mine are all showing as 'pending download'.

 

Edit: I forgot I needed to move my apple loops folder to my external HD and then create a symlynk in the Library folder on the Macintosh HD pointing to the apple loops folder on my external HD. I then had to reindex the apple loops and all appears to be well for now.

MBP 2018, 2.2Ghz 6 Core Intel i7, 16GB RAM, Logic X 10.6.3, OSX 10.15.7, Focusrite Scarlett 2i2, Komplete 10 Ultimate, Komplete Kontrol S61.
Link to comment
Share on other sites

  • 1 month later...

Here's something strange.

 

I had already made symbolic links for Library>Audio>Apple Loops and Impulse Responses as well as Library>Application Support>Apple, Garage Band and Logic and everything was hunky dory (awesome).

 

Hard drive crash. Erase, reformat, copy files from back up. Same name, same path.

 

Open Logic ... "The Sound Library directory could not be found" ... Reset:Ignore:Retry

 

Ignore ... ALL INSTRUMENTS AND SOUNDS WORK AND LOOPS ARE INTACT!

 

I reindexed all loops. Still the same message. Made the symbolic links again. Same message.

 

I don't really care because it appears to work but now I won't be able to download any new sounds. GarageBand, same thing. All sounds are there but same message. And it is telling me that there are new sounds to download.

 

Everything is greyed out in Sound Library except for "ReInstall Sound Library".

 

For the love of all things holy ... how do I force this thing to make sense?

 

EDIT:

WOW!! Should have followed this solution before posting: viewtopic.php?f=5&t=143985#p755405 ... it worked! Thanks @helment.

Link to comment
Share on other sites

  • 9 months later...
  • 3 months later...

Similar issue in Logic 10.6.3 on a MBP running Catalina. Logic suddenly couldn't find loops and sounds that are on the ext drive. I started doing @helment work-around but got nervous. The dialog box says Logic wants to move files and asks for computer pw. In Logic Pro dropdown menu, only option offered is to Reinstall Sound Library. Is that going to bring up the window where I can uncheck all but the Reverb Presets? I'm such a newb and this is making my head swim. TIA

 

UPDATE: I got partway thru @helment workaround but was never given the option to selectively download sounds. I renamed and moved, but then I was 'forced' to reinstall the Sound Library. All working fine now EXCEPT that now my Time Machine backup is full as a result and backups keep failing. Is it safe to delete the old renamed sound library? Just drag it to the trash and empty?? Thanks in advance! (in case TIA isn't a known abbreviation. ;)) p.s. screenshot for what it looks like in the external drive location. 377706458_ScreenShot2022-02-06at8_56_41PM.thumb.png.5d7775cbc585e6e1826c5d7fe917b372.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...