Jump to content

Has anyone tried MIDI mapping smart controls?


Recommended Posts

i'm trying to midi learn the parameters and it is stuck in "learn mode", but the knobs aren't affecting the parameter. i've tried learning through the "external assignment", also through "parameter mapping", and also option L to learn host automation. none of them work for smart controls. through host automation, it at least recognizes it in the window and says it is mapped, but the parameters still don't move with the knobs.


Link to comment
Share on other sites

To assign Smart Controls, click the Learn button in the Controller Assignment pane of the Smart Control inspector: https://www.logicprohelp.com/assign-midi-controller-knobs-plugin-logic-pro/

thank you for responding.


I stated above that i've tried mapping that way under "external assignment" and also through "parameter mapping" to no avail. The parameters remain stagnant for some reason even when i am learning it.

Link to comment
Share on other sites

apparently there is a "track lock" feature somewhere in the control surface window which i checked and is already unchecked. This thread is from 2015



Good news, I think I licked this.


I became even more convinced that somehow my control surface assignments were tied to track 1 when, in a last ditch effort, I took track 2 (an electric piano) and drug it above track 1 (a synth pad) in the main window so that the electric piano was now track 1. And, lo and behold, I magically had control of its Smart Control knobs via my keyboard!


So then I went digging for that "Track Lock" function . . . and here's where it was hiding. Go to your Control Surface setup window, then your Control Surface Group window. There's a "Track Lock" checkbox about 3/4ths of the way down the parameter list. NOTE: You may not be able to see it if you have your Device window open too (this is why it took me FOREVER to find it), but if you click to disclosure triangle to close the Device window, you should be able to see all your CS Group parameters.


Long story short, I unchecked the Track Lock checkbox and now everything works great. When track 1 is selected, I control track 1's smart controls. When track 2 is selected, I control its smart controls. Works on any track, any patch.


Thanks for your help, gentlemen. Without your feedback, I'm not sure I would have solved this. I think I just would have had less hair.


Link to comment
Share on other sites

The problem seems to be that you're using one (or multiple) control surface(s) that is(are) already mapped somehow. If that's the case you need to refer to your control surface manual to determine which knobs control the Smart Controls.

I don't know about that, because i clear them constantly through controller assignments..unless you are speaking of templates i've made with my controllers. (or maybe you mean my maschine mk3 controller editor, i don't know) I've also came upon this thread which states it is a bug



Link to comment
Share on other sites

you've confirmed this bug six years ago and it looks like it still isn't fixed



Indeed I did. Completely forgot about that one.

understandable, but frustrating and very unhopeful that it will ever be fixed since it is an issue that persists from over half a decade ago. yay for more carpel tunnel and working in the box meticulously i guess.

Link to comment
Share on other sites

By the way, maybe this is due to the fact that the Smart Controls on the main track of a summing stack can be mapped to the individual subtracks inside the stack. Just guessing.

i know the words you're saying, but don't understand the functionality of what you're saying :(

Link to comment
Share on other sites

Picture two synthesizer tracks, packed into a summing stack so that you can play the layered sound of the sum of the two synthesizers. On the main track of the summing stack, open the Smart Controls and you can map the knobs to plug-ins on the summing channel strip but also on the synth 1 channel strip and plug-ins on the synth 2 channel strip.
Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...