Jump to content

Logic automatically adding flex markers that I don't want!


Recommended Posts

Hello! Whenever I record an audio region and turn Flex Pitch on, Logic automatically adds in a bunch of rhythmic flex markers. These aren't the ones that determine the beginnings and endings of notes—I'm talking about the silly blue markers that appear all over the place; usually multiple of them are placed on a single long note. I understand their purpose, but I do not want them in there. The reason is that whenever I split the region before one of those markers, Logic decides to just delete the rest of the flex note, making me unable to use flex pitch on it. I don't see how automatic unwanted deletion is a useful feature, but that's besides the point. I can prevent this behavior by going into Flex Time - Rhythmic and deleting the automatically added flex markers. Unfortunately, I have to delete the markers one at a time, since the eraser tool doesn't work on the automatically added markers. I record hundreds of audio regions per day, so this repeated deletion really takes some extra time.


Does anybody have any ideas on how to prevent Logic from adding those unnecessary markers? Thanks!!


LPX 10.4.4 (I can't use 10.5.0 because it takes too long to save on my computer)

macOS 10.15.4

Link to comment
Share on other sites

Could you share a screenshot so we can see what you mean exactly? How to attach files to your post


Thanks for your reply. Attached are two images.


In the Flex Pitch - Rhythm image, you can see those blue markers are everywhere in the region to the right. They were added automatically and are entirely unwanted. If you split the region or the note BEFORE one of those markers, then the remainder of the note, i.e. the part that is after that marker gets deleted. This really slows down the workflow, since many times I like to create very long vocal notes by cross-fading a bunch of takes together. The problem is that sometimes I need to trim or split off the beginning of the region. Because of those blue markers, trimming or splitting makes the note-block disappear out of Flex Pitch.


In the Flex Pitch - Pitch image, you can see that, in the region to the left, there is a note-block in Flex Pitch. That's because I went in and manually took out all the blue markers before trimming the clip. But in the region to the right, there is no note-block, even though there is clearly a waveform (and the note I was singing was within a half-step of the previous note, so it's not simply out of the screen). And re-analyzing for flex editing does not work—the note-block only re-appears if you drag out the beginning of the clip to its full length and re-analyze. But again, I want it to be trimmed exactly where I have it, without the note-block being automatically deleted.


Flex Pitch - Rhythm. Unwanted blue markers.


Flex Pitch - Pitch. Note is gone.

Link to comment
Share on other sites

Do you have any tempo changes in this project?


Yes, there are several tempo changes. This particular section is during a slow ritard. I recorded the audio region at exactly the same time-position as it is now, and all I did was drag it vertically down from my REC(AIHU1) track down into the Audio 1 track.

Link to comment
Share on other sites

I believe those are tempo change markers, not Flex markers. See if they match the positions of your tempo changes in the global tracks.


The tempo change is continuous (i.e. the tempo line is sloped). So maybe there's a new marker for every time the tempo goes down by 1?


Either way—if it's not a Flex marker, then how is it that splitting the region or the flex note-block causes the remainder of the flex note-block to disappear? This is the main problem. It seems like Logic just forgets that the rest of the note is there. But when I delete those markers, the problem doesn't happen. I'm fine with Logic not generating tempo change markers at all, since in this project I will never be moving regions horizontally. Wondering if there might be a way to turn them off.

Link to comment
Share on other sites

You can look in your Tempo List to see the individual tempo changes and their exact positions.


Attached is an image. There is a tempo change at the beginning and at the end of the ritard, but not during (which is where all the blue markers are, in every single region).


I don't believe there's a way to turn off the generation of tempo markers.


Ah ok. That is unfortunate. They seem unnecessary to me—I wonder if there couldn't just be a "locking" option where locked regions don't deform with tempo changes, and unlocked regions do. (Obviously an SMPTE lock wouldn't work, since you can't move them around.) Maybe that's harder to program than I could imagine, or just wouldn't work for some reason.


Thanks for your replies.


Link to comment
Share on other sites

Okay so it seems that they are Flex markers, since when I right-click on one to delete it, it gives me the option "Delete Flex Marker".

They're called tempo markers, but I suppose the shortcut menu doesn't make a difference and call them "flex markers".


Tempo markers cannot be moved, they indicate the position of a tempo change and protect the stretching produced by moving a flex marker that's next to them from occurring past their position, much like a flex marker would. Flex markers can be moved to flex (stretch or compress) audio waveforms. They look different, too:







Link to comment
Share on other sites

  • 2 years later...

almost 2023 and I still have the same problem.

A audio region recorded during a tempo change, gets irremovable tempo flex marks, blocks the possibility of correcting the recording through normal flex edits and even - once you turn the flex on - changes the actually recording to something else through the programming of the blue flex marks.

Some help around the bug would be greatly appreciated! thanks

Screenshot 2022-10-26 at 17.25.23.png

Link to comment
Share on other sites

They are flex markers created by smart tempo analysis ( not tempo changes in the tempo event list).

Select the track - Edit -> tempo -> remove original recording tempo. This should eliminate the smart tempo flex markers....   If you have any manual markers - Right click on the region and select reset flex markers.  See below and let us know if that helps.

smart tempo FM.gif

Edited by volovicg
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...