Jump to content

Can't save project

Go to solution Solved by Scorwitz,

Recommended Posts

Help! I've been working on a project I'm loving, but I can't seem to Save As, or Save a Copy, and when I try and close out it asks me if I want to save and I click Save but nothing seems to happen. I can find the file in Finder, but it's not in the usual place.


Reasons as to why... I started this project by opening a downloaded free template. I extracted the Zip file that included the template, sounds, and loops into my Audio Music Apps - Project Templates folder. Opened logic and started new from my templates, and pulled up the one I'd downloaded. Wasn't sure where to put all the rest of the files in the zip, so it downloaded everything I needed, as all sounds came from Logic anyway.


Now I'm in this predicament. Worse comes to worse, I think I should be able to bounce to mp3 and trying recreating. I'm not too far in, but it took a while to get the kicks and rimshots to sound the way I wanted, as well as the bass equalizers.


I realize this isn't much to go on, but wondering if I force quit, will it still be there. (Crystal ball anyone?)

Link to comment
Share on other sites

Open it, do a Save As, and *choose somewhere where you know it's going to be saved*. Make sure you include assets, then go to the Finder and find the file - check it's last modified date/time if necessary.


When you press save and say "nothing seems to happen" - what do expect to happen? Fireworks? :) The file should be saved. If it can't be saved (eg, permissions problem) you'll get an error. But just because you don't see the bits being written to disk doesn't mean nothing's happening.


I wonder if you're saving to somewhere else, and then reopening the wrong file that wasn't your saved version, perhaps.

Link to comment
Share on other sites

No. I haven't closed yet. I'm sitting here with it open cause I'm afraid to lose it. Literally 'nothing' happens. Like I'm not prompted to save as a new name, or a new location, none of the normal anything.


The only indication that anything is saved is there is an "Untitled - 2 Tracks" file in Finder when I ask to 'locate in finder'. If all that other stuff was happening I don't think I'd be having an issue

Link to comment
Share on other sites

Yes, it's there while the project is open. So far when I go to quit, it tells me if I don't save it will be deleted, and when I click save, again, nothing happens.


Is there a way to easily copy the tracks, with their instruments, and settings from the window of one project to a new one that I've opened from a template that I know I can save?

Link to comment
Share on other sites

  • Solution
Oh wow. I won't explain everything I just did, but it worked! After a force quite, I only had to find one .bmp and Spotlight found it, and I opened it, and was able to Save As, and the file structure in my Logic folder looks normal. Thanks all!
Link to comment
Share on other sites

Ok I'll try, but I don't want to confused anyone...


So I forced quit Logic, since I couldn't even close the project without cancelling changes.


The free template I downloaded came with:

Songwrite Template Name:

- Songwriter Instruments

- Samples

- Impulse Responses

- Freeze Files

- Audio Files


I saved just the .logicx file to ~/Music/Audio Music Apps/Project Templates/ as I researched online.


I guess I should have saved the whole template folder there, but that didn't seem right to me at the time since the templates folder only has .logicx files in it.


I guess later, my project saved to the normal place, and maybe some of the new things I did after having opened the template, but not everything. So I cross-referenced all the folders, samples, etc... that should have been in there with what was in there, and made sure it was whole, and that it was all in the Logic folder as if it were saved as a folder anyway.


Once it was time to open it up again, I crossed my fingers and prayed, and it only couldn't find the one .bmp file, which I located, and it opened!


Tried the Save As - Rename and it's in the right place now :)

Link to comment
Share on other sites

  • 2 years later...
  • 3 weeks later...
On 2/4/2023 at 4:42 PM, Rambird said:

I had the same issue today, just wanted to add what I did so maybe someone doesn't panic. Sent myself the session via email directly from logic, then rebooted Mac (m1). Gone.

“Gone”?, as in your project is gone?

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

The email share is the solution !!!!!!!

I just had a 2 1/2 hour session of work before running into this same issue, and then a 1 1/2 hour stress session of trying find a way to get this thing saved before the pressure-filled moment of closing the open project. DAMN!!! Glad I found this.

Cheers to this thread.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...