Jump to content

Midi bluetooth not working right


Recommended Posts

Mac: Macbook Pro 2018

OS: 10.15.5

Logic Pro X: 10.5.1

Device: Korg Nanokey Studio Midi Keyboard

 

Hello, When connecting via bluetooth midi in the Bluetooth config area, the device (keyboard) gets detected and within seconds disconnects itself and grays out. I've turned the device on and off and I'm still getting the same results. Also, when the device is connected for the brief seconds Logic Pro does show a pop up notification that it reads it. Is this a Mac OS issue?? Requesting assistants.

293196649_ScreenShot2020-06-23at10_35_36PM.thumb.png.3f562c7deca01dc0ca4ca40e4105f344.png

1575938971_ScreenShot2020-06-23at10_35_16PM.thumb.png.193b5d2b8133c8bc443dae3e07e19f2f.png

806294617_ScreenShot2020-06-23at10_34_56PM.thumb.png.1a1aef4a5cccf3bac8442e52a5a7e6df.png

309257094_ScreenShot2020-06-23at10_34_37PM.thumb.png.b339c57bb9fb3095f2cd00e425942ab0.png

Link to comment
Share on other sites

  • 2 weeks later...
On your last picture, it looks like that your nanoKey Studio is actually connected...

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

  • 1 month later...

There's a known issue between Korg's Bluetooth devices and Logic Pro X. I bet if you close LPX, turn off the bluetooth, then load GarageBand and reconnect, all will be fine.

Some have had good luck by updating the firmware. Right now for myself I get about a 50% success rate with my Mac that runs Mojave, and 0% with my mac running Catalina.

Good luck... and if you find a solution, please post it here!

iMac i5 3.8 GHz - 64 GB RAM | Catalina 10.15.7 | LPX 10.5.1
MacBook Pro i9 2.9 GHz - 32 GB RAM | Catalina 10.15.6 | LPX 10.5.1
Focusrite Solo, 18i8 | Roland A49, A88 | Korg KeyAIR 25 & 37, nanoKEY Studio BT | Akai MPK Mini 2 | Arturia Keylab 61 mkII, KeyStep, Minilab mkII

Link to comment
Share on other sites

I think that Catalina is more strict regarding permissions...

Also it won't run non 64bits apps/code

LogicPro 10.7.4, MainStage 3.6,
MBPro 17", Core2Duo, 8G, OSX 10.12.6, MacPro, Xeon 6Cores, 64GB, OSX 10.16.1,
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII, Several vintage gear
AAS, NI, Celemony, Spectrasonics, Korg, Arturia, etc..., PC, iPadPro 5th gen 12.9”(Duet D., V-Control & LogicRemote), AtariST(Notator SL),

Link to comment
Share on other sites

I think that Catalina is more strict regarding permissions...

Also it won't run non 64bits apps/code

Oh, you are certainly right on both counts! Not sure how that would cause my Korg keyAIR2 25 and 37 to work fine in GarageBand but fail on loading Logic Pro X, though.

I've fully updated my drivers and have followed all the Internet Wisdom I could find but still no consistent success. On both machines, I use the keyboards with GarageBand no problem, but as soon as I load LPX, the keyboards (usually) stop working.

iMac i5 3.8 GHz - 64 GB RAM | Catalina 10.15.7 | LPX 10.5.1
MacBook Pro i9 2.9 GHz - 32 GB RAM | Catalina 10.15.6 | LPX 10.5.1
Focusrite Solo, 18i8 | Roland A49, A88 | Korg KeyAIR 25 & 37, nanoKEY Studio BT | Akai MPK Mini 2 | Arturia Keylab 61 mkII, KeyStep, Minilab mkII

Link to comment
Share on other sites

  • 8 months later...

Hello,

I have this exact same issue with a macbook pro 2019 on Big Sur.

I used to have a Macbook pro 2016 until last year and had no issue.

The frustrating thing here is that it happens that the keyboard stay connected. Well, it happened I think twice after trying dozen of times.

Most of the time, it connects, then as OP issue just disconnect and lose visibility from the bluetooth Midi Device's devices list.

Last time I tried, with Logic Pro X closed, I connected the keyboard, it stayed connected, and as soon as I opened Logic Pro X it disconnected.

Any discovery since the last comment here?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...