Jump to content

Latency Issues with Catalina


Gerwinius
 Share

Recommended Posts

Hi there,

 

I am about to go nuts... Just set up my new interface (Roland Rubix 44), after my old MOTU UL mk3 wouldn´t work under Catalina anymore (Yes, I checked all the drivers, firmware - but it simply didn´t work, causing horrible distortions and delays, even MOTU told me, that they weren´t aware of problems with the new drivers. Sold it then, the new owner didn´t report issues, anyways...)

 

Honestly, I wish there was a way to downgrade to Mojave and LPX 10.4.8 where all worked fine, unfortunately, I had no choice, as the new mac shipped with 10.15 on it.

IF ANYBODY knows a workaround to downgrade both, LPX and Catalina -- PLEASE tell me how. Maybe someone just has a blank Copy to submit, as Apple fights downgrades, and my backup-system even for the old mac doesn´t work because of another issue with TimeCapsule... So that would be highly appreciated!!!

 

Now back to the subject: I compared the same setup (user template: plugin chains, buffer size (128, wich works perfect on the old system), same routing, not too much of load:

*2 Instances of NI Maschine 2

*2 Instances of Komplete Kontrol Stereo Plugin

*3 Live-Mic Inputs, routed to one singel Bus with a little bit of Reverb

*One Rec-Track for the Machine PlugIn, just with a limiter

*One Aux Channel with the internal Mastering-Template of LPX (HipHop-Wide), routed to two Output with a send

 

Here is the thing: I upgraded to a new Mac because of a significant Improvement of CPU-Power. My old Mac works fine (I really love the 2014/2015 series) but as soon as the Maschine-Files get heavier, it starts to reach its limits. For small Projects it still works great, but it gets quite busy and the fans drive up loudly. I simply wanted to work in a decent cpu-load, avoiding the system to sweat. Also, I wanted a decent machine reserved for music production and live-performance only.

 

In Catalina, testing the new gear today, I experienced unacceptable delay, I can´t tell how much it actually is, as roundtrip is displayed on both systems in the audio-settings at about 11 ms, about 5ms at the outputs.

On High Sierra and my 2014 MBPro I don´t get this disturbing delay which kicks me out of the musical flow. It is way too much, comparable as if I had set the buffer size to like 512 or even more samples. Same gear, same settings like day and night.

How can that be?? Anyone having the same issues on Catalina?

 

Thanks!

Link to comment
Share on other sites

have you given the mic permission in system preferences>security? something's up, because i've been on catalina since the betas, and don't have that issue. i know this is a new mac, but you could always try resetting nvram, and the smc.

 

try creating a test admin account, and running logic there. same issue?

 

others here may have suggestions; what you're experiencing is something specific to your setup, not about catalina in general. am sure you'll sort it out...

Link to comment
Share on other sites

Hi fisherking, thanks for the reply :-) After consulting Apple Support, I´ve been advised to reset nvram and smc, which I did. Systempreferences are also checked with the mic (funny thing, though) -- I somewhere in the forums read about an internet-connecter that had interfered -- that seems very odd and distant, but my mac has some kind of "bad wifi-days" - namely, there are literally days, where it sees the wifi and my hotspot, but can´t connect to it. My old mac, sitting next to it, can, though. Restart doesn´t make a difference. Maybe there is a hardware issue? idk...

 

I will try to create a test admin account and check...

thank you!

Link to comment
Share on other sites

Did you create a new user on the new Mac or did you migrate your original user acct from your old Mac? I bought a new iMac (came with Catalina, of course) and imported my User which was running under Mojave. It generated a mess. I wiped the new iMac clean and started from scratch, including a new user acct. The only problems I experienced after that came from 3rd party plugins that weren't ready for Catalina. I've thinned that herd considerably.

 

Jim

Link to comment
Share on other sites

fisherking! You saved more than my day :-)

I did as you said and it worked! I still have no idea, why that issue occurred on my main account, but yes, that´s how it is. Now I would like to understand what caused Logic to malfunction, because the other account still uses the same ressources, like the installed copy of logic...

I didn´t install all the Native Instruments Libraries, I am curious if that will work...

 

Maybe I will just delete Logic and install it anew. Maybe it was somehow interrupted when it wanted to download content due to my wifi-connection issues.

 

What would you recommend? A complete new install from the scratch? Doesn´t seem obvious to me, as Catalina really doesn´t seem to be the problem, which is great in the first place...

 

Thanks again, for this great advice! If anybody has an idea, how this came to happen, still would be very appreciated!

Link to comment
Share on other sites

@ Jim

Thanks for asking ... no, I didn´t migrate any of previous configs or data, I did a complete an clean install with all the original installer and procedures. Maybe because of that, I didn´t question that until fisherkings hint with the new user account. I really was concerned and pre-occupied by all the issues I found during research about catalina. Then, a few things were confusing, starting with the weird behaviour of my old audio interface. Next, I got into multicore-issues with NI, because Maschine seemed to use just one core, which was far too soon overloading. That was tricky, too, because one instance of the NI third party plugin seems to focus on just one core, but after the reset of nvram, it worked on multicore like it´s supposed to. Especially, when you put other ressources to work in LP, it does its job well.

 

Also, I found many threads adressing same problems with multicore-support/use on a lot of older systems, leading to question if the new mac intel i9 achitecture would make sense at all due to multicore support by NI... quite difficult, if something doesn´t work, as there are so many possibilities.

 

I will try to make it work in the new account to sort it out before I mark this as solved. But I am optimistic now :-)

 

Gerwinius

Link to comment
Share on other sites

Solved! I take this on me, dear Community.... normally, when you´re facing a problem, you should start checking first things first. Even if it was a confusing entrance into that very simple issue -- as it turned out to be -- the problem was my preoccupation in the first place. I should have re-initialised LPX, as this is the most simple thing to do and doesn´t even take time. I never did that before, simply, because I never had to, so I didn´t even know about this function. But that solved it-- Logic must have screwed somethin during installation, and even when I upgraded after first issues with my previous MOTU Ultralite Hybrid Mk3 from 10.5. to 10.5.1 -- that should have done the job... Anyways -- if one of the many things I´ve learned trying to solve that issue -- it´s most likely: even if there seems to be a complex issue, start with the simple things :-) And check the assumptions, even if they seem settled. Sorry Apple, sorry NI, all great and works now as it should :-)

 

Thanks again and happy musicmaking!

 

Love, Gerwinius

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...