Jump to content

Enabling Flex Edit throws all timing of imported audio files


HasseFX
 Share

Go to solution Solved by David Nahmani,

Recommended Posts

Maybe something basic I've missed but...

 

Background: I created a song, containing a hundred or so tempo changes (tempo from live drummer), from which I made WAV stems and sent to the singer. He returned his vocals as WAV-files which I imported with no issues.

 

Problem: I need to do some temporal adjustments on the imported vocal tracks! But those WAV files are recorded using the stem files as reference, at some fixed tempo. They play back fine, but as as soon as I enable Flex Time, Logic X "adjusts" the timing according to the project tempo changes and the timing gets completely off.

 

FIxes: IDK... I can turn off the Flex & Follow for a region, but then Flex Time is also disabled. I can manually circumvent by chopping up the vocal tracks into parts and manually reset the timing affected by the tempo changes, feasible but tedious.

 

Question: Is there a way to be able to Flex Edit a track, without the automatic tempo adaption happening? Or a smoother way to get around the problem?

 

Thanks /HasseFX

Link to comment
Share on other sites

  • Solution

If enabling Flex alone changes the audio region's timing that means that the audio file don't have the correct tempo data embedded. This happens if you imported the audio files from another project, or created tempo changes in the project after you had recorded the audio files.

 

So disable Flex, and if you're happy with the way the audio files playback at the current project tempo, select the audio regions and choose Edit > Tempo > Write Project Tempo to Audio Files. Now enable Flex. The audio regions should stay put.

Link to comment
Share on other sites

So disable Flex, and if you're happy with the way the audio files playback at the current project tempo, select the audio regions and choose Edit > Tempo > Write Project Tempo to Audio Files. Now enable Flex. The audio regions should stay put.

 

Yes, that is exactly function I was looking for, intended just for this kind of situation! Thanks!

 

An alternative I discovered meanwhile is to do a Bounce-in-Place of the imported regions before applying Flex, which creates a new audio file with the project tempo written. Useful maybe in the case when you chop up an audio file in several regions, some that you do want to adapt to the project tempo, while others should not.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...