Jump to content

low latency, possible midi clock


David88
 Share

Recommended Posts

Hey guys, using LLM with midi is acting pretty strange, looking for a solution to some hard to google problems.

 

so far it is doing these things:

 

LLM pulls midi written onto to the grid forward and out of time ahead of the beat, but the midi plays back fine when its off.

 

When recording midi, the data shows up really late on the grid no matter what. When I turn LLM on it will play where I played it, but the recorded data shows up by what sounds the same amount as original latency with LLM off.

 

Any guesses?

 

So far I have followed the logic pro help guide on midi sync to no avail, which included changing MTC modes.

Done the obvious restarting the app, refreshing audio settings.

 

running latest 10.5.1 on a 15in 2017 mbp

Link to comment
Share on other sites

Unfortunately adjusting/disabling that didn't do much of anything. The issue persists, I also find it strange that it only affects midi tracks. Its no fun with this thing :(

 

Should also mention I've tried buffer sizes and all the usual latency remedies.

Link to comment
Share on other sites

Sorry David I should have typed removed as pr your suggestion, what I actually did was start a clean project and only put one midi track in it with no plugins. My guess is either some global setting I'm missing, or something up with the audio on my machine.

 

Yes I'm using EZdrummer with a roland drumset going through usb directly into a macbook.

Link to comment
Share on other sites

Sorry David I should have typed removed as pr your suggestion, what I actually did was start a clean project and only put one midi track in it with no plugins. My guess is either some global setting I'm missing, or something up with the audio on my machine.

Gotcha, so that wasn't it then. Let's answer Jakob's test before we go any further.

Link to comment
Share on other sites

Are you monitoring the drums through its sound module ? If so, try disable software monitoring in Logics audio preferences and see if that changes anything ?

 

I am monitoring out of the built in headphone port, logic is sending to an aggregate device with headphones and an audio capture. I have tested without the audio cap just using built in and built out as Apple support recommended with no difference. Toggling software monitoring didnt affect the issue eithee.

 

signal chain is drum module->usb/midi cable->macbook/logic->headphones

 

It is better with just the one track going on but not usable as it was a month ago, I've also noticed that occasionally i'll get a pop and latency will increase on audio tracks, regardless of whether LLM is engaged or not. This is likely a separate issue, but made me think it might be something global with clock source or something.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...