Jump to content

Logic crashing on loading plugins screen, not responding after opening project, crashing when creating instrument track


jaronm
 Share

Recommended Posts

Hi all, glad to be a member of LPH. Have been a long-time browser of the forums for basic troubleshooting and issues, but i've now encountered an issue that is beyond me and has me in it's grips with frustration, confusion and anger.

 

This problem started when I had a random crash of Logic (I can't remember exactly what was done to cause the crash — this happened 4 days ago and I've done a lot of things to try and alleviate the problem since then). The crash wasn't out of the ordinary; sometimes Logic would crash and I would have to force quit and resort to the auto-saved session — no drama. Although, this time after crashing, it seemed that Logic would get stuck on the opening screen when it's trying to load the plugins. I tried opening a few different sessions and it seemed to get stuck on different plugins across different sessions, a couple of those plugins I remember being FabFilter Pro Q3 and the stock Logic Gain plugin. I've had this happen before, and I seemed to be able to troubleshoot that issue by deleting Logic prefs from the Preferences folder in my Library. This time, though, that was not the case. I have tried almost everything that I could find upon searching the forums (deleting Logic prefs, opening without Core Audio engaged, opening Logic with Ctrl+Shift to disable non-responsive AU plugins).

 

I tried all this and nothing would work, so I took the harder route and reformatted my whole MacBook, after which, Logic was able to open older sessions. After reinstalling some plugins, it seems that the problem came back. Now, Logic does a few things. If I launch normally, it will get stuck on the "loading plugins" bar. If I launch holding Ctrl, it will prompt me to load without Core Audio engaged, to which I will select "without Core Audio", after which it seems as if it's about to open my session window, but will then become unresponsive, forcing me to force quit. If I launch holding Ctrl+Shift, it will launch but be unresponsive, again forcing me to force quit LPX. I've even tried disconnecting my main external SSD (where my Native Instruments content and all of my project files live), and launching a session from my desktop, alleviating the possibility that something is corrupted on my SSD, still to no avail.

 

I am able to open a blank session with no trouble, but if I try to create a new software instrument, it gives me the spinning beachball indefinitely, forcing me to once again force quit LPX. The confusing part is that before I had the initial crash 4 days ago, all of my installed plugins had been working perfectly with no hiccup. I upgraded to the newest version of Logic around the time it was released (the version with the new sampler), but that was obviously well before I ran into this issue. Unfortunately, I can't even post a crashlog, as the app becomes unresponsive and causes me to force quit.

 

Any help would be greatly appreciated, as this has been going on for almost a week and besides stopping me from earning money, is driving me crazy and making me want to throw my computer at the ground!

 

Thanks a lot.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...